help.lst

OWEN Logic

Среда программирования OWEN Logic

Руководство пользователя

Версия 11

2018


Назначение

Программное обеспечение (ПО) OWEN Logic – среда программирования, предназначенная для создания алгоритмов работы коммутационных приборов, относящихся к классу программируемых реле (ПР), в частности, приборов серии ПР1хх, ПР200 производства ПО ОВЕН. Для составления программы используется визуальный язык на основе графических блоков (FBD), применяемых в цифровых электрических схемах.

Эти приборы применяются для построения автоматизированных систем управления, а также для замены релейных систем защиты и контроля. При использовании ПР требуется меньше переключающих устройств для решения ряда задач малой автоматизации, что снижает затраты на проектирование и изготовление систем, а также повышает их надежность.

Перечень приборов, для программирования которых может использоваться программа, доступен на сайте производителя.


Основные характеристики

Программное обеспечение OWEN Logic позволяет пользователю разработать коммутационную программу по собственному алгоритму с последующей записью ее в энергонезависимую память прибора.

Одновременно среда программирования может работать только с одним проектом. При создании проекта не требуется подключения ПР.

Последовательность операций при разработке проекта следующая:

1) установка среды программирования OWEN Logic на ПК;

2) запуск среды программирования;

3) создание нового проекта (для конкретной модели ПР) или открытие существующего проекта для редактирования;

4) сохранение проекта на жестком диске ПК;

5) отладка проекта в режиме симуляции;

6) загрузка проекта в ПР.

Разработка коммутационной программы в среде программирования ведется с помощью графического языка программирования FBD.


Требования к системе

Среда программирования OWEN Logic работает на ПК под управлением операционных систем (ОС) MS Windows версии XP и выше. Для её работы должна быть предустановленна среда ".NET Framework 4.0". При отсутствии среды .NET Framework запрос на его установку появляется автоматически.

Минимальные и рекомендуемые требования к персональному компьютеру определяются требованиями к среде ".NET Framework 4.0" - см. соответствующий раздел в документации https://msdn.microsoft.com.


Принцип выполнения коммутационной программы

Коммутационная программа для ПР составляется с учетом количества имеющихся у него входов, выходов и наличия часов реального времени.

Функциональная схема работы ПР:

Работу ПР можно представить в виде последовательно выполняемых шагов:

Шаг 1 – логическое состояние входов автоматически записывается в ячейки памяти входов (количество ячеек равно числу входов, например, I1,…, I8).

Шаг 2 – коммутационная программа считывает значения из ячеек памяти входов и выполняет над ними логические операции в соответствии со схемой.

Шаг 3 – после обработки всей коммутационной программы производится запись результатов на физические выходы ПР (для включения выходных элементов Q1, …, Q4).

Шаг N – переход на Шаг 1 (после выполнения всех предыдущих шагов обработки коммутационной программы цикл работы ПР повторяется с первого шага).

Время выполнения всех шагов называется рабочим циклом ПР и зависит от сложности алгоритма коммутационной программы.


Аббревиатуры и термины

Аббревиатуры и термины, используемые в тексте руководства:

ОWEN Logic | Cреда программирования, разработанная компанией ОВЕН
FBD (Function Block Diagram) | Графический язык (диаграмм функциональных блоков) для визуального программирования.
Коммутационная программа, проект | Коммутационная программа, созданная пользователем в среде программирования программы OWEN Logic для последующей записи в ПР
Логический сигнал («сигнал») | Дискретная физическая величина (напряжение или ток), принимающая только два значения: включено – соответствует логической «1» (лог. «1»), и отключено – логическому «0» (лог. «0»)
Макрос | Функциональный блок, разработанный пользователем
ПК | Персональный компьютер
ПО, программа | Программное обеспечение
ПР | Программируемое реле
Прибор | Программируемое устройство, например программируемое реле ПР110
Преобразователь | Устройство, через которое ПР подключается к ПК
Уставка | Заданное значение параметра функционального блока (установленный режим)
Функциональный блок | Структурная единица программы, которая после выполнения выдает одно или более значений. Может быть создано множество поименованных экземпляров (копий) функционального блока
Функция | Структурная единица программы, которая после выполнения выдает только один элемент данных, который рассматривается как результат. Функция не хранит информацию о своем внутреннем состоянии, то есть вызов функции с одними и теми же фактическими параметрами выдает то же значение
Холст, схема | Поле для размещения экземпляров графических компонентов проекта и редактирования соединительных цепей между ними
Цикл | Время выполнения ПР заданной коммутационной программы (зависит от количества выполняемых операций в программных цепях)


Быстрый старт

В данном разделе на примере простых задач поясняется, каким образом составляются управляющие коммутационные программы в среде программирования OWEN Logic.

Включатель света с автоматическим отключением

Автоматическое управление электромотором мешалки


Включатель света с автоматическим отключением

В подсобных помещениях и коридорах электрический свет нужен ограниченное время.

После включения освещения, его нередко забывают отключить, что приводит к излишнему расходу электроэнергии.

Задача обеспечить включение света на заданный интервал времени, например, у входной двери в квартиру, по следующему алгоритму:

  1. перед входной дверью установлен датчик освещения (F1) и кнопка включения света ТАЙМЕР (SB1);
  2. при кратковременном нажатии на кнопку ТАЙМЕР при недостаточном естественном освещении светильник должен включаться на интервал времени 1 мин – этого времени достаточно, чтобы найти замочную скважину и ключом открыть дверь;
  3. при удерживании нажатой кнопки ТАЙМЕР в течение 2 с светильник должен включаться на интервал времени 3 мин независимо от внешнего освещения – этот режим может потребоваться при уборке коридора;
  4. предусмотреть возможность управления работой светильника по командам от внешних управляющих устройств или при помощи включателя СВЕТ (SA1), независимо от внешнего освещения. Этот режим удобен во время приема гостей или для дальнейшей автоматизации квартиры в рамках программы «умный дом»;
  5. предусмотреть возможность включения светильника только в вечернее и ночное время.

Выбор программируемого прибора

Для реализации данной задачи управляющий автомат должен иметь встроенные часы реального времени, три входа и один выход, что обеспечивают приборы из серии ПР110, имеющие последнюю букву «Ч» в обозначении.

При выполнении автоматики на основе ПР110-24.8Д.4Р-Ч можно воспользоваться схемой:

Электрическая схема подключения ПР, SA1 - переключатель OFF-ОN; SB1 - кнопка без фиксации OFF-ОN; HL1 - световая лампа

Создание коммутационной программы

На этапе планирования составляется схема реализации поставленной задачи на основе логических элементов и функциональных блоков, доступных в программе

Схема может иметь вид:

Схема электрическая принципиальная для управляющей программы «Свет_Logic»

Выход Q2 схемы используется как контрольный для проверки функционирования логической части (элементов D1–D6). Выход Q1 является основным и может включиться только в заданные таймером D7 интервалы времени при соблюдении логических условий, обеспечиваемых элементами D1– D6.

Описание работы схемы:

  1. При кратковременном (менее 2 с) нажатии на кнопку ТАЙМЕР (SB1), логическая «1» поступает на вход логического элемента И (D2). Так как на втором входе D2 также присутствует логическая «1», на выходе D2 появится логическая «1», которая запустит формирователь импульса (D3) длительностью 1 мин. Этот импульс через элемент ИЛИ (D6) поступит на выход Q2.
  2. Контакты датчика F1 замыкают цепь только при хорошем естественном освещении – в этом случае логическая «1» на входе D1 преобразуется в логический «0» на выходе и поступает на вход логического элемента И (D2), что блокирует работу D2. При этом нажатие кнопки ТАЙМЕР не включит выход Q2.
  3. При удержании нажатой кнопки ТАЙМЕР более 2 с, на выходе блока D4 появится логическая «1», которая запустит формирователь импульса (D5) длительностью 3 мин. Этот импульс через элемент ИЛИ (D6) поступит на выход Q2 (интервал действия импульса не зависит от состояния датчика F1).
  4. При включении тумблера «СВЕТ» (SA1) логическая «1» через элемент ИЛИ (D6) поступит на выход Q2 (на время включения SA1).
  5. Сигнал логическая «1» с выхода Q2 поступает на вход логического элемента И (D8), а если на второй вход этого элемента также поступает логическая «1» (от таймера реального времени D7) – на выходе Q1 появится логическая «1» (выходное реле Q1 включится).

Программа, обеспечивающая работу ПР:

Управляющая программа «Свет_Logic» на основе ФБ программы OWEN Logic (с открытой вкладкой свойств для блока CLOCKW1)


Автоматическое управление электромотором мешалки

При производстве пищевых продуктов часто требуется перемешивать компоненты (например, молоко или сливки на молочной ферме) в течение определенного времени.

Задача обеспечить работу установки по следующему алгоритму:

  1. необходимы два режима работы: «Автоматический» и «Ручной», переключаемых тумблером «РЕЖИМ» (SA1);
  2. в режиме «Автоматический», при включении оператором установки кнопкой ПУСК (SB1), производится автоматическое включение и отключение электромотора через заданные интервалы времени (15 с – включен, 10 с – отключен). Отключение установки производится через интервал 5 мин или оператором при помощи кнопки СТОП (SB2);
  3. в режиме «Ручной» производится прямое управление работой электромотора от кнопок ПУСК и СТОП (без временных интервалов отключения);
  4. при перегрузке электромотора (на котором устанавливается соответствующий датчик – F1) должно срабатывать автоматическое отключение установки с индикацией режима «Неисправность» лампой (HL1) и звуковым прерывистым сигналом (интервал повторения звукового сигнала 3 с);
  5. звуковой сигнал должен отключаться кнопкой СБРОС (SB3);
  6. с помощью кнопки КОНТРОЛЬ (SB4) проверяется исправность элементов сигнализации – работа лампы и звукового сигнала.

Выбор программируемого прибора

Для реализации данной задачи управляющий прибор должен иметь шесть входов (по числу управляющих сигналов) и три выхода, что обеспечивает любая модель прибора из серии ПР110.

При выполнении автоматики на основе ПР110-24.8Д.4Р можно воспользоваться схемой:

Электрическая схема подключения ПР, где SA1 – переключатель OFF-ОN; SB1–SB4 – кнопки без фиксации OFF-ОN; M1 – электромотор; HA1 – звонок; HL1 – индикаторная лампа.

Работу программы прибора можно представить в виде цепей схемы, приведенной ниже, (выходы Q1–Q3 соответствуют двум контактам клеммника ПР).

Описание работы схемы

Цепь входа I2 (включение установки): при нажатии кнопки ПУСК (SB1) на входе S (D1) появляется логическая «1» – на выходе RS-триггера D1 установится логическая «1». Этот сигнал поступает дальше, в зависимости от состояния включателя SA1:

  • при разомкнутых контактах SA1 (РЕЖИМ – Ручной), логическая «1» проходит через элементы D8, D9 и поступает на выход Q1 (контактами выходного реле электромотор М1 включится);
  • при замкнутых контактах SA1 (РЕЖИМ – Автоматический), логическая «1» проходит только через элемент D3 для запуска работы блоков D4, D5.

Цепь входа I3 (отключение установки): при нажатии кнопки СТОП (SB2) или срабатывании датчика F1 на входе R (D1) появляется логическая «1» – на выходе RS-триггера (D1) установится логический «0» (включение выхода Q1 блокируется).

Цепь входа I1 (формирование интервалов работы электромотора): при включенном триггере D1 и замкнутых контактах включателя SA1 (РЕЖИМ – Автоматический):

  • Сигнал логическая «1» от SA1 проходит через элемент D3 и поступает на D4 (формирователь импульса с задержкой 5 мин). Этот импульс, проходя через элемент ИЛИ (D2), поступит на вход R триггера D1 – установка отключится.
  • Сигнал логическая «1» с выхода D3 поступает на D5 – генератор импульсов с параметрами: логическая «1» – 15 с, логический «0» – 10 с. Эти импульсы c выхода генератора проходят через элемент ИЛИ (D8) и поступают на выход Q1 для управления работой электромотора M1.
  • При разомкнутых контактах включателя SA1 (РЕЖИМ – Ручной) логический элемент D3 заблокирован и сигнал с выхода триггера D1 через элемент D6 сразу поступает на выход Q1, т. е. в этом режиме состояние выхода триггера непосредственно управляет работой электромотора M1.

Цепь входа I6 (включение звуковой сигнализации): при срабатывании датчика F1 на входе S (D9) появляется логическая «1» – на выходе RS-триггера D9 установится логическая «1», которая включает генератор D10 с параметрами: логическая «1» – 3 с, логический «0» – 3 с. Эти импульсы проходят через элемент ИЛИ (D12) и поступают на выход Q2 для управления работой звонка HA1.

Цепь входа I7 (отключение звуковой сигнализации): при нажатии кнопки СБРОС (SB3) на входе R (D9) появляется логическая «1» – на выходе RS-триггера установится логический «0» – генератор D10 отключится.

Цепь входа I8 (контроль работы лампы и звуковой сигнализации): при нажатой кнопке КОНТРОЛЬ (SB4) логическая «1» через элемент ИЛИ (D11) поступает на включение выхода Q3 – лампа HL1 будет непрерывно светиться. Выход Q3 включится также, если контакты датчика F1 замкнуты. При нажатой кнопке КОНТРОЛЬ (SB4) логическая «1» через элемент ИЛИ (D12) поступает на включение выхода Q2 – звонок HA1 будет непрерывно работать.

Коммутационная программа, обеспечивающая работу ПР, будет иметь вид:

Примечания.

  1. Оставшиеся свободные два входа и один выход, при необходимости, можно использовать для введения дополнительных функций. Например, переключать четыре разных интервала длительности автоматической работы электромотора или изменять другие рабочие параметры установки.
  2. Технологический цикл работы установки можно сделать полностью автоматическим, если схему дополнить инкрементным счетчиком (CT), выходным сигналом которого можно выключать триггер D1.


Описание интерфейса

После запуска ПО OWEN Logic на мониторе открывается Главное окно программы:

Главное окно программы содержит:

  • заголовок окна (верхняя строка с названием программы): после создания проекта в заголовке автоматически выводится путь к файлу проекта;
  • главное меню программы: Файл, Вид, Прибор, Сервис, Помощь;
  • панели инструментов для быстрого вызова часто используемых действий;
  • панели Библиотека компонентов и Свойства (до открытия проекта в них нет информации);
  • рабочую область проекта - поле редактирования создаваемой коммутационной программы (до открытия проекта пустое);
  • статусную строку внизу главного окна, показывающую состояние программы OWEN Logic и наличие подключения к ней ПР.

Панели инструментов

Для удобства пользования программой основные функции главного меню вынесены на панели в виде пиктограмм.

Панель инструментов

Новый проект | Открывает новый проект. Текущий проект при этом закрывается.
Открыть проект | Открывает для редактирования ранее созданный и сохраненный проект.
Сохранить проект | Сохраняет текущий проект в файле (кнопка неактивна, пока проект не создан). При первом сохранении вызывает окно для присвоения имени файлу.
Печать | Отправка открытой схемы проекта на печать.
Копировать | Копирование выделенного в рабочей области элемента.
Вставить | Вставка скопированного элемента.
Отменить | Отмена последнего действия в проекте.
Восстановить | Повтор отмененного действия.
Записать программу в прибор | Запускает процедуру записи созданного проекта в ПР.
Информация | Вызывает информационное окно с версией программного обеспечения в ПР и целевом назначении проекта (модели ПР, для которой разработан проект).
Таблица переменных | Открывает таблицу для добавления переменных в проект.

Панель отладки

Режим симулятора | запуск режима моделирования работы коммутационной программы.
Порядок исполнения | Позволяет изменить порядок вычисления значений на выходах коммутационной программы или макроса и порядок передачи значений по обратным связям.
Перенумеровать компоненты | изменяет нумерацию функциональных блоков, расположенных в рабочей зоне проекта (кнопка неактивна, пока проект не создан).

Описание работы с симулятором смотрите в разделе Отладка коммутационной программы.

Панель вставки

Панель содержит пиктограммы элементов для быстрого размещения их на схеме проекта.

Блок комментариев | Добавление комментария на схему проекта.
Создание блока выходной переменной | Обеспечение удобства выполнения связей на схеме (без указания соединительной линии).
Создание блока входной переменной | Обеспечение удобства выполнения связей на схеме (без указания соединительной линии).
Создание блока константы | Задание фиксированных числовых значений (пороговых или уставок) для ФБ, работающих с целочисленными значениями.
Линия задержки | Создание задержки на 1 цикл.
Создание сетевой выходной переменной | Создание переменной, значение которой задается по сети.
Создание сетевой входной переменной | Создание переменной, значение которой задается по сети.
Создание блока записи в ФБ | Обеспечивает подачу значений переменной на вход ФБ, при этом на схеме может не отображаться соединительная линия цепи передачи сигнала.
Создание блока чтения из ФБ | Обеспечивает чтение значений переменной с выхода ФБ, при этом на схеме может не отображаться соединительная линия цепи передачи сигнала.
Преобразователь в булевское значение | Преобразовывает целочисленное значение сигнала в булевское.
Преобразователь в целочисленное значение | Преобразовывает булевское значение сигнала в целочисленное.
Преобразователь в число с плавающей точкой | Преобразовывает целочисленное значение сигнала в число с плавающей точкой.


Главное меню

Файл

Новый проект | Открывает новый проект. Текущий проект при этом закрывается
Открыть проект | Открывает для редактирования ранее созданный и сохраненный проект
Сохранить текущий документ | Сохраняет открытый документ
Сохранить проект | Пересохраняет проект под текущим именем
Сохранить проект как | Открывает диалоговое окно для выбора расположения и ввода имени сохраняемого проекта
Создать макрос | Открывает редактор макросов
Сохранить как новый макрос | Запрашивает новое имя макроса и сохраняет его
Импорт макроса из файла | Импортирует макрос из файла в библиотеку компонентов
Экспорт макроса в файл | Открывает окно для выбора расположения и имени экспортируемого макроса
Онлайн база макросов | Открывает список макросов, хранящихся на сервере
Печать | Вывод проекта на печать
Последние проекты | Список недавно открытых проектов
Выход | Выход из программы

Вид

Отменить | Отменить действие в редакторе
Восстановить | Восстановить отмененное действие в редакторе
Стиль интерфейса | Выбор цветовой темы программы
Индикаторы состояний | Меню для включения и отключения индикаторов в статусной строке
Панель библиотек | Скрыть/отобразить панель Библиотек
Панель свойств | Скрыть/отобразить панель Свойств

Прибор

Записать программу в прибор | Записывает в прибор коммутационную программу, созданную в открытом проекте
Обновить встроенное ПО | Запускает обновление прошивки подключенного прибора
Информация | Отображает информацию о подключенном приборе
Таблица переменных | Открывает таблицу переменных проекта
Юстировка входов/выходов | Открывает панель юстировки
Настройка прибора | Вызывает панель Настройка прибора
Настройка порта | Вызывает панель Настройка порта

Сервис

Перенумеровать компоненты | Автоматически перенумеровывает по порядку функциональные блоки на схеме
Режим симулятора | Запускает режим симуляции коммутационной программы
Режим OFFLINE | Запрещает опрашивать прибор по USB.

Помощь

Автопроверка нового релиза | Автоматически проверять доступность нового релиза на сервере обновления
Проверить обновления... | Вызыв диалогового окна для установки новых версий программного обеспечения
Справка | Вызов справки
История версий | Открывает в браузере список версий программы с описанием
О программе | Информация о текущей версии программы


Рабочая область

После создания проекта или открытия сохраненного проекта в рабочей области открывается вкладка "Схема" для разработки коммутационной программы (схемы) ПР на языке FBD.

Основную часть вкладки составляет холст, на котором размещаются функции и функциональные блоки. Изменить размеры холста можно на панели "Свойства".

Входы и выходы ПР обозначены в виде квадратов с маркировкой номеров: вдоль левой стороны холста расположены входы (Ix - дискретные, AIx - аналоговые), вдоль правой - выходы (Qx - позиционные реле, AOx - аналоговые, Fx - светодиоды). Входы и выходы можно перетаскивать вдоль холста методом drag&drop для удобства составления схемы. Цифры в обозначениях соответствуют номерам физических входов и выходов прибора.

Под заголовком "Схема" располагаются кнопки:
Включить/Выключить сетку | При включенной сетке на холсте отображаются вертикальная и горизонтальная линейки, сетка; размещаемые элементы и линии связи пр размещении привязываются к сетке.
Уменьшить масштаб | Уменьшение масштаба на 10% от первоначального.
Оригинальный размер | Возврат к исходному масштабу
Увеличить масштаб | Увеличение масштаба на 10% от первоначального.

Задать требуемый масштаб можно с помощью выпадающего меню справа от описанных выше кнопок.

В нижней части рабочей области находятся кнопки "Разделить" и "Объединить". Кнопка "Разделить" используется для одновременного отображения двух областей одной схемы в разных окнах, кнопка "Объединить" - для отображения схемы в одном окне.


Панель Библиотека компонентов

Если в программе открыт проект, то на панели библиотека отображаются ее разделы: функции, функциональные блоки, макросы. Выберите раздел в нижней части панели для отображения его содержимого.

Выбрать вид отображаемых компонентов можно с помощью кнопок в верхней части панели.

В выпадающем меню выберите вариант расположения компонентов:

При нажатии кнопки [image] Показать все компоненты отображаются все компоненты выбранного раздела библиотеки:

При нажатии кнопки [image] Группировка по папкам отображаются папки, содержащие компоненты разных типов:

Папка открывается двойным щелчком мыши.

Описание разделов и компонентов библиотеки в разделе Библиотека.


Панель Свойства

Панель свойства используется для отображения и редактирования:

  • параметров функций и функциональных блоков;
  • размеров холста;
  • часто используемых свойств входов и выходов (полный перечень настроек осуществляется в разделе Настройки прибора -> Входы);
  • параметров комментария, свободных переменных, блоков преобразователей.

Нажмите левой кнопкой мыши на нужный элемент на схеме, чтобы отобразить его свойства.

Поля параметров на панели свойств могут отображаться двумя способами:

  • при нажатой кнопке [image] - в алфавитном порядке;
  • при [image] - по категориям.

Параметры элементов представлены на панели Свойства в виде таблицы: в левом столбце - наименование параметра, в правом - значение параметра. Щелкните левой кнопкой мыши в поле значения параметра, чтобы его отредактировать.


Менеджер и редактор экранов

Менеджер экранов

Если ПР, выбранный при создании проекта, имеет экран, то можно настроить вывод на него информации из выполняемой коммутационной программы на вкладке "Менеджер экранов". Здесь описан интерфейс Менеджера экранов, инструкции по настройке визуализации приведены в разделе Программирование экрана прибора.

В основной части вкладки расположено изображение экрана. Способ отображения и количество экранов можно изменить, используя кнопки в верхней части панели:
Редактирование экранов
 | Добавить экран
 | Удалить экран
 | Редактировать
Размещение
 | Переместить на уровень выше
 | Переместить на уровень ниже
Масштабирование
 | Уменьшить масштаб
 | Оригинальный размер
 | Увеличить масштаб
Масштаб может быть изменен с помощью выпадающего меню справа от кнопок.

При нажатии на изображение экрана в нижней части панели отображаются параметры экрана. Здесь происходит настройка экрана.

Редактор экранов

Открывается по двойному щелчку на изображении экрана в менеджере экранов.

В рабочей области изображена схема экрана в виде прямоугольника с размеченными строками. Справа от него расположены пиктограммы

Масштаб изображения экрана в редакторе можно изменять аналогично тому, как это делается в Менеджере экранов.

Кнопка [image] Сохранить - для сохранения документа в текущем редакторе.


Панель статуса

На панели статуса выводится информация о доступных ресурсах ПР и подключении.

Вид

В зависимости от типа прибора, выбранного при создании проекта, перечень параметров в статусной строке может различаться.

Параметры и элементы управления

При подключенном приборе в строке статуса отображается информация:

  • ФБ - доступное количество экземпляров функциональных блоков.
  • Перем. - доступное количество переменных; переменные создаются неявным образом в «обратных связях», во множественных связях, где есть общий «узел».
  • Стек - доступное количество уровня стека.
  • ЭСППЗУ - доступное количество энергонезависимой памяти для Retain переменных.
  • ПЗУ - доступная память ПР в процентах от общего объема: «ПЗУ: 0…100 %».
  • ОЗУ - доступная память ПР в процентах от общего объема: «ОЗУ: 0…100 %».

    Чем больше используется в программе блоков и функций, тем больше памяти требуется для работы в ПР. ПО OWEN Logic автоматически рассчитывает доступную память ПР и в случае критического значения выводит соответствующее предупреждение.

  • ПРx-x - информация о наличии связи между ПО OWEN Logic и ПР, при наличии связи указывается модель подключенного ПР. При нажатии на блок прибор переводится в режим OFFLINE.
  • COMx - номер выбранного пользователем порта. При нажатии открывается окно для настройки порта.

Режим OFFLINE

В режиме OFFLINE устанавливается запрет на опрос прибора по USB.

Чтобы перейти в режим OFFLINE, нажмите на имя прибора на панели статуса. Аналогично происходит возврат в режим ONLINE.

Подробнее см. в разделе Загрузка в прибор.


Создание проекта и порядок работы

Создание и редактирование проекта

Чтобы создать новый проект, в главном меню программы выберите "Файл ->Создать новый проект".

Сохранение и открытие сохраненного проекта осуществляется также с помощью стандартных кнопок Windows в меню "Файл". Для удобства эти кнопки вынесены на панель инструментов.

В открывшемся окне выберите тип ПР, для которого создается проект:

Нажмите "ОК". В главном окне программы отобразится холст проекта, станут активными статусная строка и окна "Библиотека компонентов" и "Свойства".

При наличии у выбранного прибора экрана отобразится вкладка "Менеджер экранов" где можно настроить вывод информации на экран.

Разработка коммутационной программы

На холсте создается коммутационная программа проекта на языке FBD с помощью компонентов Библиотеки.

Симуляция коммутационной программы

Моделирование работы коммутационной программы в режиме симуляции. При проверке правильности работы программы изменяют состояние входов, контролируя состояние выходов на соответствие нужным условиям. Далее происходит исправление ошибок и повторная проверка.

Подключение прибора и настройка соединения

Настраивается порт и к компьютеру подключается прибор. Далее на прибор подается питание и производятся настройки прибора.

Загрузка коммутационной программы в прибор

После подключения прибора к компьютеру может быть загружена коммутационная программа. После загрузки следует сначала отключить питание прибора, затем отсоединить прибор от компьютера.


Настройка порта

Настройка состоит в выборе номера используемого СОМ-порта, остальные настройки фиксированные и выводятся для справки.

Выберите номер порта, к которому подключен прибор, в выпадающем меню и нажмите "ОК".

Подключение по USB

При подключении ПР к компьютеру через порт USB необходимо установить драйвер USB с CD-диска, входящего в комплект поставки прибора, либо скачать нужный драйвер на сайте owen.ru.

Подключите прибор к компьютеру, затем включите прибор в сеть электропитания. После этого узнайте номер эмулируемого COM-порта в Диспетчере устройств ОС Windows:

Введите этот номер в окне "Настройка порта" и нажмите ОК. при правильном подключении в строке статуса отобразится название подключенного ПР.


Настройка прибора

Для настройки связи с ПР сначала выполняется подключение его к ПК через любой свободный СОМ-порт. В зависимости от выбранной модели ПР для соединения используется либо комплект для программирования, например ПР-КП20, либо кабель для программирования, входящий в комплект поставки ПР.

Внимание! Электрическое подключение к ПК допускается выполнять только при выключенном питании ПР.

После электрического соединения устройств настраиваются параметры связи в ПО ОWEN Logic.

Настройка канала соединения с ПР производится в окне «Настройка порта». Окно вызывается из основного меню командой «Прибор -> Настройка порта».

Панели для настройки подключенного ПР вызываются в меню "Прибор" или с помощью кнопок на панели инструментов.
Информация
Таблица переменных
Юстировка входов/выходов
Настройки прибора
Настройка порта

Панель настроек прибора

Открывается с помощью меню программы «Прибор -> Настройка прибора».

Панель настроек прибора содержит разделы:

  • Экран
  • Часы
  • Интерфейсы
  • Модули расширения
  • Входы
  • Выходы

Перечень разделов может отличаться для разных типов ПР.

Все установленные настройки для прибора, за исключением часов, сохраняются вместе с проектом.


Экран

Основные настройки экрана подключенного прибора:

Перечень параметров зависит от типа прибора.

Подсветка экрана - в выпадающем меню можно выбрать длительность работы подсветки с момента последнего действия пользователя.

Яркость - настройка яркости экрана, от 0 до 100%.

Контраст - настройка контрастности отображаемых символов, от 0 до 100%.

Кнопка "Прочитать" используется для считывания текущих настроек экрана из подключенного прибора.


Часы

В окне "Часы" происходит настройка внутренних часов подключенного ПР. Задайте дату и время в соответствующих полях:

Чтобы синхронизировать часы ПР с часами компьютера, отметьте галочку "Синхронизация с компьютером". В этом случае поля "Дата" и "Время" будут неактивны.

Нажмите кнопку "Записать" в разделе "Дата и время", чтобы задать новые значения для часов ПР.

В поле "Отклонение" укажите погрешность хода часов в секундах. Если часы ПР спешат, то значение указывается со знаком "-". Коррекция часов прибора на указанную величину происходит равномерно в течение месяца.

Нажмите "Записать" в разделе "Коррекция", чтобы установить значение коррекции, не меняя даты и времени.

Кнопка "Прочитать" позволяет считать из ПР и отобразить в полях данного окна текущие значения параметров часов подключенного прибора.


Интерфейсы

Задание параметров интерфейса связи прибора ПР осуществляется в разделе "Интерфейсы" диалогового окна "Настройка прибора". Чтобы открыть окно, выберите «Прибор -> Настройка прибора » в главном меню. Доступ к настройкам возможен без подключения прибора к ПК.

Добавить/Удалить интерфейс

Если прибор содержит слот, для которого не настроен интерфейс, то можно добавить интерфейс соответствующего типа с помощью контекстного меню:

Будет добавлен интерфейс выбранного типа с настройками по умолчанию.

Настройка интерфейса

Настройка RS485

Удаление интерфейса

В зависимости от исполнения ПР добавленный интерфейс может быть заменен на интерфейс другого типа или удален через контекстное меню.

Шаблоны

Для некоторых интерфейсов возможно создание шаблонов сетевых устройств (например, для RS-485 в режиме Master). При наличии сохраненного шаблона интерфейса его можно применить к новому интерфейсу с помощью контекстного меню. Все настройки из шаблона будут перенесены на новый интерфейс.


RS-485

Для организации обмена данными между ПР и приборами, подключенными к нему по интерфейсу RS-485, должны быть произведены настройки интерфейса в окне Настройки прибора в разделе Интерфейсы. Окно открывается в меню Прибор -> Настройки прибора.

При добавлении интерфейса RS-485 в списке отображается тип интерфейся (RS-485), номер слота, для которого назначен интерфейс и режим (Master/Slave).

Выберите интерфейс щелчком мыши и в окне права введите значения параметров. Параметры зависят от технических характеристик подключаемых устройств и задач проекта.

Кнопка [image] Сделать по умолчанию - сохраняет введенные в поля данные для отображения при следующем подключении.

Кнопка [image] Заводские настройки - отображает в полях ввода заводские настройки для типа подключенного прибора.

Кнопка "Прочитать" - считывает текущие настройки подключенного прибора.

После задания корректных настроек интерфейса нажмите кнопку "Закрыть". Параметры вступают в силу после перезагрузки питания прибора или после загрузки проекта в прибор.

Кнопка "Прочитать" используется для считывания текущих настроек экрана из подключенного прибора.

Режим Master/Slave

Режим каждого доступного интерфейса RS-485 может быть определен как "Master" или "Slave".

В режиме Master ПР осуществляет чтение и запись переменных ведомых устройств, подключенных по данному интерфейсу.

В режиме Slave ПР является ведомым прибором, параметры которого опрашиваются другим устройством.

Настройка для режима Master

Настройка для режима Slave


RS485 режим Master

В режиме Master ПР сам опрашивает подключенные по интерфейсу устройства. Для организации опроса необходимо добавить и настроить опрашиваемые устройства. В контекстном меню интерфейса выберите "Добавить устройство":

Добавленное опрашиваемое устройство будет отображено в списке под названием интерфейса. В списке указывается имя и адрес устройства.

Нажмите на добавленное устройство и задайте настройки в окне справа.

В верхней части окна настройте параметры опроса:

  • Имя - имя опрашиваемого устройства, которое будет отображаться в списке интерфейсов. Назначается пользователем для удобства работы.
  • Адрес - назначается адрес опрашиваемого Slave устройства.
  • Период опроса, мс - временной интервал, через который повторяется опрос. Допустимый диапазон от 0 до 65535 мс.
  • Таймаут ответа, мс - время, по истечении которого попытка опроса считается неудачной. Допустимый диапазон от 0 до 65535 мс.
  • Кол-во попыток - количество неудачных попыток опроса, при достижении которого изменяется Статус устройства. Допустимый диапазон от 0 до 255.
  • Групповой запрос - при выборе этой функции программа позволяет делать групповые запросы регистров, которые идут подряд.
  • Статус - переменная, в которую записывается статус прибора. Тип булевский: 1 - устройство функционирует нормально 0 - связь с устройством потеряна. Переменная выбирается в таблице переменных, которая вызывается нажатием кнопки "...".
  • Опрос - булевская переменная, определяющая доступ к опросу: 0 - запрет опроса 1 - разрешение опроса. Переменная выбирается в таблице переменных, которая вызывается нажатием кнопки "...".
  • Старшим регистром вперед - определяет очередность посылки регистров при работе с двухрегистровыми переменными.
  • Старшим байтом вперед - определяет очередность следования байтов в посылке.
  • Комментарий - текстовый комментарий, описывающий устройство.

Временная диаграмма опроса:

Ниже располагается таблица переменных устройства, значения которых нужно считывать.

Добавьте переменную, нажав кнопку [image]. Она будет помещена в таблицу.

Настройте свойства переменной настраиваются в окне справа от таблицы:

  • Имя переменной - Задайте имя переменной, которое будет отображаться в таблице переменных.
  • Тип - тип считываемой переменной: булевский, целочисленный или с плавающей запятой.
  • Бит - номер бита для чтения, только для переменных булевского типа (bool), указывает пользователь.
  • Регистр/Адрес регистра - значение регистра, к которому обращается ПР, отображается в таблице.
  • Функция чтения/функция записи - выбор функции или отключения записи/чтения.
  • Количество регистров - количество занимаемых переменной регистров, указывается пользователем для целочисленных переменных (int) и с плавающей запятой (float).
  • Запуск чтения - назначается переменная булевского типа (bool) для принудительного чтения данной переменной.
  • Запуск записи - назначается переменная булевского типа (bool) для принудительной записи данной переменной.
  • Статус - позволяет назначить любую целочисленную переменную (int), в которую будет записан код ошибки в случае ее появления.
  • Комментарий - текстовый комментарий для описания значения переменной, будет отображаться в таблице переменных.

Чтобы создать несколько переменных со схожими настройками, выберите переменную в таблице и нажмите [image] Тиражировать.

  • Имя - имя переменной, которая будет тиражирована.
  • Начальный номер - начальное число, которое будет добавлено к имени тиражируемой переменной.
  • Количество - сколько переменных нужно добавить.
  • Шаг адреса - шаг, с которым будет увеличиваться значение параметра "Регистр".

Нажмите "ОК". Переменные будут добавлены в таблицу.

Чтобы удалить переменную из таблицы, выделите нужную строку и нажмите

Шаблоны интерфейса

После того как все настройки сделаны, конфигурация устройства может быть сохранена в виде шаблона. Нажмите кнопку [image] Сохранить устройство как шаблон. В открывшемся окне выберите расположение и введите имя файла. Файл будет сохранен с расширением *.dvtp.

Данный шаблон может быть использован в других проектах.


RS485 режим Slave

Добавить/Удалить интерфейс

При добавлении в список интерфейс RS485 по умолчанию установлен режим Slave - ПР предоставляет данные для считывания другими устройствами, самостоятельный опрос не ведет.

Чтобы настроить параметры передачи данных, нажмите на имя ПР (По умолчанию "Сам, 16") под заголовком интерфейса.

В окне справа расположены панели настройки. В верхней части настраиваются параметры опроса, общие для всех переменных.

  • Имя - собственное имя ПР, обозначается пользователем для удобства.
  • Адрес - собственный адрес ПР.
  • Старшим регистром вперед - определяет очередность посылки регистров при работе с двухрегистровыми переменными.
  • Старшим байтом вперед - определяет очередность следования байтов в посылке.
  • Комментарий - поле ввода комментария к устройству.

Ниже располагается таблица переменных ПР, значения которых будут считываться подключенным ведущим устройством.

  • Имя переменной - Задайте имя считываемой переменной.
  • Тип - тип считываемой переменной: булевский, целочисленный или с плавающей запятой.
  • Адрес регистра - адрес регистра сетевой переменной, назначается пользователем, диапазон доступных адресов смотрите в РП на прибор.
  • Комментарий - текстовый комментарий для описания значения переменной, будет отображаться в таблице переменных.

    Свойства переменной, указанные в таблице настраиваются в окне справа.

    Чтобы создать несколько переменных со схожими настройками, выберите переменную в таблице и нажмите [image] Тиражировать.

    • Имя - имя переменной, которая будет тиражирована.
    • Начальный номер - начальное число, которое будет добавлено к имени тиражируемой переменной.
    • Количество - сколько переменных нужно добавить.
    • Шаг адреса - шаг, с которым будет увеличиваться значение параметра "Регистр".

    Нажмите "ОК". Переменные будут добавлены в таблицу.

    Чтобы удалить переменную из таблицы, выделите нужную строку и нажмите


Шаблоны сетевых устройств (только для ПР200)

Для упрощения работы с сетевыми устройствами, которые могут быть подключены к ПР200 по интерфейсу RS-485, созданы шаблоны наиболее часто подключаемых приборов.

Файлы шаблонов размещены на сайте www.owen.ru.

Чтобы добавить шаблон, следует выполнить действия:

  1. Скачать файл шаблона на компьютер;
  2. Настроить режим сетевого интерфейса - Master.

    Параметры связи должны совпадать с параметрами подключаемого модуля.

  3. Добавить устройство из шаблонов с помощью контекстного меню интерфейса.

Название добавленного устройства будет отображено в разделе "Интерфейсы".

После добавления можно использовать сетевые переменные по своему усмотрению. Неиспользуемые регистры можно удалить, отредактировать название, пересохранить шаблон для будущих проектов.

После конфигурирования всех параметров следует проверить положение джамперов на сетевой плате ПР200. Для работы с модулями расширения по интерфейсу RS-485 их необходимо установить в положение Master (M).


Модули расширения

К прибору могут быть подключены модули ввода/вывода. При загрузке проекта все модули должны быть подключены по внутренней шине к ПР200 и запитаны для синхронизации внутреннего ПО с используемой версией программы OWEN Logic.

Параметры модулей следует настраивать на панели настроек прибора. Панель вызывается в меню программы "Прибор -> Настройки прибора".

Чтобы добавить модуль расширения, нажмите правой кнопкой мыши на "Модули расширения" и выберите "Добавить модуль расширения" и выберите модель.

Выбранный модуль будет добавлен в список модулей. для модуля указывается название модели и номер слота. При выделении модуля в списке на панели справа отобразятся его настройки.

Так как к некоторым приборам может быть подключено различное количество модулей расширения, необходимо указать номер слота, занимаемый данным модулем, в выпадающем меню.

Статус модуля может сохраняться в переменную типа bool. Если связь с модулем установлена, то переменная хранит значение True , если связь не установлена - False. Чтобы выбрать переменную, в которой будет храниться статус, нажмите кнопку "...".

Откроется таблица переменных. Можно выбрать переменную из проекта или создать новую.

Выбранная переменная будет отображаться в поле ввода.

Для выходов модуля расширения может быть настроено безопасное состояние.


Входы и выходы

В зависимости от модификации прибора и подключенных к нему модулей в окне настройки прибора отображаются различные комбинации входов и выходов. При выборе входа/выхода справа отображаются его свойства.

Добавление комментариев

Ввести комментарий можно в поле ввода в окне "Настройка прибора" или на панели свойств. Текст введенного комментария будет отображаться во всплывающей подсказке при наведении курсора на данный вход/выход на схеме:

Настройка параметров

В зависимости от типа входов/выходов прибора различаются параметры для настройки.

Чтобы сделать правильные настройки, обратитесь к руководству по эксплуатации прибора.

Безопасное состояние выходов

Для выходов модулей расширения есть возможность настроить безопасное состояние. Это состояние, которое будет принимать выход, при потере связи с головным прибором.


Информация о приборе

Чтобы получить информацию о типе подключенного ПР и о версии программного обеспечения, нажмите кнопку [image] на панели инструментов или выберите в главном меню "Прибор -> Информация...".

Откроется окно с информацией о подключенном приборе:

Информация о проекте:

Выбранная модель прибора - тип приборы, выбранный при создании проекта.

Версия среды разработки - версия, в которой изначально был создан проект, может не совпадать с текущей версией программы.

Экспортировать в проект - кнопка для экспорта проекта в ПО Owen Logic из подключенного прибора.


Таблица переменных

Окно вызывается нажатием кнопки [image] на панели инструментов или в главном меню при выборе "Прибор -> Таблица переменных".

Таблица содержит три вкладки: Переменные, Сервисные переменные, переменные интерфейса.

Переменные

Это обычные переменные, которые служат для связи между блоками и входами/выходами прибора, а также с элементами визуализации (для считывания и записи данных посредством экрана ПР).

Чтобы использовать свободные переменные в проекте, нужно создать их в таблице:

Введите имя переменной и задайте тип. Остальные параметры не обязательны для заполнения. Созданная переменная может быть использована в проекте.

Подробнее в разделе Свойства переменной.

Чтобы найти, в каком месте проекта используется переменная, нажмите левой кнопкой мыши в поле столбца "Использование в проекте" и нажмите "Показать ссылки".

В открывшемся окне отобразится информация о выбранной переменной.

Чтобы удалить привязку к блоку переменной в проекте, отметьте нужные переменные галочками и нажмите кнопку "Удалить". Удаленные переменные будут отображаться в таблице переменных, но в проекте не будут использованы.

Чтобы удалить переменную из таблицы, в ее контекстном меню выберите "Удалить переменную".

Сервисные переменные

Сервисные переменные связаны с настройкой системы прибора. Их набор может отличаться в зависимости от исполнения прибора. Сервисные переменные могут иметь ограничения по чтению/записи.

Сервисные переменные связаны с аппаратными функциями прибора, такими как часы, наличие интерфейсной платы в слоте, и пр.

Сервисные переменные обозначаются на схеме серым цветом:

Переменные интерфейса

В таблице переменных для каждого задействованного слота интерфейса создается отдельная вкладка с описанием сетевых переменных. В заголовке вкладки указывается тип интерфейса и номер слота.

Интерфейс RS-485

Для интерфейса, настроенного в режиме Master таблица содержит вкладки с переменными для каждого подключенного устройства:

О настройках переменных см. подробнее в разделе RS485- Режим Master.

Для интерфейса, настроенного в режиме Slave таблица отображает сетевые переменные, описанные в разделе RS-485 Режим Slave.


Свойства переменных

Основные свойства переменных:

Имя переменной | Имя будет отображаться в таблицах и на блоке переменной в коммутационной программе
Тип переменной | Может быть назначен один из трех типов: булевский, целочисленный, с плавающей запятой. Подробнее о типах переменных
Энергонезависимость | Значение переменной будет храниться в энергонезависимой памяти прибора в случае отключения электропитания. Для этого поставьте галочку. Время хранения зависит от типа прибора, см. руководство по эксплуатации
Значение по умолчанию | Значение, которое будет хранить переменная при записи коммутационной программы, пока в нее не будет записано новое значение
Использование в проекте | Индикация привязки к блокам в коммутационной программе. Если переменная привязана, значение "Да"
Комментарий | Текстовый комментарий отображается в нижней части таблицы при выделении строки переменной, а также во всплывающей подсказке на схеме коммутационной программы при наведении курсора на блок переменной


Типы переменных

В программе используется три типа переменных: булевский (двоичный), целочисленный и с плавающей запятой (вещественный).

Передача значения от одной переменной к другой может осуществляться только при совпадающих типах переменных.

Булевский тип (bool)

Переменная данного типа может принимать одно из двух значений: 1 (true) или 0 (false).

Линии, соединяющие переменные данного типа на схеме, обозначаются серым цветом:

Целочисленный тип (int)

Переменная данного типа - целое число, принимает значение в диапазоне от 0 до 4294967295.

На схеме переменные данного типа соединяются красными линиями:

Тип с плавающей запятой (float)

Переменная данного типа принимает значение в диапазоне от 1,175494351 E - 38) до 3,402823466E+38).

Числа одинарной точности с плавающей запятой обеспечивают относительную точность 7-8 десятичных цифр в диапазоне от 10^(-38) до примерно 10^(38).

На схеме переменные данного типа соединяются фиолетовыми линиями:


Юстировка входов/выходов

С помощью команды меню "Прибор - Юстировка Входов/Выходов" необходимо настроить аналоговые входы и выходы прибора перед запуском в эксплуатацию.

В открывшемся диалоговом окне выберите юстировку входов или выходов.

Юстировка входов

Перед началом юстировки входов, если в контроллере запущена коммутационная программа, то ее выполнение останавливается. В окне настройки введите параметры подключаемых ко входам датчиков:

Чтобы в окнах ввода восстановились настройки по умолчанию, нажмите "сбросить настройки".

В списке каналов выберите номера входов, которые нужно настроить в соответствии с введенными параметрами:

Далее следуйте указаниям программы. Настройте прибор:

При необходимости обратитесь к руководству по эксплуатации подключенного прибора.

Подавайте сигналы с требуемыми характеристиками на настраиваемые входы.

После завершения процесса юстировки программа выдаст сообщение об успешном завершении. Коммутационная программа ПР будет снова запущена.

Юстировка выходов

Выполняйте указания программы. Измерьте величину сигнала, поданного на выход, указанный в правом верхнем углу окна, и введите значение в поле ввода.

Аналогично введите значения сигналов в последующих окнах. После настройки всех выходов появится сообщение об успешном завершении юстировки:


Разработка коммутационной программы

Составление коммутационной программы рекомендуется начинать с планирования. План должен описывать все возможные состояния ПР при функционировании (в виде диаграммы режимов, таблицы состояний, электрической или функциональной схемы и/или др.).

После того как продуманы все задачи, которые должны выполняться, следует составить программу на основе функций и функциональных блоков Библиотеки программы.

Размещение компонентов и создание связей

Компоненты программы размещаются на схеме путем выбора нужного компонента в Библиотеке программы и перемещения на холст методом "drag&drop".

Входы и выходы контроллера и компонентов необходимо соединить, проведя между ними линии. Проводите соединительные линии, удерживая левую кнопку мыши.

Настройка параметров компонентов

Настройка компонентов схемы осуществляется на панели Свойства. Выделите нужный компонент и редактируйте значения его параметров.

Для разработки коммутационной программы используются следующие блоки, связи и фукнции:
Блоки переменных | Размещение переменных для ввода и чтения промежуточных значений из коммутационной программы.
Блок константы | Для ввода фиксированного значения в коммутационную программу.
Чтение/запись в функциональный блок | Чтение и запись значений отдельных параметров из функционального блока в переменную.
Сетевой обмен | Для обмена данными с другими устройствами, подключенными к ПР по сети.
Проведение линии задержки | Для создания задержки на один цикл передачи значения с выхода блока на вход.
Преобразование типов переменных | Для передачи значений от выхода к входу различных типов.
Размещение блока комментария | Текстовые комментарии на схеме.
Перенумеровать компоненты | Переназначение порядковых номеров функциональных блоков схемы.
Задание порядка исполнения | Изменение порядка вычисления значений на выходах блоков коммутационной программы.


Переменные

На схему могут быть добавлены блоки переменных:

  • входной переменной - для передачи значения в коммутационную программу;
  • выходной переменной - для записи в нее значения из коммутационной программы.

Чтобы добавить блок переменной на схему, нажмите на него на панели вставки:

Затем нажмите на схеме в то место, куда нужно поместить блок. Блок будет добавлен:

При выделенном блоке переменной на панели Свойства нажмите кнопку "..." в поле "Переменная".

После нажатия кнопки "..." откроется окно "Таблица переменных", в которой нужно выбрать или создать новую переменную и нажать "ОК". Выбранная переменная будет привязана к добавленному блоку:

Если в процессе создания алгоритма переменная выделяется красным цветом, значит, присутствует ошибка.

Чтобы узнать об ошибке, наведите курсор на выделенный красным блок переменной.


Константа

На схему могут быть добавлены блоки константы [image] :

Для включения в программу жестко заданной величины используется блок константы, расположенный на панели вставки. Нажмите на пиктограмму блока константы, а затем - в место на схеме, где должен быть расположен блок.

На панели Свойства выберите тип данных для константы и введите значение. Значение будет отображено в блоке на схеме.

После запуска коммутационной программы в приборе данное значение будет изменить невозможно.


Чтение и запись в функциональный блок

На схему могут быть добавлены блоки:

  • чтения значения из функционального блока;
  • записи значения в функциональный блок.

Блок "Запись в ФБ" используется, чтобы в процессе выполнения алгоритма задавать различные значения для параметра функционального блока.

Например, в зависимости от значения на входе I5 в функциональном блоке "BLINK1" значение параметра "Длительность вкл. состояния" будет иметь значение "2" или "10":

Разместите на схеме блок и на панели свойства выерите фукнциональный блок и имя переменной, в которую будет записываться значение из блока "Запись в ФБ":

Блок "Чтение из ФБ" предназначен для считывания текущего значения параметра функционального блока и настраивается аналогичным образом.


Сетевой обмен

Работа с сетевыми переменными

Для реализации сетевых возможностей приборов ПР в среде программирования предусмотрен специальный тип переменных – сетевые переменные, которые добавляются на схему проекта с помощью кнопок: и [image].

Назначение каждой сетевой переменной определяется пользователем на этапе разработки коммутационной схемы. Например, сетевая переменная может служить для задания по сети уставки функционального блока «Таймер с задержкой включения», «Счётчик» и др., или сетевая переменная может быть применена для считывания текущего состояния выхода функционального блока «Универсальный счётчик».

Переменные, значение которых передаётся по сети в программу пользователя, называются сетевые входы. Переменные, которые могут быть считаны по сети, – сетевые выходы.

Добавление сетевых переменных в проект рекомендуется выполнять в следующем порядке:

Шаг 1 - нажать на кнопку [image] или [image] на панели инструментов, затем нажать на место на схеме, где должна располагаться переменная. На холсте появится блок сетевой переменной.

Шаг 2 - нажмите на блок сетевой переменной и на панели свойства в поле «Переменная» на кнопку "...".

Шаг 3 – в открывшейся таблице пеменных выберите (или создайте новую) переменную для привязки. Нажмите "ОК".

Шаг 4 – подсоединить выход/вход сетевой переменной к необходимому компоненту

Вышеописанный алгоритм работы с сетевыми переменными удобен, если пользователь начинает работу с проектом с программирования прибора ПР. В случае, если список параметров Мастера сети Modbus уже известен, работу удобнее начинать с определения сетевых переменных в таблице переменных.


Линия задержки

Для создания задержки на один цикл передачи значения с выхода блока на вход используется блок Линия задержки.

Нажмите на пиктограмму Линия задержкина панели вставки и постройте линию между выходом и входом функции или функционального блока. Будет проведена красная пунктирная линия.

Пример использования

На вход I1 блока арифметического сложения (тип целочисленный) подается константа, равная 1. На вход I1 по линии задержки подается значение с выхода блока (Q), которое было вычислено в предыдущем цикле.

Значения на входах и выходах блока:

№ цикла | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10
I2 | 0 | 0 | 1 | 1 | 2 | 2 | 3 | 3 | 4 | 4
Q | 1 | 1 | 2 | 2 | 3 | 3 | 4 | 4 | 5 | 5


Преобразование типов пременных

Соединительная связь между входом и выходом блоков коммутационной прграммы могут быть созданы только для входа и выхода одного и того же типа: булевского, целочисленного или с плавающей точкой. Чтобы создать всязь между входом и выходом разных типов, используйте блоки преобразования.
Преобразователь в булевское значение | Преобразовывает целочисленное значение сигнала или значение с плавающей запятой в булевское. Если значение на входе больше "0", то на выходе блока будет "1" ("True").
Преобразователь в целочисленное значение | Преобразовывает булевское значение сигнала или число с плавающей запятой в целочисленное. Если на входе булевское значение "0" ("False"), то на выходе будет "0", если на входе "1" ("True"), то на выходе будет "1". Если на выходе число с плавающей запятой, то оно округляется с недостатком.
Преобразователь в число с плавающей запятой | Преобразовывает целочисленное значение сигнала или будевское в число с плавающей точкой.

Чтобы добавить блок преобразования, выделите нужный блок на панели вставки и затем нажмите в то место схемы, где он должен быть размещен.


Программирование экрана прибора

Если выбранный при создании проекта ПР имеет экран, то можно запрограммировать вывод на него информации проекта по определенному алгоритму. На экране может отображаться текст и значения переменных коммутационной программы прибора.

Для программирования экрана используется панель "Менеджер экранов". нажмите на заголовок в левой части экрана, чтобы открыть панель:

По умолчанию на панели отображается один экран, который можно запрограммировать для вывода информации на физическом экране прибора.

Добавление экранов

Программа позволяет настроить несколько электронных экранов, переключение между которыми для отображения на физическом экране прибора будет осуществляться по нажатию кнопки или по событию.

Чтобы добавить или убрать экран, используйте кнопки [image] Добавить экран и [image] Удалить экран.

Чтобы последовательность расположения экранов на панели, используйте кнопки [image] Переместить на уровень выше и [image] Переместить на уровень ниже.

Свойства экрана

Чтобы настроить свойства, выделите нужный экран на панели щелчком мыши. Панель настройки свойств отобразится под изображением экранов. Введите имя экрана, которое будет отображено на панели экранов и в заголовке редактора экранов.

При наличии двух и более экранов в проекте, необходимо настроить переходы (условия переключения) между экранами. Для этого нажмите кнопку "..." в строке "Переход к экрану".

Переход к экрану

Настроим переход от "Экран1" к "Экран2". В свойствах Экрана 1 нужно перейти к настройке перехода, как описано выше и в открывшемся окне выбрать "Экран2" в строке "Список экранов":

Далее необходимо выбрать условие, при котором осуществляется переключение на "Экран2".

Генерация события от прибора - при выборе этой опции нужно указать, при нажатии какой кнопки на приборе произойдет переключение на указанный экран.

Изменение значения переменной - необходимо в таблице переменных выбрать переменную двоичного (boolean) типа, при изменении значения которой будет осуществлен переход к экрану.

После завершения настройки нажмите "ОК", на панели менеджера экранов будет отображен переход:

Переход от экрана к экрану может происходить по различным событиям, для этого можно настроить коллекцию переходов. Добавьте переход аналогично тому, как это описано выше.

Редактор экранов

Чтобы настроить вывод информации на экран, откройте редактор экрана двойным щелчком мыши по изображению экрана на панели или с помощью кнопки [image] Редактировать.

Один экран может содержать несколько строк, переход к которым осуществляется с помощью кнопок прибора. Для добавления и удаления строк откройте [image] Контекстное меню строки.

В строках расположите нужные информационные блоки (элементы управления), перетаскивая их из панели "Библиотека" методом drag&drop. Описания блоков приведены в разделе Элементы управления.


Отладка коммутационной программы

Проверка корректности работы созданной коммутационной программы проводится с помощью режима симулятора, в котором моделируется изменение состояний выходов в зависимости от изменения состояний входов. Моделирование позволяет проанализировать состояние сигналов внутри коммутационной программы.

Для перехода в режим симуляции нажмите кнопку [image] Режим симулятора. Откроется панель симуляции.

Панель симуляции

На панели расположены следующие элементы управления:

  1. Кнопка запуска моделирования в реальном времени;
  2. Кнопка для пошагового моделирования, выполняет 1 цикл программы при нажатии;
  3. Пауза в работе симулятора, при повторном нажатии процесс моделирования продолжается
  4. Кнопка остановки работы симулятора, осуществляет перевод режима симуляции в первоначальное состояние;
  5. Поле ввода для задания времени периода обновления информации на схеме;
  6. Поле ввода для задания времени цикла для временных функциональных блоков - «TON», «TOF», «BLINK».
  7. Поле ввода для выбора единиц измерения времени цикла: мс, сек, мин, час.

Моделирование работы блоков часов

Для вариантов исполнений приборов с функцией часов реального времени открывается дополнительная панель, при помощи которой можно моделировать поведение функциональных блоков «CLOCK» и «CLOCK WEEK» во времени:

Окно просмотра

В режиме симуляции открывается окно просмотра. Его можно скрыть и открыть заново нажатием кнопки [image] на панели симуляции. Окно предназначено для просмотра значений перменных на каждом шаге выполнения коммутационной программы.

При запуске симуляции окно пустое.

Чтобы добавить переменную, нажмите в пустое поле в колонке "Имя", затем на кнопку "...".

Откроется таблица пременных. В ней могут быть выбраны переменные проекта, входы и выходы.

После выбора и нажатия "ОК" таблица переменных закрывается. Выбранные переменные добавляются в окно просмотра.

Также можно добавить переменную в окно просмотра с помощью контекстного меню переменной. Нажмите на переменную на схеме правой кнопкой мыши и выберите "Добавить в окно просмотра".

Последовательность работы с симулятором

После перехода в режим симуляции, моделирование коммутационной программы, в общем случае, происходит в следующей последовательности:

  1. запуск симулятора в одном из режимов: реального времени ( [image] ) или в пошаговом ( [image] );
  2. задание значений входных сигналов, изменяя значения переменных в окне просмотра:

  3. подбор значений параметров «период, мс» и «время цикла, мс» для удобства моделирования;
  4. выход из режима симуляции для корректировки коммутационной программы.

Примечание. Моделирование основной коммутационной программы (вкладка «Схема») и макросов производится по отдельности.

Моделирование работы блоков, не имеющих связи ни с одним из выходов прибора или сетевой переменной, не производится.

При моделировании значения переменных можно задавать в окне просмотра в колонке "Значения".

Симуляция не будет работать при одновременном выполнении следующих условий:

  • переменные энергозависимые;
  • переменные некорректно привязаны к другим элементам схемы.

В этом случае для корректной работы следует сделать переменные энергонезависимыми или сделать корректные привязки.


Загрузка в прибор

Загрузка коммутационной программы

После создания проекта его записывают в энергонезависимую память ПР. Для записи следует:

  • соединить ПР с COM-портом ПК при помощи коммуникационного кабеля;
  • подать питание на ПР согласно его руководству по эксплуатации;
  • настроить параметры соединения, если в этом есть необходимость.
  • записать проект в ПР, нажав кнопку [image] Записать программу в прибор на панели инструментов, или выбрав команду «Файл > Записать программу в прибор».

Если в проекте используются модули расширения, то при загрузке проекта все модули должны быть подключены по внутренней шине к ПР200 и запитаны для синхронизации внутреннего ПО с используемой версией программы OWEN Logic.

Примечание. Сразу после записи ПР переходит в рабочий режим и коммутационная программа запускается автоматически.

Внимание! Если в подключенном ПР уже есть ранее записанная коммутационная программа, то она заменяется новой.

Загрузка обновленного встроенного ПО

Если для подключенного прибора выпущена новая версия встроенного ПО, то при попытке загрузить коммутационную программу будет предложено сделать обновление:

Нажмите кнопку "Да" для запуска процесса перепрошивки.

Во время записи не допускайте разрыва связи между компьютером и прибором.

Восстановление поврежденного внутреннего ПО

Если прибор исправен, переведите его в режим загрузчика (см. руководство по эксплуатации).

В главном меню выберите Прибор -> Обновление встроенного ПО.

В открывшемся окне выберите тип прибора и нажмите "Выбрать". Начнется процесс загрузки. По окончании система выведет сообщение о результатах загрузки.

Переключение программы в режим OFFLINE

Функция используется, если в двух или более приложениях OwenLogic на одном ПК настроена передача данных в один прибор. Приложения будут поочередно занимать порт, загрузка в прибор в таком случае прервется.

Переведите приложения, которые не должны осуществлять загрузку, в режим OFFLINE.

Включение/отключение функции производится нажатием на имя прибора на панели статуса.


Библиотека

При открытом в программе проекте на панели Библиотека доступны вкладки «Функция», «Функциональный блок» и «Макрос», на которых размещены компоненты, используемые при разработке коммутационной программы.

Логические элементы в программе делятся на функциональные блоки и функции.

Функции не сохраняют состояния своих внутренних переменных. К функциям относятся такие элементы как AND, OR, XOR, NOT и другие. Число используемых функций ограничено только объемом памяти прибора.

Функциональные блоки (ФБ) сохраняют состояния своих внутренних переменных. К ФБ относятся триггеры, счетчики таймеры и другие. Каждый прибор имеет собственное ораничение на количество используемых ФБ (см. руководство по эксплуатации прибора).

Вкладка «Макросы» позволяет расширить число применяемых в проекте функциональных блоков за счет созданных пользователем.

Макросы

Вкладка "Элементы управления" доступна при открытом редакторе экранов (см. Менеджер экранов).

Элементы управления


Функции

Логические функции

Арифметические функции

Функции сравнения

Сдвиговые функции

Битовые функции


Логические функции

Логическое И (AND)

Логическое ИЛИ (OR)

Логическое НЕ (NOT)

Исключающее ИЛИ (XOR)


Функция И (AND)

Элемент используется для выполнения логических операций.

На выходе элемента логическая «1» (выход включен), если на всех входах логическая «1» (все входы включены – контакты замкнуты).

Работе соответствует приведенная таблица состояний:

I1 | I2 | Q
0 | 0 | 0
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1

Если на входы функции заведены целочисленные значения, то операция будет произведена над каждым битом в отдельности.


Функция ИЛИ (OR)

Элемент используется для выполнения логических операций.

На выходе элемента логическая «1» (выход включен), если хотя бы на одном входе логическая «1» (контакты замкнуты).

Работе соответствует приведенная таблица состояний:

Если на входы функции заведены целочисленные значения, то операция будет произведена над каждым битом в отдельности.


Функция НЕ (NOT)

Элемент используется для инвертирования сигнала.

На выходе элемента логическая «1» (выход включен), если на входе логический «0» (контакты разомкнуты) и наоборот: сигнал инвертируется.

Работе соответствует приведенная таблица состояний:

I1 | I2
0 | 1
1 | 0

Если на входы функции заведены целочисленные значения, то операция будет произведена над каждым битом в отдельности.


Функция Исключающее ИЛИ (XOR)

Элемент используется для выполнения логических операций.

На выходе элемента логическая «1» (выход включен), только если на любом из входов логическая «1».

Работе соответствует приведенная таблица состояний:

Если на входы функции заведены целочисленные значения, то операция будет произведена над каждым битом в отдельности.


Арифметические функции

Арифметические операции могут производиться над переменными целочисленного типа и типа с плавающей запятой:

 | Целочисленные | С плавающей запятой
Сложение | ADD | fADD
Вычитание | SUB | fSUB
Умножение | MUL | fMUL
Деление | DIV | fDIV
Деление с остатком | MOD | -
Возведение в степень | - | fPOW
Модуль от числа | - | fABS


Сложение (ADD, fADD)

Для операций над целочисленными переменными используется блок ADD, над переменными с плавающей запятой - fADD.

Результатом выполнения операции на выходе является сумма входных значений.

Если при выполнении операции значение числа получается больше 4294967295 (32 бита), то биты, выходящие за разрядность 32 бита, отсекаются.

Пример применения элементов для сложения чисел 24 +2 + 4 + 7 = Var1:


Вычитание (SUB, fSUB)

Для операций над целочисленными переменными используется блок SUB, над переменными с плавающей запятой - fSUB.

Результатом выполнения операции на выходе является разность входных значений.

Если при выполнении операции на первом входе (V1) значение числа меньше второго (V2), то результатом будет число, полученное сложением младшего числа плюс 0x100000000 (4294967296) минус значение числа большего: [(V1 + 0x100000000) – V2] = Q.

Пример применения элемента для вычитания чисел 24 – 2 = Var1 = 22:

Пример применения элемента для вычитания чисел, где V1 меньше V2: 2 – 24 = Var1 = 4294967274.


Умножение (MUL, fMUL)

Для операций над целочисленными переменными используется блок MUL, над переменными с плавающей запятой - fMUL.

Результатом выполнения операции умножения на выходе является произведение входных значений.

Если при выполнении операции значение числа получается больше 4294967295 (32 бита), то биты, выходящие за разрядность 32 бита, отсекаются.

Пример применения элементов для перемножения чисел 24·2·4·7 = Var1:


Деление (DIV, fDIV)

Для операций над целочисленными переменными используется блок DIV, над переменными с плавающей запятой - fDIV.

Результатом выполнения операции деления на выходе является частное от деления входных значений.

Если при использовании блока DIV в результате деления получаются доли целого числа, то на выходе производится округление значения до целого числа в меньшую сторону.

При делении на 0 на выходе элемента будет значение 0хFFFFFFFF.


Деление с остатком (MOD)

Элемент вычисляет и передает на выход (Q) остаток от деления входных целочисленных значений: V1/V2.

Пример применения элемента для выделения целого остатка от деления числа 22 на 3:

На рисунке изображен элемент MOD, вычисляющий остаток от деления в режиме симулятора. Выход Q=1.

При делении на 0 на выходе элемента будет значение 0.


Возведение числа в степень (fPOW)

Блок работает с переменными с плавающей запятой (float).

Результатом выполнения операции на выходе блока является переменная типа float, равная числу V1, возведенному в степень V2:

Q = V1^V2

Пример использования:

На рисунке показана работа элемента fPOW в режиме симулятора. На входы V1 и V2 подаются константы со значениями 3 и 4 соответственно, на выходе Q вычисленное значение - 81.


Взятие модуля от числа (fABS)

Блок работает с переменными с плавающей запятой (float).

Результатом операции на выходе является модуль подаваемой на вход переменной:

Q = |V|

Пример использования (рисунки работы блока в режиме симулятора):


Функции сравнения

Равно (EQ)

Больше (GT, fGT)

Выбор (SEL)


Равно (EQ)

Результатом выполнения операции на выходе является логическая «1», если входные числа равны:

V1 = V2; Q = 1

V1 > V2; Q = 0

V1 < V2; Q = 0

Примеры применения элементов:


Больше (GT, fGT)

Для сравнения целочисленных переменных (integer) используется блок GT, для переменных с плавающей запятой (float) - блок fGT.

Результатом выполнения операции на выходе является логическая «1», если входное число на верхнем входе (V1) больше числа на втором входе (V2):

V1 = V2; Q = 0

V1 > V2; Q = 1

V1 < V2; Q = 0

Примеры применения элементов:


Выбор (SEL, fSEL)

Для выбора целочисленных переменных (integer) используется блок SEL, для переменных с плавающей запятой (float) - блок fSEL.

Результатом выполнения операции на выходе является входной сигнал V2, если V1 равен логическому «0», и V3, если V1 равен логической «1».

V1 = 0; Q = V2

V1 = 1; Q = V3

Примеры применения элементов:


Сдвиговые функции

Логический сдвиг влево (SHL)

Логический сдвиг вправо (SHR)


Побитовый логический сдвиг влево (SHL)

Элемент используется для выполнения операции побитового логического сдвига операнда X влево на N бит с дополнением нулями справа.

Пример применения для сдвига числа 38 (десятичное) = 00100110(двоичное):


Побитовый логический сдвиг вправо (SHR)

Элемент используется для выполнения операции побитового логического сдвига операнда X вправо на N бит с дополнением нулями слева.

Пример применения для сдвига числа 152(десятичное) =10011000(двоичное):


Битовые функции

Чтение бита (EXTRACT)

Запись бита (PUTBIT)

Дешифратор (DC32)

Шифратор (CD32)


Чтение бита (EXTRACT)

Элемент используется для выполнения операции чтения значения бита N в числе на входе X. Биты нумеруются с нуля. Число на входе Х задается в десятичной системе. Выходное значение всегда двоичное (0 или 1).

Пример применения для чтения пятого бита из числа 81(десятичное) = 1010001(двоичное):


Запись бита (PUTBIT)

Элемент используется для выполнения операции записи в числе X значения бита N в состояние, указанное на входе B (логические «0» или «1»). Число на входе Х задается в десятичной системе. Выходное значение целочисленное.

Пример применения записи четвертого бита в лог. «1» для числа 38(десятичное) = 100110(двоичное):


Дешифратор (DC32)

Элемент используется для выполнения операции преобразования двоичного кода на входе в позиционный код на выходе. Перед выполнением операции над значением на входе предварительно выполняется побитовая логическая операция «И» с операндом 0x1F (11111b).

Работе элемента соответствует приведенная таблица состояний:

Пример применения:


Шифратор (CD32)

Элемент используется для выполнения операции преобразования позиционного кода на входе в двоичный код на выходе.

В случае если входное двоичное значение имеет более одной логической «1» в разрядах, работа элемента ведется только со старшим единичным разрядом.

Работе элемента соответствует таблица состояний:


Функциональные блоки

Триггеры

Таймеры

Генераторы

Счетчики

Регуляторы


Триггеры

RS-триггер с приоритетом выключения

SR-триггер с приоритетом включения

Детектор переднего фронта импульса (RTRIG)

Детектор заднего фронта импульса (FTRIG)

D-триггер (DTRIG)


RS-триггер с приоритетом выключения

Блок используется для переключения с фиксацией состояния при поступлении коротких импульсов на соответствующий вход. Работу поясняет приведенная на рисунке диаграмма.

На выходе блока появится логическая «1» по фронту сигнала на входе S.

При одновременном поступлении сигналов на входы приоритетным является сигнал входа R.


SR-триггер с приоритетом включения

Блок используется для переключения с фиксацией состояния при поступлении коротких импульсов на соответствующий вход. Работу поясняет приведенная на рисунке диаграмма.

На выходе блока появится логическая «1» по фронту сигнала на входе S.

При одновременном поступлении сигналов на входы приоритетным является сигнал входа S.


Детектор переднего фронта импульса (RTRIG)

Блок используется в случае необходимости иметь реакцию на изменение состояния дискретного входного сигнала. На выходе генерируется единичный импульс по переднему фронту входного сигнала.

Работу поясняет приведенная на рисунке диаграмма.


Детектор заднего фронта импульса (FTRIG)

Блок используется в случае необходимости иметь реакцию на изменение состояния дискретного входного сигнала. На выходе генерируется единичный импульс по заднему фронту входного сигнала.

Работу поясняет приведенная на рисунке диаграмма.


D-триггер (DTRIG)

Блок используется для формирования импульса включения выхода на интервал времени импульса на входе D, при этом выходной интервал будет синхронизирован с тактовой частотой на входе С.

На выходе Q блока появится логическая «1» по фронту тактовых импульсов на входе С при наличии логической «1» на входе D. Возврат выхода в «0» произойдет по фронту тактовых импульсов на входе С при логическом «0» на входе D.

Работу поясняет приведенная на рисунке диаграмма.

Вход S обеспечивает принудительную установку выхода Q в состояние логической «1»;

Вход R является приоритетным и обеспечивает установку выхода Q в состояние логического «0».


Таймеры

Импульс включения заданной длительности (TP)

Таймер с задержкой включения (TON)

Таймер с задержкой отключения (TOF)

Интервальный таймер (CLOCK)

Интервальный таймер с недельным циклом (CLOCKWEEK)


Импульс включения заданной длительности (TP)

Блок используется для формирования импульса включения выхода на заданный интервал времени. Работу поясняет приведенная на рисунке диаграмма.

На выходе Q блока появится логическая «1» по фронту входного сигнала (I). После запуска выход Q не реагирует на изменение значения входного сигнала на интервале Tимп, а по истечении этого интервала сбрасывается в «0».

Допустимый диапазон значений Тимп=Т: от 0 до 4147200000 мс, или 48 дней.

Длительность импульса и единицы измерения времени настраиваются на панели свойств:


Таймер с задержкой включения (TON)

Блок используется для операции задержки передачи сигнала. Работу поясняет приведенная на рисунке диаграмма.

На выходе Q блока появится логическая «1» с задержкой относительно фронта входного сигнала (I). Выход включается логической «1» на входе продолжительностью не менее длительности Т, а выключается по спаду входного сигнала.

Допустимый диапазон значений Т: от 0 до 4147200000 мс, или 48 дней.

Время задержки включения и единицы измерения времени настраиваются на панели свойств:


Таймер с задержкой отключения (TOF)

Блок используется для задержки отключения выхода. Работу поясняет приведенная на рисунке диаграмма.

На выходе блока появится логическая «1» по фронту сигнала на входе I, а начало отсчета времени задержки отключения (Tзад) происходит по каждому спаду входного сигнала. После отключения входного сигнала на выходе появится логический «0» с задержкой Tзад.

Допустимый диапазон значений Тзад: от 0 до 4147200000 мс, или 48 дней.

Время задержки выключения и единицы измерения времени настраиваются на панели свойств:


Интервальный таймер (CLOCK)

Настройка времени включения и отключения производится на панели свойств:

Блок используется для формирования импульса включения выхода по часам реального времени. Работу поясняет приведенная на рисунке диаграмма:

Время включения (Твкл) и отключения (Тоткл) выходов устанавливают в качестве параметров блока.

Допустимый диапазон значений Твкл и Тоткл: от 0,00 с до 24 ч.

В случае если заданное значение времени отключения меньше времени включения, то диаграмма переключений будет иметь вид:


Интервальный таймер с недельным циклом (CLOCKWEEK)

Настройка времени включения и отключения производится на панели свойств:

Блок используется для формирования импульса включения выхода по часам реального времени, с учетом дней недели. Работу поясняет диаграмма:

Внутренняя структура блока имеет вид:

Время включения (Твкл), отключения (Тоткл) выхода и дни недели работы устанавливают в качестве параметров блока.

Допустимый диапазон значений Твкл и Тоткл: от 0,00 с до 24 ч.


Генераторы

Генератор прямоугольных импульсов (BLINK)


Генератор прямоугольных импульсов (BLINK)

Блок используется для формирования прямоугольных импульсов пульсации.

На выходе Q генератора формируются импульсы с заданными параметрами длительности включенного (Твкл – логическая «1») и отключенного (Тоткл – логический «0») состояния на время действия управляющего сигнала на входе I (логической «1»).

Допустимый диапазон значений Твкл и Тоткл: от 0 до 4233600000 мс, или 49 дней.

Длительность включенного и отключенного состояний настраиваются на панели свойств:


Счетчики

Инкрементный счетчик с автосбросом (CT)

Универсальный счетчик (CTN)

Инкрементный счетчик (CTU)


Инкрементный счетчик с автосбросом (CT)

Блок используется для подсчета заданного числа импульсов N (вход Т – уставка числа импульсов).

На выходе Q счетчика появится импульс логической «1» с длительностью рабочего цикла прибора (Tцикл), если число приходящих на вход I импульсов достигнет установленного значения N (на входе Т).

Допустимый диапазон значений числа импульсов N: от 0 до 65535.

Число импульсов N и параметр сохранения состояния задаются на панели свойств:


Универсальный счетчик (CTN)

Блок является счетчиком, который используется для прямого и обратного счета. Операция «прямой счет» выполняется по переднему фронту импульса на входе прямого счета (U), что увеличивает значение выходного сигнала «Q».

Импульсы, приходящие на вход D («обратный счет»), уменьшают значение выхода «Q».

При поступлении на вход R логической «1», выход счетчика «Q» устанавливается в значение входа N.

При одновременном поступлении сигналов на входы U и D приоритетным является сигнал входа U.

Допустимый диапазон значений числа импульсов N: от 0 до 65535.

Значение N и параметр сохранения состояния задаются на панели свойств:


Инкрементный счетчик (CTU)

Блок используется для подсчета числа импульсов, приходящих на вход С. На выходе Q счетчика появится импульс логическая «1», если число приходящих на вход импульсов достигнет установленного значения на входе N (N – уставка).

Допустимый диапазон значений числа импульсов N: от 0 до 65535.

Счетчик сбрасывается в 0 по переднему фронту импульса на входе R. При одновременном поступлении сигналов на входы приоритетным является сигнал входа R.

Число импульсов N задается на панели свойств:


Регуляторы

ПИД-регулятор(PID)


ПИД-регулятор (PID)

Функциональный блок используется для реализации пропорционально-интегрально-дифференциального (ПИД) закона регулирования.

Входы блока

Название | Тип | Описание | Значения
E | Bool | Разрешение на работу блока. В выключенном состоянии на выход блока подается значение, заданное в свойстве «выходная мощность». | 0-Выключен 1-Включен
Pv | Float | Текущее значение регулируемой величины. |
Sp | Float | Заданное значение регулируемой величины |

Выходы блока

Название | Тип | Описание | Значения
Pwr | Float | Выходная мощность, % | 0-100

Свойства

Название | Тип | Описание | Значения
Режим работы регулятораBoolРежим работы регулятора
  • режим «нагреватель», используется для управления исполнительными органами, воздействие которых приводит к росту значения регулируемой величины;
  • режим «холодильник», используется для управления исполнительными органами, воздействие которых приводит к снижению значения регулируемой величины.
0-Нагреватель
1-Холодильник
Выходная мощность | Float | Выходная мощность в выключенном состоянии, % | 0-100
Пропорциональный коэффициент | Float | Пропорциональный коэффициент, с которым работает ПИД | 0-100
Время интегрирования | Float | Время интегрирования, с которым работает ПИД, сек | 0-9999
Время дифференцирования | Float | Время дифференцирования, с которым работает ПИД, сек | 0-100
Максимальная мощность | Float | Верхнее ограничение выдаваемой мощности.%. | 0-100 (80)
Минимальная мощность | Float | Нижнее ограничение выдаваемой мощности, %. | 0-100 (20)
Запуск АНР | boolean | Переменная, которая генерирует запуск мавтонастройки регулятора при подаче значения "True". Значение данной перемнной задается с помощью блока "Запись в ФБ".

Автонастройка

Организация процесса автонастройки осуществляется с помощью блоков "Запись в ФБ" и "Чтение из ФБ".

Инструкции по работе с блоками даны в разделе Разработка коммутационной программы.

Разместите на схеме и настройте функциональный блок PID и блоки чтения и записи.

Для запуска автонастройки необходимо добавить блок "Запись в ФБ" и привязать его к переменной "Запуск АНР" функционального блока PID1.

Значения остальных параметров функционального блока могут также задаваться с помощью блока "Запись в ФБ", как показано на рисунке выше, либо настраиваться на панели Свойства.

С помощью блоков "Чтение из ФБ" считываются значения параметров «Рассчитанный пропорциональный коэффициент», «Рассчитанное время интегрирования», «Рассчитанное время дифференцирования » и «Флаг окончания автонастройки».

Для старта автонастройки необходимо, чтобы блок ПИД-регулятора был запущен (вход «E»= "True"). Автонастройка запускается по изменению значения входа «Запуск АНР» на "True".

По завершении процесса автонастройки для чтения доступны новые значения коэффициентов: «Рассчитанный пропорциональный коэффициент», «Рассчитанное время интегрирования» и «Рассчитанное время дифференцирования». Параметр «Флаг окончания автонастройки» выставляется в "True". Если после этого сбросить вход «Запуск АНР» в "False", то сбросится и флаг окончания.

Если сбросить вход «Запуск АНР» в False до окончания настройки, то процесс останавливается, флаг окончания не выставляется, новые значения коэффициентов не вычислены.

Во время процесса настройки на выход функционального блока PID1 подается тестовая мощность, ограниченная значениями параметров «Максимальная мощность» и «Минимальная мощность».

Процесс автонастройки для режима «Нагреватель»

  1. Текущее значение меньше уставки, на выход блока подается максимальная мощность (в соответствии с настройками).
  2. Как только текущее значение станет больше уставки, на выход блока подается минимальная мощность.
  3. Повторение шагов 1 и 2.
  4. Рассчитанные параметры ПИД-регулятора подаются на соответствующие выходы, и выставляется флаг окончания.

Если в настройках указанo значение максимальной мощности, при котором невозможно достичь уставки, процесс автонастройки не закончится, пока он не будет сброшен вручную.


Макросы

Макросы представляют собой пользовательские функциональные блоки, которые можно использовать в проекте.

Перетаскивайте макросы из Библиотеки компонентов на холст проекта:

Рекомендации по созданию макросов приведены в разделе Работа с макросами.

Чтобы удалить макрос из библиотеки, выделите нужный макрос и нажмите


Элементы управления

С помощью содержащихся в данном разделе элементов осуществляется обмен данными между выполняемой коммутационной программой и экраном ПР.

Метка - выводит текстовое сообщение на экран.

Ввод/Вывод (int/float) - организует ввод/вывод на экран значения целочисленной или вещественной переменной.

Ввод/вывод (Boolean) - организует ввод/вывод на экран значения булевской переменной.

Динамический текст - в зависимости от значения переменной программы выводит определенный вариант текстовой строки.

ComboBox - выбор варианта в комбинированном меню и запись числа, соответствующего выбору, в переменную коммутационной программы.

Все элементы размещается в редакторе экранов методом drag&drop. Для более точного расположения задаются координаты экрана на панели свойств.


Метка

Элемент для размещения текстового блока в строке экрана.

Настройка свойств

Для корректного отображения на экране прибора необходимо указать координаты расположения и ввести текст на панели свойства:

Координаты

Необходимо указать координаты расположения первого символа метки по осям X и Y. Отсчет координат по обеим осям начинается с 0:

  • по оси Х - слева направо от 0 до 15 (в зависимости от свойства "Длина");
  • по оси Y - сверху вниз (в зависимости от количества срок экрана, установленного в редакторе экранов).

Чтобы задать значение координат (целое число), нажмите на кнопку со стрелкой в строке координаты (X и Y настраиваются одинаково):

На открывшейся панели можно выбрать способ задания координат: константа или переменная. При выборе неизменного расположения блока "Метка" укажите значение координаты в поле ввода.

Для создания бегущей строки выберите вариант "переменная" и нажмите кнопку "Выбор". Откроется Таблица переменных, выберите в ней переменную целочисленного типа, которая будет определять значение координаты и нажмите "ОК". Выбранная переменная будет отображаться в поле ввода:

Параметры

Текст - введите в поле текст, который будет отображаться на экране прибора. Длина текста не должна превышать значение, указанное для параметра "Длина".

Длина - максимальное количество отображаемых символов блока.

Отображение

В редакторе экранов можно видеть, как будет отображаться блок на экране прибора:


Ввод/Вывод (int/float)

Элемент для вывода на экран ПР или чтения с экрана значения целочисленной или вещественной переменной.

Настройка свойств

Для корректной работы элемента необходимо указать координаты расположения и настроить параметры ввода/вывода на панели свойства:

Диапазон

Контроль - позволяет ограничить значение, которое пользователь вводит с лицевой панели прибора. Это ограничение не распространяется на значение, полученное в ходе работы программы.

Максимум - максимальное значение параметра для ввода

Минимум - минимальное значение параметра для ввода

Координаты

Необходимо указать координаты расположения первого символа метки по осям X и Y. Отсчет координат по обеим осям начинается с 0:

  • по оси Х - слева направо от 0 до 15 (в зависимости от свойства "Длина");
  • по оси Y - сверху вниз (в зависимости от количества срок экрана, установленного в редакторе экранов).

Чтобы задать значение координат (целое число), нажмите на кнопку со стрелкой в строке координаты (X и Y настраиваются одинаково):

На открывшейся панели можно выбрать способ задания координат: константа или переменная. При выборе неизменного расположения блока "Метка" укажите значение координаты в поле ввода.

Для создания бегущей строки выберите вариант "переменная" и нажмите кнопку "Выбор". Откроется Таблица переменных, выберите в ней переменную целочисленного типа, которая будет определять значение координаты и нажмите "ОК". Выбранная переменная будет отображаться в поле ввода:

Параметры

Переменная - привязка к переменной проекта (целочисленной или с плавающей точкой). Нажмите кнопку "..." и выберите переменную в Таблице переменных.

Тип переменной - выбор типа переменной: целочисленный или вещественный. Задается, если переменная еще не привязана. при привязке переменной определяется автоматически.

Знаков - суммарное количество отображаемых знаков до и после запятой.

После запятой - количество знаков после запятой: до 6 знаков или определяется автоматически (Авто). Более подробную информацию читайте в РП на прибор.

Текст до - текст слева от числового значения.

Текст после - текст справа от числового значения.

Редактируемо - если "Да", то значение привязанной переменной можно изменять вводом с прибора.

Длина - общая максимальная длина поля, включающая текст до, значение переменной и текст после.

Отображение


Ввод/Вывод (boolean)

Элемент для вывода на экран ПР или чтения с экрана значения булевской переменной.

Настройка свойств

Координаты

Необходимо указать координаты расположения первого символа метки по осям X и Y. Отсчет координат по обеим осям начинается с 0:

  • по оси Х - слева направо от 0 до 15 (в зависимости от свойства "Длина");
  • по оси Y - сверху вниз (в зависимости от количества срок экрана, установленного в редакторе экранов).

Чтобы задать значение координат (целое число), нажмите на кнопку со стрелкой в строке координаты (X и Y настраиваются одинаково):

На открывшейся панели можно выбрать способ задания координат: константа или переменная. При выборе неизменного расположения блока "Метка" укажите значение координаты в поле ввода.

Для создания бегущей строки выберите вариант "переменная" и нажмите кнопку "Выбор". Откроется Таблица переменных, выберите в ней переменную целочисленного типа, которая будет определять значение координаты и нажмите "ОК". Выбранная переменная будет отображаться в поле ввода:

Параметры

Переменная - привязка к булевской переменной проекта. Нажмите кнопку "..." и выберите переменную в Таблице переменных.

Текст "True" - Текст, соответствующий значению переменной, равному "1".

Текст "False" - Текст, соответствующий значению переменной, равному "0".

Текст до - текст слева от выводимого значения.

Текст после - текст справа от выводимого значения.

Редактируемо - если "Да", то значение привязанной переменной можно изменять вводом с прибора.

Длина - общая максимальная длина поля, включающая текст до, значение переменной и текст после.

Отображение


Динамический текст

Элемент для вывода на экран ПР одной из нескольких текстовых строк в зависимости от значения привязанной переменной.

Настройка свойств

Координаты

Необходимо указать координаты расположения первого символа метки по осям X и Y. Отсчет координат по обеим осям начинается с 0:

  • по оси Х - слева направо от 0 до 15 (в зависимости от свойства "Длина");
  • по оси Y - сверху вниз (в зависимости от количества срок экрана, установленного в редакторе экранов).

Чтобы задать значение координат (целое число), нажмите на кнопку со стрелкой в строке координаты (X и Y настраиваются одинаково):

На открывшейся панели можно выбрать способ задания координат: константа или переменная. При выборе неизменного расположения блока "Метка" укажите значение координаты в поле ввода.

Для создания бегущей строки выберите вариант "переменная" и нажмите кнопку "Выбор". Откроется Таблица переменных, выберите в ней переменную целочисленного типа, которая будет определять значение координаты и нажмите "ОК". Выбранная переменная будет отображаться в поле ввода:

Параметры

Переменная - привязка к целочисленной переменной проекта. Нажмите кнопку "..." и выберите переменную в Таблице переменных.

Список строк - Таблица, в каждой строке которой значению привязанной целочисленной переменной ("Значение") соответствует выводимая на экран текстовая строка ("Текст"). В столбце "Символов" указывается количество символов в строке, восклицательный знак выводится при превышении значения параметра "Длина".

Длина - Максимальная длина поля. При превышении длины текст будет отображаться не полностью.

Отображение


Комбинированный список (ComboBox)

Элемент для выбора одного в меню из нескольких текстовых строк и записи в привязанную переменную значения, соответствующего выбору.

Настройка свойств

Координаты

Необходимо указать координаты расположения первого символа метки по осям X и Y. Отсчет координат по обеим осям начинается с 0:

  • по оси Х - слева направо от 0 до 15 (в зависимости от свойства "Длина");
  • по оси Y - сверху вниз (в зависимости от количества срок экрана, установленного в редакторе экранов).

Чтобы задать значение координат (целое число), нажмите на кнопку со стрелкой в строке координаты (X и Y настраиваются одинаково):

На открывшейся панели можно выбрать способ задания координат: константа или переменная. При выборе неизменного расположения блока "Метка" укажите значение координаты в поле ввода.

Для создания бегущей строки выберите вариант "переменная" и нажмите кнопку "Выбор". Откроется Таблица переменных, выберите в ней переменную целочисленного типа, которая будет определять значение координаты и нажмите "ОК". Выбранная переменная будет отображаться в поле ввода:

Параметры

Переменная - привязка к целочисленной переменной проекта. Нажмите кнопку "..." и выберите переменную в Таблице переменных.

Список строк - Таблица, в каждой строке которой значению привязанной целочисленной переменной ("Значение") соответствует выводимая на экран текстовая строка ("Текст"). В столбце "Символов" указывается количесво символов в строке, восклицательный знак выводится при превышении значения параметра "Длина".

Длина - Максимальная длина поля. При превышении длины текст будет отображаться не полностью.

Отображение


Работа с макросами

Макросы представляют собой комплексные алгоритмические блоки, которые создаются аналогично разработке коммутационной программы. Их можно сохранять в библиотеке компонентов для дальнейшего использования в проекте, экспортировать в файл для использования в других проектах, импортировать созданные ранее макросы или загружать из онлайн базы в библиотеку проекта.

Создание макроса

Работа с макросами выполняется в следующей последовательности:

1) Создание макроса при помощи выбора команды «Файл -> Создать макрос». В открывшемся диалоговом окне задайте количество входов и выходов в макросе:

2) Разработка алгоритма работы макроса

Выполняется на вкладке «Редактор макросов» аналогично разработке основной коммутационной программы.

Количество входов и выходов можно увеличить с помощью контекстного меню редактора или с помощью кнопок .

Чтобы удалить вход или выход, щелкните по нему правой кнопкой мыши и выберите "Удалить".

3) Задание имени и описания для макроса на панели Свойства:

Введенное имя будет указано в заголовке редактора макросов.

4) Определение типов и имен входов/выходов

Выделите курсором вход или выход и настройте его на панели Свойства.

5) Задание «видимости» из коммутационной программы уставок функциональных блоков.

Чтобы уставки выбранного ФБ были доступны при использовании ФБ в коммутационной программе, настройте в окне свойств блока параметр «Использование в макросе»: Да.

6) Сохранение макроса в проекте, выбором команды меню «Файл > Сохранить как новый макрос»

7) Использование макроса в коммутационной программе выполняется выбором вкладки «Макросы» на панели «Библиотека компонентов» и перенесением его на холст основной коммутационной программы.

Экспорт макроса

Экспортировать макрос в файл возможно при открытом окне редактора макроса. Если нужно экспортировать макрос, сохраненный на панели библиотеки, то для открытия редактора необходимо перетащить макрос на холст коммутационной программы и в контекстном меню блока макроса выбрать "Редактировать".

Далее в программе в меню "Файл" нажмите "Экспорт макроса в файл".

В открывшемся окне выберите место расположения и сохраните файл макроса, который будет иметь расширение *.tpl. После этого будет отображено сообщение об успешном экспорте макроса.

Импорт макроса

Чтобы для создания коммутационной программы использовать макрос, созданный в другом проекте, этот макрос нужно импортировать в библиотеку.

Для этого в программе в меню "Файл" нажмите "Импорт макроса из файла".

В открывшемся окне выберите нужный файл и нажмите "ОК". Макрос будет добавлен в библиотеку в раздел "Макросы", теперь его можно использовать в проекте.

Загрузка макроса из онлайн базы

Сервер компании ОВЕН содержит пополняющуюся библиотеку макросов, которые можно загрузить в проект при наличии Интернет подключения.

Чтобы перейти к списку макросов, хранящихся в онлайн базе, в меню Файл нажмите "Онлайн база макросов".

В открывшемся окне в верхней части под надписью «Доступные на сервере» находится список макросов, разделенных по группам. Ниже, под надписью «Установленные в проекте», - список тех макросов, которые добавлены или созданы в текущем проекте.

Файлы макросов разделены на разделы. Откройте нужные разделы. Полное описание макроса можно открыть в формате pdf при клике на имя макроса. Для корректного отображения может потребоваться установка приложения Acrobat Reader, которая будет выполнена автоматически.

Отметьте галочкой макросы, которые нужно загрузить в проект.

Нажмите "Загрузить". Выбранные макросы появятся в списке установленных в проекте.


Дополнения (Плагины)

Каждое дополнение устанавливается отдельно. Для этого следует скачать нужное дополнение со страницы программы и установить:

Программное обеспечение OWEN Logic

  • Создание мастера тиражирования. С помощью мастера тиражирования можно загрузить пользовательскую программу в прибор без участия OWEN Logic.
  • Экспорт устройства в OPC. Позволяет экспортировать спроектированное в программе OwenLogic устройство в OPC-сервер.


Плагин «Мастер тиражирования»

Плагин позволяет создавать из проекта OWEN Logic мастер тиражирования - файл с расширением .exe, содержащий внутри себя пользовательскую программу. С помощью мастера тиражирования можно загрузить пользовательскую программу в прибор без участия OWEN Logic.

Файл может быть защищен с помощью ключа. Если загруженная в прибор программа была зашифрована ключом, то с помощью мастера тиражирования повторно загрузить можно только программу с совпадающим ключом.

Рекомендуется создать текстовый файл с расширением .rtf с описанием проекта. Эта информация будет отображаться при выборе файла в мастере тиражирования перед загрузкой его в прибор.

Создание файла с ключом

Проект может быть зашифрован с помощью ключа.

  1. В меню "Файл" нажмите "Создать файл с ключом".

    Откроется диалоговое окно:

  2. Введите имя файла.

    Ключ генерируется автоматически. Он может быть изменен при нажатии кнопки

  3. Нажмите кнопку "Сохранить".

    Файл с ключом по умолчанию сохраняется в папку ...Документы/Owen Logic/Keys. Его можно перенести в другую папку.

Выбор файла с ключом для проекта

Перед тиражированием укажите в свойствах документа имя файла с ключом, если он создан:

  1. Нажмите в любое пустое место на схеме.
  2. В свойствах документа в строке "Имя файла с ключом" нажмите на кнопку "...".

  3. Выберите созданный для этого проекта файл с ключом.

  4. Нажмите "Открыть".

Создание мастера тиражирования

Для создания мастера тиражирования в программу OWEN Logic должен быть установлен соответствующий плагин. Скачать установочный файл плагина можно по ссылке на сайте компании ОВЕН в разделе "Программное обеспечение" > "Программное обеспечение OWEN Logic" > "Дистрибутивы").

Чтобы приступить к созданию мастера, выполните следующий действия:

  1. Нажмите в меню "Дополнения" на "Создать мастер тиражирования". Если в меню нет раздела "Дополнения", значит, плагин не установлен.

    Откроется окно для создания мастера тиражирования.

    Параметры устройства считываются из прибора и заполняются автоматически.

  2. Заполните поля:
    • Имя конечного файла - имя файла мастера тиражирования, который будет создан.
    • Путь к мастеру тиражирования - расположение создаваемого файла.
    • Файл с описанием алгоритма - текстовый файл с описанием проекта в формате .rtf.

  3. Нажмите "Создать".

При отсутствии ошибок будет создан файл с указанным именем и расширением .exe. Отчёт о создании файла выводится в нижней части окна.

Чтобы скрыть или открыть область отображения отчета, нажмите [image]. Информация о предупреждениях и ошибках выводится, если отмечены соответствующие флажки.

Запись коммутационной программы в прибор через мастер тиражирования

  1. Запустите созданный файл мастера тиражирования.

    При открытии мастера отобразится текст описания проекта из прикрепленного файла с расширением .rtf. Если файл не был прикреплен во время создания мастера, то описание проекта будет пустым.

  2. Нажмите "Далее". В разделе "Настройки порта" укажите номер COM-порта, к которому подключен прибор. Как узнать номер порта, описано в разделе Настройка порта.

    После выбора порта в правом нижнем углу будет отображаться состояние подключения к прибору. При наличии ошибки подключения будет отображен знак "Внимание" и текст ошибки. При наведении на знак "Внимание" отобразится подсказка с описанием ошибки.

    Ошибка
    Возможные причины
    Прибор не подключен
    • Неправильно выбран COM-порт.
    • Не установлен драйвер USB.
    • Разрыв соединения.
    Требуется другой прибор Подключенный прибор не соответствует проекту. Нужно либо заменить прибор в проекте и создать новый мастер тиражирования, либо подключить другой прибор.

    Если никаких ошибок нет, то отображается зеленая галочка с названием прибора.

    Если Происходит постоянное прерывание связи с прибором (галочка мигает), то, возможно, порт USB отнимает другое приложение. Это может быть, если запущена программа OwenLogic и в ней настроено подключение к этому же порту. В таком случае для загрузки проекта в прибор программу следует перевести в режим "OFFLINE".

  3. Если соединение стабильно, нажмите "Далее".

    Предупреждение. В случае выбора и загрузки неверного файла для прошивки с другим ключом текущая пользовательская программа в приборе перестанет функционировать, на экране появится надпись "Программа повреждена!"

  4. Нажмите "Запись". Начнется процесс загрузки алгоритма. В это время нельзя прерывать связь компьютера с прибором. По завершении загрузки будет выведено сообщение.


Экспорт устройства в OPC

Устройство, созданное в программе OwenLogic, может быть добавлено в проект в программе OPC-сервер.

Для экспорта устройства следует выполнить действия:

  1. Экспортировать устройство из OwenLogic: команда главного меню "Дополнения -> Экспорт устройства в ОРС".

  2. В программе ОРС-сервер добавить узел в дерево объектов.
  3. В контекстном меню узла выбрать "Добавить -> Устройство из файла". Откроется окно проводника.
  4. В окне выбрать файл, который был экспортирован из OwenLogic. Нажать "Открыть".
  5. Выбрать протокол обмена с устройством. Нажать "Выбрать".

Устройство и теги будут добавлены в дерево объектов.

В случае необходимости следует изменить опции устройства и тегов.

Для проверки правильности настройки запустите режим опроса.

Инструкции по работе с программой "OPC-сервер" приведены в справке к программе.


Переменные

Чтобы добавить текстовый комментарий на схему, на панели Вставки нажмите кнопку

. Затем нажмите на то место схемы, где должен располагаться комментарийи , удерживая левую кнопку мыши начертите прямоугольную область тексового блока.

Для выделенного блока комментария можно изменить настройки ввода текста на панели Свойства:

Чтобы ввести тест комментария, выделите двойным щелчком мыши текстовый блок, введите новый текст:

Можно добавить комментарии к компонентам на схеме, которые будут отображаться при наведении курсора на компонент. Для этого на панели Свойства в поле "Комментарий" введите текст.


Задание порядка исполнения

Вычисление значений всех выходов и обратных связей в коммутационной программе происходит в определенном порядке. Чтобы этот порядок изменить, нажмите на панели отладки в выпадающем меню кнопку "Обратные связи" или "Выходы".

Чтобы изменить очередность выполенения, двойным щелчком мыши выделите нужный выход или обратную связь и введите число, какой по счету должна выолняться данная операция.

После установления правильной очередности отключите режим настройки порядка исполнения, отключив кнопку "Обратные связи" или "Выходы".

Готовая программа может быть загружена в прибор.


Перенумеровать компоненты

Переназначение порядковых номеров функциональных блоков схемы: пользователь может автоматически переназначить нажатием кнопки [image] Перенумеровать компоненты на панели инструментов. Одноименнпые блоки нумеруются по порядку сверху вниз и слева направо:


Выходы

Добавление комментариев выходам прибора осуществляется на панели свойств или на панели Настройка прибора -> Выходы:

Текст введенного комментария будет отображаться во всплывающей подсказке при наведении курсора на данный выход на схеме.

В зависимости от типа выходов прибора различаются параметры для настройки.

Чтобы правильно настроить выходы ПР, обратитесь к руководству по эксплуатации прибора.