Используемые аббревиатуры и термины
  ОWEN Logic — cреда программирования, разработанная компанией ОВЕН.
  FBD (Function Block Diagram) — графический язык (диаграмм функциональных блоков) предназначен для визуального программирования.
  Коммутационная программа, проект — программа, созданная пользователем в OWEN Logic для последующей записи в прибор.
  Логический сигнал («сигнал») — дискретная физическая величина (напряжение или ток), принимающая только два значения: включено – соответствует логической «1» (лог. «1»), и отключено – логическому «0» (лог. «0»).
  ЛКМ — левая кнопка мыши.
  Макрос — функциональный блок, разработанный пользователем.
  ПЗУ — постоянное запоминающее устройство. Энергонезависимая память, используется для хранения массива неизменяемых данных.
  ПК — персональный компьютер.
  ПКМ — правая кнопка мыши.
  ПО, программа — программное обеспечение.
  Прибор — программируемое устройство, например ПР200.
  Преобразователь — устройство, через которое прибор подключается к ПК.
  ОЗУ — оперативное запоминающее устройство. Энергозависимая часть памяти прибора, в которой во время работы хранится выполняемый код (программы), а также входные, выходные и промежуточные данные, обрабатываемые процессором.
  Уставка — заданное значение параметра функционального блока (установленный режим).
  Функциональный блок (ФБ) — структурная единица программы, которая после выполнения выдает одно или более значений. Может быть создано множество поименованных экземпляров (копий) функционального блока.
  Функция — структурная единица программы, которая после выполнения выдает только один элемент данных, который рассматривается как результат. Функция не хранит информацию о своем внутреннем состоянии, то есть вызов функции с одними и теми же фактическими параметрами выдает то же значение.
  Холст, схема — поле для размещения графических компонентов проекта и редактирования соединительных цепей между ними.
  Цикл — время выполнения прибором заданной коммутационной программы (зависит от количества выполняемых операций в программных цепях).
  ЭСППЗУ — электронно-стираемое программируемое постоянное запоминающее устройство: часть интегральной схемы микропроцессора, используемая для хранения данных.


О программе
OWEN Logic – среда программирования, предназначенная для создания алгоритмов работы коммутационных приборов, относящихся к классу программируемых реле , в частности, приборов серий ПР1хх и ПР200 производства компании ОВЕН. Для составления программы используется визуальный язык на основе графических блоков (FBD), применяемых в цифровых электрических схемах.
Приборы применяются для построения автоматизированных систем управления и замены релейных систем защиты и контроля. В случае использования, например, ПР200, требуется меньше переключающих устройств для решения ряда задач малой автоматизации, что снижает затраты на проектирование и изготовление систем, а также повышает их надежность.
Перечень приборов, для программирования которых может использоваться OWEN Logic представлен на сайте.


Назначение
OWEN Logic позволяет пользователю разработать коммутационную программу по собственному алгоритму с последующей записью ее в энергонезависимую память прибора.
Одновременно среда программирования может работать только с одним проектом. Во время создания проекта не требуется подключения прибора.
Последовательность операций для разработки проекта:
1. Установка среды программирования OWEN Logic на ПК.
2. Запуск среды программирования.
3. Создание нового проекта (для конкретной модели прибора) или открытие существующего проекта для редактирования.
4. Сохранение проекта на жестком диске ПК.
5. Отладка проекта в режиме симуляции.
6. Загрузка проекта в прибор.


Требования к ПК
Минимальная конфигурация:
• Процессор Intel Atom 1.5 ГГц;
• Оперативная память 1 Гб;
• Свободное место на диске 100 Мб;
• Операционная система Windows XP/7/8/10;
• Свободный USB порт для подключения прибора;
• Клавиатура и мышь;
• Дисплей с разрешением 1024 × 768.
Рекомендуемая конфигурация:
• Процессор Intel Core i3 2 ГГц;
• Оперативная память 4 Гб;
• Свободное место на диске 200 Мб;
• Операционная система Windows XP/7/8/10;
• Свободный USB порт для подключения прибора;
• Клавиатура и мышь;
• Дисплей с разрешением 1280 × 800.
Необходимо подключение к Интернет в случаях:
• для обновления OWEN Logic;
• для обновления прошивок устройств;
• для загрузки шаблонов сетевых устройств;
• для загрузки макросов в Менеджере компонентов.
Для работы OWEN Logic требуется программная платформа «.NET Framework 4.0». Если программная платформа «.NET Framework 4.0» не установлена, то запрос на ее установку появится автоматически.


«Горячие» клавиши
Сочетание клавиш | Действие
Меню/Файл
Ctrl + N | Создать новый проект
Ctrl + О | Открыть существующий проект
Ctrl + Alt + S | Сохранить открытый проект под другим именем
Ctrl + S | Сохранить открытый проект
Ctrl + Р | Печать
Меню/Вид
Ctrl + Z | Отменить последнее изменение
Ctrl + Y | Вернуть (восстановить) отмененное действие
Меню/Прибор
Ctrl + F7 | Записать программу в прибор
Меню/Помощь
F1 | Вызов справки
Клавиши работы с элементами
Ctrl + С | Копировать выделенный элемент(ы) в буфер обмена
Ctrl + V | Вставить из буфера обмена
Delete | Удаление выбранного элемента
Клавиши изменения размера элемента
Ctrl + → | Увеличение ширины выделенного элемента
Ctrl + ← | Уменьшение ширины выделенного элемента
Ctrl + ↓ | Уменьшение высоты выделенного элемента
Ctrl + ↑ | Увеличение высоты выделенного элемента
Масштабирование
Ctrl + Колесо мыши | При вращении колеса мыши «от себя» масштаб холста увеличивается. Если «на себя» то уменьшается


Время цикла
Время цикла это, в общем случае, временной отрезок за который прибор:
• опрашивает состояние физических входов и копирует их значения в память;
• обеспечивает работу пользовательской программы;
• записывает результаты работы пользовательской программы в физические выходы;
• производит чтение/запись сетевых переменных.
По умолчанию время цикла равно 1 мс. Прибор подстраивает время цикла в зависимости от сложности пользовательской программы.
Время цикла увеличивается если:
• возрастает сложность алгоритма (задействовано большое число ФБ и макросов);
• в проекте используется большое число сетевых переменных;
• используется большое число элементов для работы с данными при помощи экрана прибора.
Пользователь не может задавать время цикла. Если прибор оснащен экраном, то текущее время цикла можно посмотреть с помощью системного меню. Если прибор подключен к ПК, то время цикла можно посмотреть с помощью пункта меню Информация о приборе OWEN Logic.


Принцип выполнения коммутационной программы
Программа для прибора составляется с учетом количества имеющихся у него входов, выходов и наличия часов реального времени.
Функциональная схема работы прибора:
Работу прибора можно представить в виде последовательно выполняемых шагов (рабочий цикл):
1. Логическое состояние входов автоматически записывается в ячейки памяти входов (количество ячеек равно числу входов, например, I1…I8).
2. Коммутационная программа считывает значения из ячеек памяти входов и выполняет над ними логические операции в соответствии со схемой.
3. После обработки всей коммутационной программы результаты записываются на физические выходы прибора (для включения выходных элементов Q1…Q4).
4. Переход к Шагу 1 (после выполнения всех предыдущих шагов обработки коммутационной программы цикл работы прибора повторяется с первого шага).
Время выполнения всех шагов зависит от сложности алгоритма коммутационной программы.


Начало работы
Для начала работы следует:
1. Запустить OWEN Logic и создать проект;
2. Если нужно, настроить порт;
3. Если нужно, настроить прибор;
4. Создать пользовательскую программу;
5. Отладить пользовательскую программу;
6. Загрузить программу в прибор.


Быстрый старт
В данном разделе на примерах объясняется процесс создания программ в OWEN Logic.
Включатель света с автоматическим отключением
Автоматическое управление электромотором мешалки
Вывод значения переменной на экран
Задание уставок таймеров с экрана
Пример подключения ПР200 к OwenCloud через шлюз ПМ210 по протоколу Modbus RTU
Упаковка/распаковка бит/целых чисел
Обработка битовых переменных с помощью маски


Включатель света с автоматическим отключением
В подсобных помещениях и коридорах электрический свет нужен ограниченное время. После включения освещения, его нередко забывают отключить, что приводит к излишнему расходу электроэнергии.
Задача — свет должен включаться на заданный интервал времени, например, у входной двери в квартиру, по следующему алгоритму:
1. Перед входной дверью устанавливаются датчик освещения (F1) и кнопка включения света ТАЙМЕР (SB1).
2. Если недостаточно естественного освещения, то светильник должен включаться кратковременным нажатием кнопки ТАЙМЕР на одну минуту – достаточно, чтобы найти замочную скважину и ключом открыть дверь.
3. Если удерживать кнопку ТАЙМЕР в течение 2 секунд, то светильник должен включаться на три минуты независимо от внешнего освещения – данный режим может потребоваться при уборке коридора.
4. Светильник должен управляться командами от внешних управляющих устройств или с помощью включателя СВЕТ (SA1), вне зависимости от внешнего освещения. Данный режим удобен во время приема гостей или для дальнейшей автоматизации квартиры в рамках системы «умный дом».
5. Светильник должен включаться только в вечернее и ночное время.
Выбор программируемого прибора
Для реализации данной задачи у управляющего прибора задействуются встроенные часы реального времени, три входа и один выход. Данный функционал обеспечивают приборы из серии ПР110, имеющие последнюю букву «Ч» в обозначении.
Для реализации системы на основе ПР110-24.8Д.4Р-Ч можно воспользоваться схемой:
Создание коммутационной программы
На этапе планирования составляется схема реализации поставленной задачи на основе логических элементов и функциональных блоков, доступных в программе.
Схема может иметь вид:
Выход Q2 схемы используется как контрольный для проверки функционирования логической части (элементов D1–D6). Выход Q1 является основным и может включиться только в заданные таймером D7 интервалы времени в случае соблюдения логических условий, обеспечиваемых элементами D1–D6.
Описание работы схемы:
1. Если кратковременно (менее 2 с) нажать на кнопку ТАЙМЕР (SB1), логическая «1» поступает на вход логического элемента И (D2). Так как на втором входе D2 также присутствует логическая «1», на выходе D2 появится логическая «1», которая запустит формирователь импульса (D3) длительностью 1 мин. Этот импульс через элемент ИЛИ (D6) поступит на выход Q2.
2. Контакты датчика F1 замыкают цепь только в случае наличия естественного освещения – тогда логическая «1» на входе D1 преобразуется в логический «0» на выходе и поступает на вход логического элемента И (D2), что блокирует работу D2. В данном случае нажатие кнопки ТАЙМЕР не включит выход Q2.
3. Если удерживать кнопку ТАЙМЕР более 2 с, на выходе блока D4 появится логическая «1», которая запустит формирователь импульса (D5) длительностью 3 мин. Данный импульс через элемент ИЛИ (D6) поступит на выход Q2 (интервал действия импульса не зависит от состояния датчика F1).
4. Если тумблер «СВЕТ» (SA1) включен, логическая «1» через элемент ИЛИ (D6) поступит на выход Q2 (на время включения SA1).
5. Если на второй вход логического элемента И (D8) поступает логическая «1» (от таймера реального времени D7) вместе с сигналом логической «1» с выхода элемента ИЛИ (D6), на выходе Q1 появится логическая «1» (выходное реле Q1 включится).
Программа работы:


Автоматическое управление электромотором мешалки
Для производства пищевых продуктов часто требуется перемешивать компоненты (например, молоко или сливки на молочной ферме) в течение определенного времени.
Задача обеспечить работу установки по следующему алгоритму:
1. В системе должны быть два режима работы: «Автоматический» и «Ручной», переключаемых тумблером «РЕЖИМ» (SA1).
2. В автоматическом режиме электромотор должен включаться и отключаться нажатием кнопки ПУСК (SB1) через заданные интервалы времени (15 с – включен, 10 с – отключен). Установка должна отключаться через интервал в 5 минут или с помощью кнопки СТОП (SB2).
3. В ручном режиме электромотор должен управляться кнопками (без временных интервалов отключения).
4. В случае перегрузки электромотора (на котором устанавливается соответствующий датчик – F1) установка должна автоматически отключаться с индикацией режима «Неисправность» лампой (HL1) и звуковым прерывистым сигналом (интервал повторения звукового сигнала – 3 с).
5. Звуковой сигнал должен отключаться кнопкой СБРОС (SB3).
6. С помощью кнопки КОНТРОЛЬ (SB4) должна проверяться исправность элементов сигнализации – работа лампы и звукового сигнала.
Выбор программируемого прибора
Для реализации данной задачи управляющий прибор должен иметь шесть входов (по числу управляющих сигналов) и три выхода, что обеспечивает любая модель прибора из серии ПР110.
При выполнении системы на основе ПР110-24.8Д.4Р можно воспользоваться схемой:
Электрическая схема подключения: SA1 – переключатель OFF-ОN, SB1–SB4 – кнопки без фиксации OFF-ОN, M1 – электромотор, HA1 – звонок, HL1 – индикаторная лампа.
Работу программы прибора можно представить в виде цепей схемы, приведенной ниже (выходы Q1–Q3 соответствуют двум контактам клеммника ПР110-24.8Д.4Р).
Описание работы схемы
Цепь входа I2 (включение установки): в случае нажатия кнопки ПУСК (SB1) на входе S (D1) появляется логическая «1» – на выходе RS-триггера D1 установится логическая «1». Данный сигнал поступает дальше в зависимости от состояния включателя SA1:
• если контакты SA1 (РЕЖИМ – Ручной) разомкнуты, логическая «1» проходит через элементы D8, D9 и поступает на выход Q1 (контактами выходного реле включится электромотор М1);
• если контакты SA1 (РЕЖИМ – Автоматический) замкнуты, логическая «1» проходит только через элемент D3 для запуска работы блоков D4, D5.
Цепь входа I3 (отключение установки): при нажатии кнопки СТОП (SB2) или срабатывании датчика F1 на входе R (D1) появляется логическая «1» – на выходе RS-триггера (D1) установится логический «0» (включение выхода Q1 блокируется).
Цепь входа I1 (формирование интервалов работы электромотора): если триггер D1 включен, и контакты включателя SA1 (РЕЖИМ – Автоматический) замкнуты:
• сигнал логической «1» от SA1 проходит через элемент D3 и поступает на D4 (формирователь импульса с задержкой 5 мин). Данный импульс, проходя через элемент ИЛИ (D2), поступит на вход R триггера D1, и установка отключится;
• сигнал логической «1» с выхода D3 поступает на D5 – генератор импульсов с параметрами: логическая «1» – 15 с, логический «0» – 10 с. Данные импульсы c выхода генератора проходят через элемент ИЛИ (D8) и поступают на выход Q1 для управления работой электромотора M1;
• Если контакты включателя SA1 (РЕЖИМ – Ручной) разомкнуты, то логический элемент D3 заблокирован, и сигнал с выхода триггера D1 через элемент D6 сразу поступает на выход Q1, т. е. в данном режиме состояние выхода триггера управляет работой электромотора M1.
Цепь входа I6 (включение звуковой сигнализации): в случае срабатывания датчика F1 на входе S (D9) появляется логическая «1» – на выходе RS-триггера D9 установится логическая «1», которая включает генератор D10 с параметрами: логическая «1» – 3 с, логический «0» – 3 с. Данные импульсы проходят через элемент ИЛИ (D12) и поступают на выход Q2 для управления работой звонка HA1.
Цепь входа I7 (отключение звуковой сигнализации): в случае нажатия кнопки СБРОС (SB3) на входе R (D9) появляется логическая «1» – на выходе RS-триггера установится логический «0», и генератор D10 отключается.
Цепь входа I8 (контроль работы лампы и звуковой сигнализации): при нажатой кнопке КОНТРОЛЬ (SB4) логическая «1» через элемент ИЛИ (D11) поступает на включение выхода Q3 – лампа HL1 включится. Если контакты датчика F1 замкнуты, то выход Q3 включается. При нажатой кнопке КОНТРОЛЬ (SB4) логическая «1» через элемент ИЛИ (D12) поступает на включение выхода Q2, и звонок HA1 включится.
Коммутационная программа будет иметь вид:
ПРЕДУПРЕЖДЕНИЕ
1. Оставшиеся свободные два входа и один выход можно использовать для введения дополнительных функций. Например, переключать четыре разных интервала длительности автоматической работы электромотора или изменять другие рабочие параметры установки.
2. Технологический цикл работы установки можно сделать полностью автоматическим, если схему дополнить инкрементным счетчиком (CT), выходным сигналом которого можно выключать триггер D1.


Вывод значения переменной на экран
Есть прибор и подключенный к нему по RS-485 модуль ввода.
Необходимо считать с модуля значения на входах 1 и 2 и вывести их на экран прибора.
Создадим новый проект в OWEN Logic.
Подключим шаблон сетевого устройства в проект. Для этого запустим Менеджер компонентов и отсортируем компоненты по «Шаблоны сетевых устройств». Из сгенерированного списка выберем МВ110–8А и нажатием на кнопку «Загрузить в проект» скачаем шаблон.
Далее через меню Настройки прибора подключим этот шаблон к конфигурации прибора.
После добавления шаблона сетевого устройства в Таблице переменных необходимо уточнить имена и типы переменных, которые планируется выводить на экран (Izm_fl1 и Izm_fl2). Это температуры, измеренные модулем, и передаваемые в прибор по протоколу Modbus. Переменные имеют тип «с плавающей запятой», т. е. могут иметь целую и дробную часть, а также знак.
Для настройки отображения переменных следует перейти в Менеджер экранов. По умолчанию, при создании нового проекта в OWEN Logic здесь создается один начальный экран. В дальнейшем, по мере необходимости, количество экранов несложно увеличивать, добавляя новые и настраивая переходы между ними. Для нашей задачи пока будет достаточно одного экрана.
Двойным кликом по экрану открыть окно его редактирования.
Рядом с рабочей областью появляется окно библиотеки Компонентов. Если у вас его нет, зайдите в главное меню и поставьте галочку в разделе Вид → Панель библиотек. Также полезно проконтролировать наличие галочки в пункте Вид → Панель свойств. Оба этих окна будут нужны дальше.
Из библиотеки компонентов добавляем элемент «Ввод/вывод (int/float)». Его добавление на рабочую область экрана позволяет выводить значения целых переменных и переменных с плавающей запятой.
Двойным кликом по элементу, переходим к Окну свойств. Для каждого добавленного элемента отображения необходимо в первую очередь указать ту переменную в проекте, с которой будет связан этот элемент. По умолчанию Ввод/вывод настроен на работу с вещественными переменными, т. е. с типом данных «с плавающей запятой». Проверьте эту настройку в окне Свойств, в пункте «Тип переменной». Дальше нам необходимо в строке «Переменная» кликнуть на <не выбрана>, и нажать кнопку «...».
Откроется Таблица переменных. В ней выбираем нужную переменную, например, Izm1 на вкладке «RS-485, Слот1».
В поле «Знаков» указать, сколько знаков всего вам необходимо выводить для значения выбранной переменной. А в поле «После запятой» указываете количество дробных разрядов. В настройках число будет выводиться в формате XXX.Y, с десятыми долями. «Текст до» и «Текст после» формируют фиксированные надписи, сопровождающие выводимое значение.
Следует поставить пробелы в нужных местах, чтобы надписи не сливались с числами и были хорошо читаемы. Эти два поля можно оставлять пустыми, если нужно сэкономить место на экране. В поле длина указывается общее количество знаков для данного элемента.
Поле «Редактируемо» предполагает включение возможности изменять выводимое число с кнопок прибора. Здесь следует поставить «нет», так как менять измеренные на модуле значения температур нельзя.
На этом настройка одного элемента «Ввод/вывод» завершена. Для упрощения дальнейшей работы скопируем этот элемент со всеми настройками. Для этого следует кликнуть на нем ПКМ. В контекстном меню выбираем «Копировать» (или следует воспользоваться сочетанием клавиш Ctrl + C).
Затем необходимо опять воспользоваться контекстным меню и использовать «Вставить» (или следует воспользоваться сочетанием клавиш Ctrl + V), для добавления элемента поверх существующего. После следует перетащить блок на новое место, например, на вторую строку экрана. Далее, во втором блоке меняем переменную на Izm_fl2 и заменяем текстовый блок на Т2.
Проект готов к загрузке в прибор.


Задание уставок таймеров с экрана
Необходимо управлять задержками ФБ Blink и TP с экрана. Предусмотреть возможность преобразования задержек в миллиcекунды, секунды или часы.
Необходимо отображать заданную уставку ФБ на экране прибора.
Для реализации алгоритма был выбран ПР200. Холст программы с элементами приведен ниже.
Функциональные блоки Blink и TP принимают в качестве уставок переменные в формате INT с дискретностью 1 мс.
Чтобы пересчитать уставки под нужные единицы времени следует:
• для отображения значений в секундах, следует разделить введенное значение на 1000;
• для отображения уставок в минутах следует разделить введенное значение на (60 ∙ 1000);
• для отображения уставок в часах. следует разделить введенное значение на (60 ∙ 60 ∙ 1000).
Если необходимо выводить значение уставки с десятичными знаками, следует перевести число в формат float и поделить на соответствующий коэффициент.
Пример
Нужно перевести 2500 миллисекунд в секунды. Для этого: 2500 мс / 1000 = 2,5 с.


Пример подключения ПР200 к OwenCloud через шлюз ПМ210 по протоколу Modbus RTU
Будем считать, что ПМ210 уже подключен к ПР200 и настроен для работы.
Создайте проект для ПР200 в среде Owen Logic. На вкладке Настройки прибора задайте следующие сетевые настройки:
В настройках слота укажите адрес 1 и добавьте следующие сетевые переменные:
Обратите внимание, что переменная с плавающей точкой (rVar) занимает два регистра в памяти прибора (в данном случае – 513 и 514).
Создайте экран визуализации и добавьте на него элементы Ввод-выход Int и Ввод-вывод Float. Привяжите к ним переменные wVar (Int) и rVar (Float). В настройках элементов для параметра Редактируемо поставьте значение Да, чтобы иметь возможность изменять их с дисплея ПР200.
Загрузите проект в ПР200 (Прибор – Загрузить программу в прибор).
Зайдите на главную страницу сервиса OwenCloud. Если вы еще не зарегистрированы в сервисе – необходимо пройти процедуру регистрации.
Перейдите на вкладку Администрирование, откройте вкладку Приборы и нажмите кнопку Добавить прибор ( [image] ).
Укажите следующие настройки:
• Идентификатор – введите IMEI сетевого шлюза (указан на корпусе шлюза);
• Тип прибора – выберите тип Произвольное устройство Modbus;
• Адрес в сети – укажите адрес 1;
• Название прибора – введите название прибора (например, ПР200);
• Часовой пояс – укажите часовой пояс, в котором находится прибор.
Нажмите кнопку Добавить.
Нажмите на название прибора, чтобы перейти к его настройке:
На вкладке Общее/Общие настройки укажите скорость опроса и настройки COM-порта прибора в соответствии с настройками в OWEN Logic. Нажмите кнопку Сохранить для применения новых настроек. При необходимости вы можете изменить и другие настройки (например, период опроса).
На вкладке Параметры/Настройки параметров Modbus добавьте параметры вручную. Обратите внимание, что адреса регистров указываются в HEX – поэтому используемые значения отличаются от тех, которые приведены в OWEN Logic [512 (DEC) = 200 (HEX)].
Нажмите на пиктограмму , чтобы перейти к просмотру значений параметров прибора. Измените значения переменных с дисплея ПР200 и наблюдайте соответствующие изменения в OwenCloud. При необходимости изменения значений из облачного сервиса перейдите на вкладку Запись параметров.


Упаковка/распаковка бит/целых чисел
В данном примере описана работа макросами из Менеджера компонентов. Подробные описания макросов доступны в Менеджере компонентов.
Пример работы макросов
Необходимо считывать состояние входов прибора и выводить на экран состояние выбранного входа.
На иллюстрации ниже приведен холст проекта и настройки вывода на экран.


Обработка битовых переменных с помощью маски
По сигналу выходы включаются или выключаются. Если реализуется дополнительное условие — срабатывает вход 1, то выходы 2, 4, 6 и 8 должны принимать инвертированное состояние относительно текущего.
Для задания состояний выходов воспользуется макросами из Менеджера компонентов — BOOL_INT и INT_BOOL.
Дополнительное условие данного примера можно реализовать с помощью побитного исключения XOR. В качестве маски воспользуемся целочисленной константой — 170 (10101010 в двоичном виде).
Пример холста в режиме симуляции приведен ниже.


Описание интерфейса
После запуска OWEN Logic на мониторе ПК открывается Главное окно программы:
Главное окно программы содержит:
• заголовок окна (верхняя строка с названием программы): после создания проекта в заголовке автоматически выводится путь к файлу проекта;
• главное меню программы: Файл, Вид, Прибор, Сервис, Помощь;
• панели инструментов для быстрого вызова часто используемых действий;
• панели Библиотека компонентов и Свойства и Переменные (до открытия проекта в них нет информации);
• рабочую область проекта – поле редактирования коммутационной программы (до открытия проекта пустое);
• статусную строку внизу главного окна, показывающую состояние программы OWEN Logic и наличие подключения к ней прибора.
Панели инструментов
Для удобства пользования программой основные функции главного меню вынесены на панели в виде пиктограмм.
Панель инструментов
Новый проект | Открывает новый проект. Текущий проект при этом закрывается.
Открыть проект | Открывает для редактирования ранее созданный и сохраненный проект.
Сохранить проект | Сохраняет текущий проект в файле (кнопка неактивна, пока проект не создан). При первом сохранении вызывает окно для присвоения имени файлу.
Печать | Отправка открытой схемы проекта на печать.
Копировать | Копирование выделенного в рабочей области элемента.
Вставить | Вставка скопированного элемента.
Отменить | Отмена последнего действия в проекте.
Восстановить | Повтор отмененного действия.
Записать программу в прибор | Запускает запись созданного проекта в прибор.
Информация | Вызывает информационное окно с версией программного обеспечения в ПР и целевом назначении проекта (модели прибор, для которой разработан проект).
Настройки прибора | Вызывает меню с настройками прибора
Таблица переменных | Открывает таблицу для добавления переменных в проект.
Панель отладки
Режим симулятора | Запуск режима моделирования работы коммутационной программы.
Порядок исполнения | Позволяет изменить порядок вычисления значений на выходах коммутационной программы или макроса и порядок передачи значений по обратным связям.
Перенумеровать компоненты | Изменяет нумерацию функциональных блоков, расположенных в рабочей зоне проекта (кнопка неактивна, пока проект не создан).
Описание работы с симулятором приведено в разделе Отладка коммутационной программы.
Панель вставки
Панель содержит пиктограммы элементов для быстрого размещения их на схеме проекта.
Блок комментариев | Добавление комментария на схему проекта.
Создание блока выходной переменной | Обеспечение удобства выполнения связей на схеме (без указания соединительной линии).
Создание блока входной переменной | Обеспечение удобства выполнения связей на схеме (без указания соединительной линии).
Создание блока константы | Задание фиксированных числовых значений (пороговых или уставок) для ФБ, работающих с целочисленными значениями.
Линия задержки | Создание задержки на 1 цикл.
Создание сетевой выходной переменной | Создание переменной, значение которой задается по сети.
Создание сетевой входной переменной | Создание переменной, значение которой задается по сети.
Создание блока записи в ФБ | Подача значений переменной на вход ФБ, на схеме может не отображаться соединительная линия цепи передачи сигнала.
Создание блока чтения из ФБ | Чтение значений переменной с выхода ФБ, на схеме может не отображаться соединительная линия цепи передачи сигнала.
Преобразователь в булевское значение | Преобразовывает целочисленное значение сигнала в булевское.
Преобразователь в целочисленное значение | Преобразовывает булевское значение сигнала в целочисленное.
Преобразователь в число с плавающей точкой | Преобразовывает целочисленное значение сигнала в число с плавающей точкой.


Главное меню
Файл
Новый проект | Открывает новый проект. Текущий проект закрывается
Смена целевой платформы | Открывает диалоговое окно смены модификации прибора для выполнения пользовательской программы
Открыть проект | Открывает для редактирования ранее созданный и сохраненный проект
Сохранить текущий документ | Сохраняет открытый документ
Сохранить проект | Пересохраняет проект под текущим именем
Сохранить проект как | Открывает диалоговое окно для выбора расположения и ввода нового имени проекта
Создать файл с ключом | Создает файл ключа (подробнее см. Мастер тиражирования)
Сведения о проекте | Открывает меню сведений о проекте
Создать макрос | Открывает редактор макросов
Сохранить как новый макрос | Запрашивает новое имя макроса и сохраняет его
Импорт макроса из файла | Импортирует макрос из файла в библиотеку компонентов
Экспорт макроса в файл | Открывает окно для выбора расположения и имени экспортируемого макроса
Менеджер компонентов | Открывает меню Менеджера компонентов
Печать | Вывод проекта на печать
Последние проекты | Список недавно открытых проектов
Выход | Выход из программы
Вид
Отменить | Отменить действие в редакторе
Восстановить | Восстановить отмененное действие в редакторе
Стиль интерфейса | Выбор цветовой темы программы
Индикаторы состояний | Меню для включения и отключения индикаторов в статусной строке
Панель библиотек | Скрыть/отобразить панель Библиотек
Панель свойств | Скрыть/отобразить панель Свойств
Переменные | Скрыть/отобразить панель Переменные
Менеджер экранов | Скрыть/отобразить Менеджер экранов Меню доступно для приборов с экраном
Сбросить расположение панелей | Отменяет пользовательские настройки положения панелей и возвращает их к «по умолчанию»
Прибор
Записать программу в прибор | Записывает в прибор коммутационную программу, созданную в открытом проекте
Обновить встроенное ПО | Запускает обновление прошивки подключенного прибора
Информация | Отображает информацию о подключенном приборе
Таблица переменных | Открывает таблицу переменных проекта
Юстировка входов/выходов | Открывает панель юстировки
Настройка прибора | Вызывает панель Настройка прибора
Настройка порта | Вызывает панель Настройка порта
Сервис
Перенумеровать компоненты | Автоматическая нумерация ФБ по порядку на схеме
Режим симулятора | Запускает режим симуляции коммутационной программы
Режим OFFLINE | Запрещает опрашивать прибор по USB.
Расширения
ПРИМЕЧАНИЕ
Данное меню по умолчанию содержит один пункт — Управление расширениями. Другие появляются по мере установки расширений, подробнее см. Установка расширений.
Управление расширениями | Запускает мастер установки расширений
Экспорт устройства в ОРС | Запускает расширение «Экспорт устройства в ОРС»
Экспорт устройства в OwenCloud | Запускает расширение «Экспорт устройства в OwenCloud»
Мастер тиражирования | Запускает расширение «Мастер тиражирования»
Помощь
Автопроверка нового релиза | OWEN Logic будет автоматически проверять доступность нового релиза на сервере обновления
Проверить обновления... | Вызов диалогового окна для установки новых версий программного обеспечения
Справка | Вызов справки
История версий | Открывает в браузере список версий программы с описанием
О программе | Информация о текущей версии программы


Информация о проекте
Данное меню содержит сведения о проекте.
Вкладка ”Общие”
На этой вкладке содержится информация о версиях OWEN Logic, в которых создавался и изменялся проект.
Вкладка ”Алгоритм”
ПРИМЕЧАНИЕ
Данная вкладка доступна только для ПР200.
На этой вкладке содержится информация о версиях пользовательской программы.
По нажатию кнопки “ОК” изменения сохраняются. А по нажатию ”Отмена” — сбрасываются.


Менеджер компонентов
Сервер компании ОВЕН содержит пополняющуюся библиотеку компонентов, которые можно загрузить в проект при наличии Интернет-подключения.
Чтобы перейти к списку компонентов в меню Файл следует выбрать «Менеджер компонентов».
В открывшемся окне будет показан список компонентов.
Компоненты можно фильтровать по типам, группам и имени. Выпадающий список позволяет быстро выбирать категорию — Все/Макросы/Шаблоны сетевых устройств.
Макросы дополнительно разделены на группы, в зависимости от назначения.
Полное описание компонента можно прочитать, кликнув на его имя. Для корректного отображения может потребоваться установка приложения Acrobat Reader, которая будет выполнена автоматически. Над полем с полным описанием выводится краткая информация о компоненте.
Чтобы загрузить необходимые компоненты в проект следует воспользоваться рекомендациями раздела Добавление компонента .
Вкладка «Библиотека» — локальное хранилище компонентов на диске компьютера пользователя. Если на вкладке «Онлайн база» нажать кнопку «Загрузить в библиотеку», то после сохранения, компоненты будут доступны без подключения к Интернет. Если на вкладке «Библиотека» нажать кнопку «Загрузить в проект», то компоненты будут добавлены в панель Библиотека в раздел «Макросы проекта».
Файлы Библиотеки располагаются по адресу: C:\Users\[имя пользователя]\Documents\Owen Logic\Library\
Есть возможность сохранить или распечатать описание макроса. Для этого следует навести курсор мыши на поле описания и в нижней части появится панель с кнопками ”Сохранить” и ”Распечатать”:
При нажатии кнопки [image] в нижней части окна раскроется список с сообщениями:


Добавление компонента в проект
Сервер компании ОВЕН содержит пополняющуюся библиотеку компонентов, которые можно загрузить в программу пользователя при наличии Интернет подключения.
Для добавления компонента из Менеджера компонентов следует:
1. В меню Файл выбрать пункт Менеджер компонентов.
2. Появится окно с таблицей доступных на сервере компонентов. Если кликнуть на имя компонента, то можно увидеть его описание.
3. Выполнить поиск/сортировку в строке поиска.
Или выделить галочкой необходимые шаблоны.
4. Если нажать кнопку «Загрузить в проект», то компонент будет добавлен в панель Библиотека компонентов. Если нажать кнопку «Загрузить в библиотеку», то компонент будет загружен на диск. Файлы Библиотеки располагаются по адресу: C:\Users\[имя пользователя]\Documents\Owen Logic\Library\.
5. В таблице «Менеджера компонентов» появится зеленая галочка, сигнализирующая об успешной загрузке. Галочка будет располагаться в столбце «Библиотека» или «Проект» в зависимости от того, какую кнопку нажал пользователь в п.4.
Для подключения сетевого шаблона к конфигурации прибора следует воспользоваться рекомендациями раздела Шаблоны сетевых устройств.
Для добавления макроса в пользовательскую программу следует воспользоваться рекомендациями раздела Работа с макросами.


Панель свойств
На панели свойств отображаются и редактируются:
• параметры функций и функциональных блоков;
• размеры холста;
• часто используемые свойства входов и выходов (полный перечень настроек осуществляется в разделе Настройки прибора → Входы);
• параметры комментария, свободных переменных, блоков преобразователей.
Если элемент не выбран, то отображаются свойства холста.
Для отображения свойств элемента следует кликнуть на него левой кнопкой мыши.
Поля параметров на панели свойств могут отображаться двумя способами:
• при нажатой кнопке [image] — в алфавитном порядке;
• при [image] — по категориям.
Параметры элементов представлены на панели Свойства в виде таблицы: в левом столбце – наименование параметра, в правом – значение параметра. Для редактирования параметра следует кликнуть ЛКМ в поле значения параметра.


Загрузка в прибор
Запись программы в прибор
ВНИМАНИЕ
Если в подключенном приборе уже есть ранее записанная коммутационная программа, то она заменяется новой.
Созданный проект записывается в энергонезависимую память прибора. Для записи проект в прибор следует:
• подключить прибор к ПК;
• подать питание на прибор, если требуется;
• настроить параметры соединения, если в этом есть необходимость;
• записать проект в прибор нажав кнопку [image] Записать программу в прибор на панели инструментов, или выбрав команду меню Файл → Записать программу в прибор.
Если программа была создана для другого прибора, чем тот, в который ее пользователь пытается записать, то будет выведено соответствующее сообщение:
ПРИМЕЧАНИЕ
Сразу после записи программы, прибор переходит в рабочий режим и коммутационная программа запускается автоматически.
Переключение OWEN Logic в режим OFFLINE
Функцию следует использовать, если в двух или более приложениях OWEN Logic на одном ПК настроена передача данных в один прибор. Приложения будут поочередно занимать порт, загрузка в прибор в таком случае прервется.
Приложения, которые не должны осуществлять загрузку, следует перевести в режим OFFLINE.
Данная функция включается/отключается кликом по имени прибора на панели статуса.


Обновление встроенного ПО
Загрузка обновления встроенного ПО в прибор
Если для подключенного прибора выпущена новая версия встроенного ПО, во время попытки загрузить коммутационную программу будет предложено сделать обновление:
Для запуска обновления ПО следует нажать кнопку «Да».
Во время записи не допускать разрыва связи между компьютером и прибором.
Восстановление поврежденного встроенного ПО
Если прибор исправен, переведите его в режим загрузчика (см. руководство по эксплуатации).
В главном меню выберите Прибор → Обновление встроенного ПО.
В открывшемся окне выбрать тип прибора и нажать кнопку «Выбрать». Начнется процесс загрузки. По окончании система выведет сообщение о результатах загрузки.
Если вышеуказанный способ не срабатывает, то необходимо ознакомиться с п. 10 FAQ или обратиться в сервисный центр.
Обновление встроенного ПО модуля расширения
Если к прибору подключен модуль и для него доступно обновление встроенного ПО, то программа автоматически предложит обновить встроенное ПО модуля.
Для принудительного обновления встроенного ПО модуля в главном меню выберите Прибор → Обновление встроенного ПО.
Перейдите на вкладку Модуль, выберите модификацию, номер слота и нажмите кнопку «Выбрать».
Во время обновления следить за непрерывностью подачи питания на головное устройство и модули.
Если в головное устройство загружается программа пользователя без подключенного модуля расширения, возможна ситуация, когда внутреннее ПО головного устройства и модуля расширения будут иметь несовместимые версии. Это приведет к ситуации, что на модуле расширения будет индицирована Авария. Для устранения Аварии следует повторно обновить встроенного ПО модуля расширения.


Информация о приборе
Чтобы получить информацию о типе подключенного прибора и о версии программного обеспечения, следует нажать кнопку [image] на панели инструментов или выбрать в главном меню «Прибор → Информация...».
Откроется окно с информацией о подключенном приборе:
Информация о проекте:
Выбранная модель прибора — тип прибора, выбранный при создании проекта.
Версия среды разработки — версия, в которой изначально был создан проект. Может не совпадать с текущей версией программы.
Экспортировать в проект — экспорт в проект настроек входов/выходов из подключенного прибора. Используется для применения настроек входов/выходов к созданному проекту.


Настройка прибора
Для настройки связи с прибором сначала следует подключить прибор к ПК. В зависимости от выбранной модели прибора для соединения используется либо комплект для программирования, например ПР-КП20, либо кабель для программирования из комплекта поставки прибора.
ВНИМАНИЕ
Подключение к ПК допускается выполнять только при выключенном питании прибора.
После подключения прибора к ПК следует настроить параметры связи в ПО ОWEN Logic.
Канал соединения с прибором настраивается в окне «Настройка порта». Окно вызывается из основного меню командой «Прибор → Настройка порта».
Панели для настройки подключенного прибора вызываются в меню «Прибор» или с помощью кнопок на панели инструментов.
Информация;
Таблица переменных;
Юстировка входов/выходов;
Настройки прибора.
Настройка порта.
Панель настроек прибора
ПРИМЕЧАНИЕ
Перечень разделов отличается для разных приборов.
Панель настроек прибора открывается с помощью меню программы «Прибор → Настройка прибора».
Панель настроек прибора содержит разделы:
• Экран;
• Часы;
• Интерфейсы;
• Модули расширения;
• Входы и выходы.
Все установленные настройки для прибора, за исключением часов, сохраняются вместе с проектом.


Экран
Основные настройки экрана подключенного прибора:
Перечень параметров зависит от типа прибора.
Подсветка экрана — в выпадающем меню можно выбрать длительность работы подсветки с момента последнего действия пользователя.
Яркость — настройка яркости экрана, от 0 до 100 %.
Контраст — настройка контрастности отображаемых символов, от 0 до 100 %.
Кнопка «Прочитать» используется для считывания текущих настроек экрана из подключенного прибора.


Часы
В окне «Часы» настраиваются внутренние часы подключенного прибора. В соответствующих полях задается дата и время:
Чтобы синхронизировать часы прибора с часами ПК, следует отметить галочку «Синхронизация с компьютером» — поля «Дата» и «Время» станут неактивны.
Чтобы задать новые значения для часов прибора, следует нажать кнопку «Записать» в разделе «Дата и время».
Поле «Отклонение» служит для указания погрешности хода часов в секундах. Если часы прибора спешат, то значение указывается со знаком минус. Коррекция часов прибора на указанную величину происходит равномерно в течение месяца.
Чтобы установить значение коррекции, не меняя даты и времени, следует нажать кнопку «Записать» в разделе «Коррекция».
Кнопка «Прочитать» позволяет считать из прибора и отобразить в полях данного окна текущие значения параметров часов подключенного прибора.


Интерфейсы
Параметры интерфейса связи прибора задаются в разделе «Интерфейсы» диалогового окна «Настройка прибора». Для открытия окна Настройка прибора следует выбрать Прибор → Настройка прибора в главном меню. Доступ к настройкам возможен без подключения прибора к ПК.
Работа по интерфейсам связи производится по протоколу Modbus.
Добавить/Удалить интерфейс
Если прибор содержит слот, для которого не настроен интерфейс, то с помощью контекстного меню можно добавить интерфейс:
Интерфейс выбранного типа будет добавлен с настройками по умолчанию.
Настройка интерфейса
Настройка RS485
Удаление интерфейса
В зависимости от модификации прибора добавленный интерфейс может быть заменен на интерфейс другого типа или удален через контекстное меню.
Шаблоны
Для некоторых интерфейсов возможно создание шаблонов сетевых устройств (например, для RS-485 в режиме Master). Если есть сохраненный шаблон, то его можно применить к новому интерфейсу с помощью контекстного меню. Все настройки из шаблона будут перенесены на новый интерфейс.
Для некоторых устройств производства фирмы ОВЕН есть готовые шаблоны, которые можно загрузить с сервера с помощью Менеджера компонентов.


Работа по протоколу Modbus
Общие сведения
OWEN Logic обеспечивает работу по протоколам Modbus-RTU (Master/Slave) или Modbus-ASCII (Master/Slave).
ПРИМЕЧАНИЕ
Приборы ПР110 и ПР114 могут работать только в режиме Slave если к ним подключен модуль ПР-МИ485.
Для организации обмена данными в сети через интерфейс RS-485 необходим Мастер сети. Основная функция Мастера сети – инициировать обмен данными.
На линии связи допускается наличие только одного устройства в режиме Master.
Если прибор работает в режиме Master, то для минимизации времени получения данных со всех устройств рекомендуется:
• если одно или несколько Slave-устройств не подключены или недоступны, то рекомендуется предусмотреть в программе блокировку опроса этих устройств или сократить до минимума параметр «Таймаут ответа» для этих устройств. В ином случае время опроса будет расти пропорционально количеству неподключенных устройств и величине установленного параметра «Таймаут ответа» для этих устройств;
• во время установки параметра «Интервал между запросами» следует учитывать количество Slave-устройств и общее количество запросов. Если время обработки всех запросов занимает больше времени, чем установлено параметром «Интервал между запросами», то данный параметр будет игнорироваться.
Основным недостатком Modbus является сетевой обмен по типу Master/Slave, что не позволяет ведомым устройствам передавать данные по мере их появления и поэтому требует интенсивного опроса ведомых устройств ведущим.
Особенности работы со Slave-устройствами
С помощью OWEN Logic возможно запрограммировать управление до 16 устройствами по одному интерфейсу связи. Каждое устройство поддерживает до 256 переменных. Допускается использование одинаковых адресов и имен переменных для каждого устройства.
Сведения о подключении к RS-485
Для качественной работы приемопередатчиков и предотвращения влияния помех, на концах линии связи следует установить согласующие резисторы с сопротивлением 120 Ом. Резистор следует подключать непосредственно к клеммам прибора.
ПРЕДУПРЕЖДЕНИЕ
Не следует ставить резисторы на входе каждого прибора, подключенного к линии, или на конце каждого отвода от линии, это приведет к срабатыванию защиты приемопередатчиков RS-485 и их отключению.
Для линий связи RS-485 необходимо использовать экранированный кабель с витой парой, предназначенный для промышленного интерфейса RS-485 с волновым сопротивлением 120 Ом (например, КИПЭВ). Экран кабеля должен быть соединен с функциональной землей только в одной точке.
Количество интерфейсов RS-485
Некоторые приборы поддерживают до двух интерфейсов RS–485. Эти интерфейсы можно настроить на работу в двух независимых сетях RS-485.
Особенности конфигурирования приборов с платой ПР-ИП485
Выбрать режим работы Master/Slave для приборов можно в Настройках прибора в OWEN Logic. А с помощью установки перемычек на плате ПР-ИП485 можно подключить или отключить подтягивающие резисторы линий связи А и В.
Подтягивающие резисторы устанавливаются для задания определенного состояния линий связи, когда в сети RS-485 нет передачи. Резисторы устанавливаются в одном месте сети RS-485, как правило, возле Master. Если прибор настроен на работу в режиме Master, то рекомендуется подключить подтягивающие резисторы, если в режиме Slave – отключить.
Состав запроса
Запрос Master к Slave содержит:
• адрес Slave;
• код функции, применяемый к Slave;
• данные – адрес первого регистра и их количество (в случае записи – значения);
• контрольную сумму.
Адрес - это поле, содержащее номер устройства, которому адресован запрос. Каждое устройство в сети должно иметь уникальный адрес. Устройство отвечает только на те запросы, которые поступают по его адресу, во избежание конфликтов. При этом, Slave в своем ответе так же посылает поле Адрес.
Код функции содержит номер функции Modbus. Функция может запрашивать данные или давать команду на определенные действия. Коды ошибок используются Slave, чтобы определить, какое действие предпринять для их обработки. Коды функций являются числами в диапазоне от 1 до 127. Функции с номерами от 128 до 255 зарезервированы для пересылки кодов ошибок в ответном сообщении. Код «0» не используется.
В поле Данные содержится информация, которую передает Master устройство подчиненному, либо наоборот, в случае ответного сообщения. Длина этого поля зависит от типа передаваемых данных.
В поле Контрольная сумма содержится информация, необходимая для проверки целостности сообщения и отсутствия ошибок передачи.
Стандартные коды ошибок Modbus
01 — Принятый код функции не может быть обработан.
02 — Адрес данных, указанный в запросе, недоступен.
03 — Значение, содержащееся в поле данных запроса, является недопустимой величиной.
Функции и области данных
При запросе Master обращается к одной из областей памяти Slave с помощью определенной функции. Область памяти характеризуется типом хранящихся в ней значений (биты/регистры) и типом доступа (только чтение/чтение и запись).
Область данных | Обозначение | Тип данных | Тип доступа
Coils (Регистры флагов) | 0x | булевый | чтение/запись
Discrete Inputs (Дискретные входы) | 1x | булевый | только чтение
Input Registers (Регистры ввода) | 3x | целочисленный | только чтение
Holding Registers (Регистры хранения) | 4x | целочисленный | чтение/запись
Каждая область памяти состоит из определенного (зависящего от конкретного устройства) количества ячеек. Каждая ячейка имеет уникальный адрес. Для конфигурируемых устройств производитель предоставляет карту регистров, в которой содержится информация о соответствии параметров устройства и их адресов. Для программируемых устройств пользователь формирует такую карту самостоятельно с помощью среды программирования. Существуют устройства, в которых сочетаются оба рассмотренных случая – у их карты регистров есть фиксированная часть и часть, которую пользователь может дополнить в соответствии со своей задачей .
В некоторых устройствах области памяти наложены друг на друга (например, 0x и 4x) – т. е. пользователь сможет обращаться разными функциями к одним и тем же регистрам.
Функция определяет операцию (чтение/запись) и область памяти, с которой эта операция будет произведена.
Код функции | Имя функции | Выполняемая команда
1 (0x01) | Read Coil Status | Чтение значений из нескольких регистров флагов
2 (0x02) | Read Discrete Inputs | Чтение значений из нескольких дискретных входов
3 (0x03) | Read Holding Registers | Чтение значений из нескольких регистров хранения
4 (0x04) | Read Input Registers | Чтение значений из нескольких регистров ввода
5 (0x05) | Force Single Coil | Запись значения в один регистр флага
6 (0x06) | Preset Single Register | Запись значения в один регистр хранения
15 (0x0F) | Force Multiple Coils | Запись значений в несколько регистров флагов
16 (0x10) | Preset Multiple Registers | Запись значений в несколько регистров хранения
В различных документах идентичные обозначения могут иметь разный смысл в зависимости от контекста. Например, префикс 0x часто используют как указание на шестнадцатеричную систему счисления, поэтому в одном случае 0x30 может обозначать «30-й бит области памяти coils», а в другом – «адрес 30 в шестнадцатиричной (HEX) системе счисления» (при этом данный адрес может относиться к любой области памяти).
Опрос Slave может быть одиночным или групповым. При одиночном опросе Master считывает каждый из параметров Slave отдельной командой.
При групповом опросе Master считывает одной командой сразу несколько параметров, чьи адреса в карте регистров расположены строго последовательно и не имеют разрывов. Групповой опрос позволяет уменьшить трафик в сети и время, затрачиваемое на опрос устройства, но в некоторых случаях его применение невозможно (или возможно с ограничениями) из-за индивидуальных особенностей прибора.
Время опроса и таймаут ответа
При корректно заданных параметрах, происходит опрос регистров с заданным интервалом. Если указан период опроса, меньший, чем общее время обмена, корректный обмен по интерфейсу будет нарушен.
При настройках времени таймаута ответа от Slave меньше возможного, ответ устройства Slave бракуется. Следующий запрос заканчивается неудачей и данные по интерфейсу не поступают в регистры Master.
Порядок регистров и порядок байт
Порядок следования регистров/байт важен при считывании системных переменных формата float (аналоговые входы/выходы) прибора в режиме Slave.
Переменные OWEN Logic при работе по Modbus имеют следующие особенности:
• целый тип (int) — занимает один регистр, настройка следования регистров/бит не влияет на данный тип;
• булевский тип (bool) — занимает один бит, можно задавать номер бита регистра;
• тип с плавающей запятой (float) — занимает два регистра, порядок следования байт и регистров важен.
Автоподстройка времени цикла программы
Приборы могут подстраивать время работы цикла программы в зависимости от сложности алгоритма. Автоподстройка времени цикла программы влияет на работу интерфейса RS-485, так как обработка запросов происходит в оставшееся после выполнения программы время цикла.
Согласно алгоритму подстройки времени цикла, минимальное число вызовов Master составляет до 50 раз в секунду. Если Master не успевает опросить все устройства, то необходимо вносить изменения в алгоритм для оптимизации количества запросов.
Период опроса и правила его назначения
Прибор все запросы ставит в очередь. Если очередь короткая, то прибор выполнит все циклы запроса-ответа и остановится в ожидании пока не подойдет к концу заданный период. Если очередь длинная и не укладывается в заданный период, то прибор будет опрашивать все необходимые параметры с максимально возможным периодом, но этот период будет больше заданного в настройках.
Временная диаграмма опроса:
Для максимальной скорости 115200 бит/с опрос двух переменных типа float в «идеальных» условиях (короткая линия связи, отсутствие помех) у одного подчиненного устройства:
• время ответа от начала запроса 2,64 мс;
• следующий запрос начинается не раньше 12 мс;
• общее время на запрос 1 регистра float 3,4 мс.
В вышеперечисленных условиях, прибор сможет отправлять 83 запроса в секунду. Данное значение справедливо и для других приборов с подобными временными характеристиками. В процессе разработки алгоритма, когда логика усложняется, то увеличивается время цикла и количество запросов за секунду будет снижаться.
Значение периода опроса зависит от алгоритма, как часто и какие параметры надо опрашивать. Рекомендуется выставлять период опроса равным 1 с. В этом случае прибор сможет опросить до 50 переменных.
Порядок опроса нескольких устройств на шине
Устройства опрашиваются согласно сформированной очереди. Опрос происходит от наименьшего адреса к наибольшему. В примере на иллюстрации ниже, первым будет опрошено устройство с адресом 8, а последнее с адресом 32.
Можно задавать разный период период опроса подчиненных устройств. Конкретное значение будет зависеть от решаемой задачи.
Расчет адреса и бита для считывания булевой переменной в режиме Master
В некоторых случаях требуется вычислить адрес регистра и номер бита подчиненного устройства. Для определения адреса регистра и номера бита, из документации на опрашиваемый прибор берется расположение битовой переменной, например, бит 1400, далее следует:
1. Вычислить адрес регистра: 1400 ÷ 16 = 87.
2. Вычислить номер бита 1400 mod 16 = 8.
Полученные адрес и номер вводятся в поля «Регистр» и «Бит» при настройке опроса устройства.


RS-485
Для обмена данными по интерфейсу RS-485, должен быть настроен интерфейс в окне Настройки прибора в разделе Интерфейсы. Окно открывается в меню Прибор → Настройки прибора.
В случае добавления интерфейса RS-485 в списке отображается тип интерфейса (RS-485), номер слота, для которого назначен интерфейс и режим (Master/Slave).
Значения параметров интерфейса можно ввести в окне справа после выбора интерфейса кликом. Параметры зависят от технических характеристик подключаемых устройств и задач проекта.
Кнопка [image] Сделать по умолчанию — сохраняет введенные в поля данные для отображения при следующем подключении.
Кнопка [image] Заводские настройки — отображает в полях ввода заводские настройки для типа подключенного прибора.
Кнопка «Прочитать» — считывает текущие настройки подключенного прибора.
После задания корректных настроек интерфейса следует нажать кнопку «Закрыть». Параметры вступают в силу после перезагрузки прибора по питанию или после загрузки проекта в прибор.
Режим Master/Slave
Режим каждого доступного интерфейса RS-485 может быть определен как «Master» или «Slave».
В режиме Master прибор считывает и записывает переменные ведомых устройств, подключенных по данному интерфейсу.
В режиме Slave прибор является ведомым, параметры которого опрашиваются другим устройством.
Настройка для режима Master
Настройка для режима Slave


RS-485 режим Master
В режиме Master прибор опрашивает подключенные по интерфейсу устройства. Для опроса следует добавить и настроить опрашиваемые устройства. Для добавления устройства следует нажать кнопку «Добавить устройство» в контекстном меню интерфейса:
Добавленное подчиненное устройство будет отображено в списке под названием интерфейса. В списке указывается имя и адрес устройства.
Чтобы настроить устройство в окне справа следует нажать на добавленное устройство.
Настройка параметров опроса:
Для интерфейса RS-485, настроенного в режим Master, групповой опрос подчиненных устройств не поддерживается.
• Имя — имя опрашиваемого устройства, которое будет отображаться в списке интерфейсов. Назначается пользователем для удобства работы;
• Адрес — назначается адрес опрашиваемого Slave устройства;
• Период опроса, мс — временной интервал, через который повторяется опрос. Допустимый диапазон от 0 до 65535 мс;
• Таймаут ответа, мс — время, по истечении которого попытка опроса считается неудачной. Допустимый диапазон от 0 до 65535 мс.
Рекомендуется задавать в диапазоне 300 - 500 мс.
• Кол-во попыток — количество неудачных попыток опроса, при достижении которого изменяется Статус устройства. Допустимый диапазон от 0 до 255;
• Статус — переменная, в которую записывается статус прибора. Тип булевский: 1 — устройство функционирует нормально, 0 — связь с устройством потеряна. Переменная выбирается в таблице переменных, которая вызывается нажатием кнопки «...».
• Опрос — булевская переменная, определяющая доступ к опросу: 0 — запрет опроса, 1 — разрешение опроса. Переменная выбирается в таблице переменных, которая вызывается нажатием кнопки «...».
• Старшим регистром вперед — определяет очередность посылки регистров во время работы с двухрегистровыми переменными.
• Старшим байтом вперед — определяет очередность следования байт в посылке.
• Комментарий — текстовый комментарий, описывающий устройство.
Пример
Например, нужно считать число "-250.123".
В зависимости от настройки порядка следования регистров/байт оно будет передаться различным образом.
Настройка порядка следования регистров/байт | Передаваемое число
Чтобы добавить переменную следует нажать кнопку [image] . Переменная будет помещена в таблицу, как на рисунке ниже.
Свойства переменной настраиваются в окне справа от таблицы:
• Имя переменной — служит для отображения в таблице переменных;
• Тип — тип считываемой переменной: булевский, целочисленный или с плавающей запятой;
• Бит — номер бита для чтения, только для переменных булевского типа (bool), указывает пользователь;
• Регистр/Адрес регистра — значение регистра, к которому обращается прибор, отображается в таблице;
• Функция чтения/функция записи — выбор функции или отключения записи/чтения;
• Количество — количество занимаемых переменной регистров, указывается пользователем для целочисленных переменных (int). Возможные значения 1 и 2;
• Запуск чтения — назначается переменная булевского типа (bool) для принудительного чтения данной переменной;
• Запуск записи — назначается переменная булевского типа (bool) для принудительной записи данной переменной;
• Статус — позволяет назначить любую целочисленную переменную (int), в которую будет записан код ошибки Modbus, в случае ее появления;
• Комментарий — текстовый комментарий для описания значения переменной, будет отображаться в таблице переменных;
Чтобы создать несколько переменных со схожими настройками, следует выбрать переменную в таблице и нажать кнопку [image] Тиражировать. Переменные будут добавлены в таблицу.
• Имя — имя переменной, которая будет тиражирована;
• Начальный номер — начальное число, которое будет добавлено к имени тиражируемой переменной;
• Количество — количество переменных, которые нужно добавить;
• Шаг адреса — шаг, с которым будет увеличиваться значение параметра «Регистр».
Переменные будут добавлены в таблицу.
Чтобы удалить переменную из таблицы, следует выделить нужную строку и точка в конце предложения [image] .
Шаблоны сетевых устройств
Настройки и конфигурация сетевого устройства могут быть сохранены в виде файла шаблона. Для сохранения шаблона следует нажать кнопку [image] Сохранить устройство как шаблон. В открывшемся окне выбрать расположение и ввести имя файла. Файл будет сохранен с расширением *.dvtp.
Сохраненный шаблон можно использовать в других проектах.
Конфигурирование платы ПР-ИП485
После конфигурирования всех параметров в OWEN Logic следует проверить положение джамперов на сетевой плате ПР-ИП485. Для работы в режиме Master по интерфейсу RS-485 джамперы следует установить в положение MST.


RS-485 режим Slave
По умолчанию для RS-485 установлен режим Slave — прибор предоставляет данные для считывания другими устройствами, самостоятельный опрос не ведет.
Чтобы настроить параметры передачи данных, следует нажать на имя прибора (по умолчанию — «Сам, 16») под заголовком интерфейса.
В окне справа расположены панели настройки. В верхней части настраиваются параметры опроса, общие для всех переменных.
• Имя — имя прибора, назначается пользователем для удобства;
• Адрес — адрес прибора;
• Старшим регистром вперед — определяет очередность посылки регистров при работе с двухрегистровыми переменными;
• Старшим байтом вперед — определяет очередность следования байтов в посылке;
• Комментарий — поле ввода комментария к устройству.
Для интерфейса RS-485, настроенного в режим Slave, можно опрашивать до 64 регистров прибора при групповом опросе.
В нижней части окна располагается таблица переменных прибора, значения которых будут считываться ведущим устройством.
• Имя переменной — имя считываемой переменной (задает пользователь);
• Тип — тип считываемой переменной: целочисленный или с плавающей запятой. Булевские переменные, например состояние дискретных входов, можно считать в целочисленную переменную. Состояние конкретного входа можно извлечь с помощью блока EXTRACT или подходящего макроса из Менеджера компонентов;
• Адрес регистра — адрес регистра сетевой переменной, назначается пользователем. Диапазон доступных адресов указан в руководстве пользователя на прибор;
• Комментарий — текстовый комментарий для описания значения переменной, будет отображаться в таблице переменных;
Свойства переменной, указанные в таблице настраиваются в окне справа.
Чтобы создать несколько переменных со схожими настройками, следует выбрать переменную в таблице и нажать [image] Тиражировать.
– Имя — имя переменной, которая будет тиражирована.
– Начальный номер — начальное число, которое будет добавлено к имени тиражируемой переменной.
– Количество — количество переменных ,которое нужно добавить.
– Шаг адреса — шаг, с которым будет увеличиваться значение параметра «Регистр».
После ввода значений следует нажать кнопку ОК. Переменные будут добавлены в таблицу.
Чтобы удалить переменную из таблицы, следует выделить ее и нажать [image] .


Шаблоны сетевых устройств
Для упрощения работы с сетевыми устройствами, которые могут быть подключены к прибору по интерфейсу RS-485, созданы шаблоны наиболее часто подключаемых приборов. Они размещены на сервере компании ОВЕН. Подробнее см. раздел Добавление компонента.
Для добавления шаблона в OWEN Logic:
1. Настроить режим сетевого интерфейса — Master.
Параметры связи должны совпадать с параметрами подключаемого прибора.
2. Добавить устройство из шаблонов с помощью контекстного меню, которое вызывается по клику ПКМ на строку «RS485, Слот 1, Master».
3. Откроется меню Проводника Windows, где нужно выбрать необходимый шаблон.
Название добавленного устройства появится в разделе «Интерфейсы».
В добавленном шаблоне можно удалить неиспользуемые регистры, отредактировать название, пересохранить шаблон для будущих проектов с помощью контекстного меню.


Модули расширения
К прибору можно подключить модули ввода/вывода. Для подключения модулей следует настроить параметры модулей на панели настроек прибора. Панель вызывается в меню программы Прибор → Настройки прибора.
Чтобы добавить модуль расширения, следует кликнуть ПКМ на вкладку «Модули расширения» → «Добавить модуль расширения» и выбрать модель.
Выбранный модуль будет добавлен в список модулей. Для каждого модуля указывается название модели и номер слота. У выделенного модуля в списке на панели справа отображаются его настройки.
В выпадающем меню следует указать номер слота, занимаемый данным модулем.
Статус подключения модуля может сохраняться в переменную типа bool. Если связь с модулем установлена, то переменная хранит значение True, если связь не установлена — False. Чтобы выбрать переменную, в которой будет храниться статус, следует нажать кнопку «...».
Откроется таблица переменных, в которой можно выбрать переменную из проекта или создать новую.
Выбранная переменная будет отображаться в поле ввода.
Для выходов модуля расширения может быть настроено безопасное состояние.


Входы и выходы
Комментарии к входам прибора можно добавить на панели свойств или на панели Настройка прибора → Входы:
Добавление комментариев
Комментарий можно написать в поле в окне «Настройка прибора» или на панели свойств.
Текст введенного комментария будет отображаться во всплывающей подсказке при наведении курсора на данный вход на схеме:
Настройка параметров
В зависимости от типа входов прибора различаются параметры для настройки.
Для правильной настройки входов прибора следует обратиться к руководству по эксплуатации прибора.
Безопасное состояние выходов модулей расширения
Для выходов модулей расширения можно настроить безопасное состояние. Выход будет принимать безопасное состояние в случае потери связи с головным прибором.


Юстировка входов/выходов
ВНИМАНИЕ
Юстировку следует проводить только в случае больших расхождений измеренных значений с реальными.
Юстировка запускается с помощью команды меню «Прибор → Юстировка Входов/Выходов».
В открывшемся диалоговом окне следует выбрать юстировку входов или выходов.
Юстировка входов
Если в приборе запущена коммутационная программа перед началом юстировки входов, то она останавливается. В окне настройки следует ввести параметры подключаемых к входам датчиков:
Чтобы восстановились настройки по умолчанию в окнах ввода, следует нажать «Сбросить настройки».
Выбрать номера входов для настройки в соответствии с введенными параметрами можно в выпадающем меню «Выбор канала».
Для настройки прибора следует выполнить дальнейшие указания программы:
В случае необходимости следует обратиться к руководству по эксплуатации подключенного прибора.
На юстируемые входы следует подать сигналы с требуемыми характеристиками.
После завершения юстировки программа выдаст сообщение об успешном завершении. Коммутационная программа прибора будет снова запущена.
Юстировка выходов
Для юстировки выходов следует выполнить указания программы. Затем измерить величину поданного на выход сигнала, который указан в правом верхнем углу окна и ввести значение в поле ввода.
Аналогично вводятся значения сигналов в последующих окнах. После настройки всех выходов появится сообщение об успешном завершении юстировки:


Таблица переменных
Таблица переменных вызывается нажатием кнопки [image] на панели инструментов или в главном меню при выборе «Прибор → Таблица переменных».
Таблица содержит три боковые вкладки: «Переменные», «Сервисные переменные» и «Переменные интерфейса».
Переменные
Переменные служат для связи между блоками и входами/выходами прибора, экранами (для считывания и записи данных с помощью экрана прибора).
Чтобы использовать свободные переменные в проекте, следует создать их в таблице:
Для создания переменной следует ввести её имя и задать тип. Остальные параметры заполняются в зависимости от эксплуатационной потребности. Таблица переменных поддерживает фильтрацию по имени. Символ «Пробел» выполняет роль логического ИЛИ и позволяет фильтровать переменные по нескольким критериям.
Подробное описание типов переменных см. раздел Свойства переменной.
Чтобы найти место использования переменной в проекте, следует нажать в поле столбца «Использование в проекте» и выбрать «Показать ссылки».
В открывшемся окне отобразится информация о выбранной переменной.
Чтобы удалить привязку к блоку переменной в проекте, следует отметить нужные переменные галочками и нажать кнопку «Удалить». Удаленные переменные будут отображаться в таблице переменных, но в проекте использоваться не будут .
Чтобы удалить переменную из таблицы, следует кликнуть ПКМ по имени переменной и в появившемся меню выбрать «Удалить переменную».
Сервисные переменные
Сервисные переменные связаны с настройкой аппаратной платформы прибора. Их набор может отличаться в зависимости от прибора. Сервисные переменные могут иметь ограничения по чтению/записи.
Сервисные переменные обозначаются на схеме серым цветом:
Переменные интерфейса
В таблице переменных для каждого задействованного слота сетевого интерфейса создается отдельная вкладка с описанием сетевых переменных. В заголовке вкладки указывается тип интерфейса и номер слота.
Интерфейс RS-485
Для интерфейса, настроенного в режим Master, таблица содержит вкладки с переменными для каждого подключенного устройства:
О настройках переменных см. подробнее в разделе RS485- Режим Master.
Для интерфейса, настроенного в режим Slave, таблица отображает сетевые переменные, из раздела RS-485 Режим Slave.


Свойства переменных
Основные свойства переменных:
Имя переменной | Имя будет отображаться в таблицах и на блоке переменной в коммутационной программе
Тип переменной | Может быть назначен один из трех типов: булевский, целочисленный, с плавающей запятой. См. подробнее о типах переменных
Энергонезависимость | Для сохранения значения переменной в энергонезависимой памяти прибора в случае отключения электропитания следует поставить галочку в поле настройки. Время хранения зависит от типа прибора, см. руководство по эксплуатации
Значение по умолчанию | Значение, которое будет хранить переменная при записи коммутационной программы, пока в нее не будет записано новое значение
Использование в проекте | Индикация привязки к блокам в коммутационной программе. Если переменная привязана, то значение — «Да»
Комментарий | Текстовый комментарий отображается в нижней части таблицы при выделении строки переменной и во всплывающей подсказке на схеме коммутационной программы при наведении курсора на блок переменной


Типы переменных
В программе используется три типа переменных: булевский (двоичный), целочисленный и с плавающей запятой (вещественный).
Значения от одной переменной к другой могут передаваться только при совпадающих типах переменных.
Булевский тип (bool)
Переменная данного типа может принимать одно из двух значений: 1 (true) или 0 (false).
Линии, соединяющие переменные данного типа на схеме, обозначаются серым цветом:
Целочисленный тип (int)
Переменная данного типа — целое число, принимает значение в диапазоне от 0 до 4294967295.
На схеме переменные данного типа соединяются красными линиями:
Тип с плавающей запятой (float)
Переменная данного типа принимает значение в диапазоне от 1,175494351E–38 до 3,402823466E+38.
Числа одинарной точности с плавающей запятой обеспечивают относительную точность 7 – 8 десятичных цифр в диапазоне от 10–38 до примерно 1038.
На схеме переменные данного типа соединяются фиолетовыми линиями:


Настройка порта
В окне Настройка порта выбирается номер используемого СОМ-порта, остальные настройки фиксированные и выводятся для справки.
Подключение по USB
Для подключения прибора к компьютеру через порт USB следует установить драйвер USB с компакт-диска из комплекта поставки прибора, либо скачать на сайте www.owen.ru.
После установки драйвера следует подключить прибор к компьютеру и включить питание (если этого требует загрузка проекта). Номер эмулируемого COM порта можно узнать в Диспетчере устройств ОС Windows:
Номер COM порта следует ввести в окне «Настройка порта» и нажать «ОК». Если подключение корректно, то в строке статуса OWEN Logic отобразится название подключенного прибора.


Режим симулятора
Корректность работы созданной коммутационной программы проверяется с помощью режима симулятора, в котором моделируется изменение состояний выходов в зависимости от изменения состояний входов. Моделирование позволяет проанализировать состояние сигналов внутри коммутационной программы.
Для перехода в режим симуляции следует нажать кнопку [image] Режим симулятора. Откроется панель симуляции.
Панель симуляции
На панели расположены следующие элементы управления:
1. Кнопка запуска моделирования в реальном времени.
2. Кнопка для пошагового моделирования, выполняет 1 цикл программы при нажатии.
3. Пауза в работе симулятора, при повторном нажатии процесс моделирования продолжается.
4. Кнопка остановки работы симулятора, переводит режим симуляции в первоначальное состояние.
5. Поле ввода для задания времени периода обновления информации на схеме.
6. Поле ввода для задания времени цикла для временных функциональных блоков - «TON», «TOF», «BLINK».
7. Поле ввода для выбора единиц измерения времени цикла: мс, сек, мин, час.
Время цикла может быть выбрано произвольно. Все уставки таймеров будут отработаны в любом случае в промежуточных шагах симулятора.
ВНИМАНИЕ
Время цикла в симуляторе не тоже самое, что время цикла, рассчитываемое непосредственно в приборе.
Моделирование работы блоков часов
Для приборов с функцией часов реального времени открывается дополнительная панель, с помощью которой можно моделировать поведение функциональных блоков «CLOCK» и «CLOCK WEEK» во времени:
Окно просмотра
В режиме симуляции открывается окно просмотра. Окно просмотра можно скрыть и открыть заново нажатием кнопки [image] на панели симуляции. Окно предназначено для просмотра значений переменных на каждом шаге выполнения коммутационной программы.
До время запуска симуляции окно пустое.
Для добавления переменной следует нажать в пустое поле в колонке «Имя», затем на кнопку «...».
Откроется таблица переменных. В ней могут быть выбраны переменные проекта, входы и выходы.
После выбора и нажатия кнопки «ОК» таблица переменных закрывается. Выбранные переменные добавляются в окно просмотра.
Также переменную можно добавить в окно просмотра с помощью контекстного меню переменной нажатием на переменную на схеме правой кнопкой мыши и выбором кнопки «Добавить в окно просмотра».
Последовательность работы с симулятором
После перехода в режим симуляции, коммутационная программа моделируется в общем случае в следующей последовательности:
1. Запуск симулятора в одном из режимов: реального времени ( [image] ) или в пошаговом ( [image] ).
2. Задание значений входных сигналов, на блоке входов:
3. Подбор значений параметров «период, мс» и «время цикла, мс» для удобства моделирования.
4. Выход из режима симуляции для корректировки коммутационной программы.
Для переменных также можно указывать значения. Двойным кликом на значении переменной можно открыть поле ввода и ввести новое значение переменной.
ПРЕДУПРЕЖДЕНИЕ
Основная коммутационная программа (вкладка «Схема») и макросы моделируются по отдельности.
Работа блоков, не имеющих связи ни с одним из выходов прибора или сетевой переменной, не моделируются.
Во время моделирования значения переменных можно задавать в окне просмотра в колонке «Значения».
Симуляция не будет работать при одновременном выполнении следующих условий:
• энергозависимые переменные;
• переменные некорректно привязаны к другим элементам схемы.
Для корректной работы симуляции следует сделать переменные энергонезависимыми или сделать корректные привязки.


Расширения
Доступны следующие расширения:
• Мастер тиражирования. С помощью “Мастера тиражирования” можно загрузить пользовательскую программу в прибор без участия OWEN Logic. и защитить ее от копирования;
• Экспорт устройства в OwenCloud. Позволяет экспортировать конфигурацию сетевых переменных для опроса в облачном сервисе OwenCloud;
• Экспорт устройства в OPC. Позволяет экспортировать конфигурацию сетевых переменных для опроса в ОВЕН OPC-сервер.


Управление расширениями
ПРИМЕЧАНИЕ
Для установки расширений на ПК должен быть открыт порт 8084.
Для установки расширений следует:
1. В меню “Расширения” выбрать пункт ”Управление расширениями”.
2. В появившемся окне отметить галочкой необходимые расширения.
Далее нажать кнопку ”Установить”.
3. Через некоторое время Мастер управления расширениями сигнализирует об успешной установке зеленой галочкой напротив выбранных расширений.
4. После выхода из Мастера управления расширениями необходимо перезапустить OWEN Logic. О чем предупредит появившийся диалог:
После перезапуска OWEN Logic расширения будут готовы к использованию.
Для удаления расширения следует:
1. В меню “Расширения” выбрать пункт ”Управление расширениями”.
2. В появившемся окне выбрать не нужное расширение и нажать × около него.
3. После выхода из Мастера управления расширениями необходимо перезапустить OWEN Logic. О чем предупредит появившийся диалог:


Расширение «Мастер тиражирования»
Расширение позволяет создавать из проекта OWEN Logic мастер тиражирования — файл с расширением .exe, содержащий внутри себя пользовательскую программу. С помощью мастера тиражирования можно загрузить пользовательскую программу в прибор без участия OWEN Logic.
ВНИМАНИЕ
Тиражировать пользовательскую программу можно только между одинаковыми модификациями прибора!
Файл проекта может быть защищен с помощью ключа. При записи проекта с ключом, ключ записывается в память прибора. Затем можно записывать любые программы с помощью мастера тиражирования, но запустятся на приборе только те, у которых ключ совпадает или отсутствует.
Все созданные OWEN Logic ключи размещаются по адресу C:\Users\[имяпользователя]\Документы\Owen Logic\Keys.
Если программа была записана мастером тиражирования без файла ключа (файл отсутствовал по вышеуказанному пути или ошибочно был выбран другой ключ), то после записи программы в память прибора на экране прибора высветится надпись: «Программа Logic: Повреждена».
Перед созданием мастера тиражирования рекомендуется создать текстовый файл с расширением *.rtf с описанием проекта. Эта информация будет отображаться при запуске мастера тиражирования, перед загрузкой проекта в прибор.
Создание файла с ключом
Для создания файла с ключом следует в меню Файл выбрать команду Создать файл с ключом.
Откроется диалоговое окно, в котором следует ввести имя файла:
Ключ генерируется автоматически. Ключ можно изменить нажатием кнопки [image] или вручную.
Для сохранения ключа следует нажать кнопку «Сохранить».
Файл с ключом по умолчанию сохраняется в папку C:\Users\[имяпользователя]\Документы\Owen Logic/Keys .
Выбор файла с ключом для проекта
Перед тиражированием следует указать в свойствах проекта имя файла с ключом, если он создан.
Для этого следует нажать в любое пустое место на схеме.
В свойствах документа в строке «Имя файла с ключом» нажать на кнопку «...».
В появившемся окне выбрать созданный файл с ключом и нажать кнопку «Открыть».
Создание мастера тиражирования
Чтобы приступить к созданию мастера, выберите в меню «Расширения» Создать мастер тиражирования.
Откроется окно для создания мастера тиражирования. Если к проекту подключен ключ, то будет выведена надпись «Пользовательская программа защищена ключом!». В ином случае будет выведена надпись «Устройство поддерживает защиту пользовательской программы, но для проекта не выбран файл с ключом».
Параметры устройства считываются из прибора и заполняются автоматически.
В окне параметров следует заполнить поля:
• Имя конечного файла — имя файла мастера тиражирования, который будет создан;
• Путь к мастеру тиражирования — расположение создаваемого файла;
• Файл с описанием алгоритма — текстовый файл с описанием проекта в формате *.rtf.
После заполнения полей следует нажать кнопку «Создать». В случае отсутствия ошибок будет создан файл с указанным именем и расширением .exe. Отчёт о создании файла выводится в нижней части окна.
Чтобы скрыть или открыть область отображения отчета, следует нажать кнопку [image] . Информация о предупреждениях и ошибках выводится, если отмечены соответствующие флажки.
Запись коммутационной программы в прибор через мастер тиражирования
Для записи коммутационной программы в прибор через мастер тиражирования следует запустить созданный файл мастера тиражирования.
Во время открытия мастера отобразится текст описания проекта из прикрепленного файла с расширением *.rtf. Если файл не был прикреплен во время создания мастера, то описание проекта будет пустым.
Для продолжения следует нажать кнопку «Далее». В разделе «Настройки порта» указывается номер COM-порта, к которому подключен прибор. Как узнать номер порта, описано в разделе Настройка порта.
После выбора порта в правом нижнем углу будет отображаться состояние подключения к прибору. В случае ошибки подключения будет отображен знак [image] и текст ошибки. При наведении на знак [image] отобразится подсказка с описанием ошибки.
Ошибка
Возможные причины
Прибор не подключен
• неправильно выбран COM-порт;
• не установлен драйвер USB;
• разрыв соединения
Требуется другой прибор
Подключенный прибор не соответствует тому, для которого был создан проект. Нужно заменить прибор в проекте и создать новый мастер тиражирования, либо подключить подходящий прибор
Если никаких ошибок нет, то отображается зеленая галочка с названием прибора.
Если связь с прибором постоянно прерывается (галочка мигает), то, возможно, порт USB занимает другое приложение. Это может быть, если запущена программа OWEN Logic и в ней настроено подключение к этому же порту. В таком случае для загрузки проекта в прибор программу следует перевести в режим OFFLINE или выгрузить из памяти ПК.
Если соединение стабильно, то следует нажать кнопку «Далее».
Для записи программы в устройство следует нажать кнопку «Запись». Начнется процесс загрузки алгоритма. В это время нельзя прерывать связь ПК с прибором. По завершении загрузки будет выведено сообщение.


Расширение «Экспорт устройства в OPC»
Данное расширение экспортирует сетевые переменные из проекта OWEN Logic для использования в программе ОВЕН OPC-сервер.
Для экспорта следует:
1. Экспортировать устройство из OWEN Logic: команда главного меню «Дополнения → Экспорт устройства в ОРС».
Появится окно проводника Windows, где следует выбрать место сохранения и имя файла с расширением *.dev.
2. В программе ОРС-сервер добавить узел в дерево объектов.
3. В контекстном меню узла выбрать «Добавить → Устройство из файла». Откроется окно проводника Windows.
4. В окне выбрать файл, который был экспортирован из OWEN Logic. Нажать «Открыть».
5. Выбрать протокол обмена с устройством. Нажать «Выбрать».
Устройство и теги будут добавлены в дерево объектов.
Если необходимо отредактировать устройство, то следует изменить опции устройства и тегов.
Для проверки правильности настройки следует подключить прибор к ПК и запустить режим опроса.
Инструкции по работе с «ОВЕН OPC-сервер» приведены в его справке.


Расширение «Экспорт устройства в OwenCloud»
Расширение сокращает время добавления прибора, настроенного в режим Slave, в облачный сервис компании ОВЕН.
Работа с OwenCloud требует подключения специального устройства, шлюза, к прибору. Будем считать, что шлюз уже настроен и подключен к прибору, настройки приведены в Руководстве по эксплуатации на шлюз.
Для экспорта конфигурации параметров Modbus устройства следует:
1. Создать проект в OWEN Logic, настроить в меню Прибор → Настройки прибора интерфейс RS-485 в режим Slave;
2. Задать адрес прибора;
3. Создать переменные для опроса;
4. Выбрать в меню Расширения → Экспорт устройства для OwenCloud;
5. В появившемся меню выбрать расположение и задать имя файла *.json.
Дальнейшие действия требуют наличия личного кабинета в OwenCloud.
После входа в личный кабинет следует:
1. Нажать на кнопку [image] ;
2. На открывшейся странице нажать кнопку [image] ;
3. В появившемся меню следует задать Идентификатор — IMEI/заводской номер сетевого шлюза (указан на корпусе шлюза). В выпадающем списке Тип прибора выбрать «Произвольный прибор Modbus». Ввести адрес прибора, который был задан в OWEN Logic. Заполнить остальные поля. Далее следует нажать кнопку Добавить.
4. На вкладке Общее/Общие настройки указать скорость опроса и настройки COM-порта прибора в соответствии с настройками в OWEN Logic. Нажать кнопку Сохранить для применения новых настроек.
5. В появившейся странице следует нажать кнопку Настройки параметров. Нажать на выпадающий список «Импортировать» и выбрать вариант «Загрузить из JSON». В открывшемся меню выбрать ранее созданный *.json файл и нажать Загрузить параметры.
6. Modbus переменные прибора будут добавлены в OwenCloud.


Рабочая область
После создания проекта или открытия сохраненного проекта в рабочей области открывается вкладка «Схема» для разработки программы прибора на языке FBD.
Основную часть вкладки составляет холст, на котором размещаются функции и ФБ. Изменить размеры холста можно на панели «Свойства документа».
Входы и выходы прибора обозначены в виде квадратов с маркировкой номеров: вдоль левой стороны холста расположены входы (Ix — дискретные, AIx — аналоговые), вдоль правой стороны холста расположены выходы (Qx — дискретные, AOx — аналоговые, Fx — светодиоды). Цифры в обозначениях соответствуют номерам физических входов и выходов прибора. Входы и выходы можно перетаскивать вверх/вниз вдоль холста методом drag & drop, удалять и добавлять для удобства компоновки схемы.
Под заголовком «Схема» располагаются кнопки:
Включить/Выключить сетку | При включенной сетке на холсте отображаются вертикальная и горизонтальная линейки и сетка. Элементы и линии связи при размещении привязываются к сетке
Уменьшить масштаб | Уменьшение масштаба на 10 % от первоначального
Оригинальный размер | Возврат к исходному масштабу
Увеличить масштаб | Увеличение масштаба на 10 % от первоначального
Задать требуемый масштаб можно с помощью выпадающего меню справа от описанных выше кнопок.
В нижней части рабочей области находятся кнопки:
Используется для одновременного отображения двух областей одной схемы в разных окнах
Используется для отображения схемы в одном окне


Панель Библиотека компонентов
Если в программе открыт проект, то на панели Библиотека компонентов отображаются ее разделы: функции, функциональные блоки, макросы. Для отображения содержимого раздела Библиотеки компонентов, его следует выбрать в нижней части панели.
Выбрать вид отображаемых компонентов можно с помощью кнопок в верхней части панели.
В выпадающем меню можно выбрать вариант расположения компонентов:
При нажатии кнопки [image] Показать все компоненты отображаются все компоненты выбранного раздела библиотеки:
При нажатии кнопки [image] Группировка по папкам отображаются папки, содержащие компоненты разных типов:
Папка открывается по двойному клику.
Описание разделов и компонентов библиотеки приведено в разделе Библиотека.


Панель «Переменные»
По умолчанию, слева от рабочего холста располагается панель «Переменные» на ней отображаются переменные из Таблицы переменных.
Для создания блока входной переменной следует перетащить переменную (методом drag & drop) на схему.
Для создания блока выходной переменной следует перетащить переменную из панели «Переменные» на холст, удерживая клавишу Shift.
Если переменную перетащить к коннектору элемента схемы, то будет создан блок переменной, присоединенный к этому коннектору элемента.
Для поиска места использования переменной на схеме следует выделить переменную в панели «Переменные». В области ссылок отобразятся ссылки, в каких местах использована переменная. Если кликнуть по ссылке, то на холсте будет выделен блок к которому привязана переменная.
Места использования переменной можно просмотреть в пункте «Показать ссылки» контекстного меню блока переменной. По клику на ссылку будет совершен переход к месту использования переменной.


Менеджер и редактор экранов
Менеджер экранов
Если выбранное во время создания проекта устройство имеет экран, то можно настроить вывод на него информации из программы. Инструкции по работе с экранами приведены в разделе Программирование экрана прибора.
В основной части вкладки расположено изображение экрана.
Редактирование экранов
Добавить экран
Удалить экран
Редактировать группу
Масштабирование
Уменьшить масштаб
Оригинальный размер
Увеличить масштаб
Масштаб может быть изменен с помощью выпадающего меню справа от кнопок.
При нажатии на изображение экрана в нижней части панели отображаются параметры экрана. Здесь происходит настройка экрана.
Редактор экранов
Открывается по двойному клику на изображении экрана в менеджере экранов.
В рабочей области изображена схема экрана в виде прямоугольника с размеченными строками. Справа от него расположены пиктограммы [image] .
Масштаб изображения экрана в редакторе можно изменять аналогично Менеджеру экранов.
Кнопка [image] Сохранить служит для сохранения документа в текущем редакторе.


Панель статуса
На панели статуса выводится информация о доступных ресурсах прибора и подключении.
Вид
В зависимости от прибора, выбранного при создании проекта, перечень параметров в статусной строке может различаться.
Параметры и элементы управления
При подключенном приборе в строке статуса отображается информация:
• ФБ — индикатор отражает доступное количество экземпляров функциональных блоков;
• Перем. — индикатор отражает доступное количество переменных;
• Стек — индикатор отражает уровень использования памяти выделенной под стек. Стек используется для промежуточных вычислений в программе;
• ЭСППЗУ — индикатор отражает доступное количество энергонезависимой памяти для Retain переменных;
• ПЗУ — индикатор отражает доступную память прибора в процентах от общего объема: «ПЗУ: 0…100 %»;
• ОЗУ — индикатор отражает доступную память прибора в процентах от общего объема: «ОЗУ: 0…100 %». Чем больше используется в программе блоков и функций, тем больше памяти требуется для работы в приборе. OWEN Logic автоматически рассчитывает доступную память прибора и в случае критического значения выводит соответствующее предупреждение;
• ПРххx-xхх — индикатор информирует о наличии связи между OWEN Logic и прибором. При наличии связи указывается модель подключенного прибора. Если прибор не подключен на индикаторе отображается надпись «Прибор не подключен». При нажатии на этот индикатор OWEN Logic переводится в режим OFFLINE;
• COMx — номер выбранного пользователем порта. Нажатие на блок открывает окно настройки порта.
Режим OFFLINE
В режиме OFFLINE устанавливается запрет на опрос прибора.
Чтобы перейти в режим OFFLINE, следует кликнуть на имя прибора на панели статуса. Вид индикатора изменится на »OFFLINE». Повторый клик позволяет вернуться в режим ONLINE.
Подробнее см. в разделе Загрузка в прибор.


Создание проекта и порядок работы
Создание и редактирование проекта
Чтобы создать новый проект, в главном меню программы выберите «Файл → Создать новый проект».
Сохранить и открыть сохраненный проект можно с помощью «горячих кнопок» или с помощью меню «Файл». Для удобства кнопки с основными функциями вынесены на панель инструментов.
В открывшемся окне следует выбрать модификацию прибора, для которого создается проект, и нажать «ОК». Меню выбора прибора поддерживает фильтрацию по модели.
В главном окне программы отобразится холст проекта, станут активными статусная строка и окна «Библиотека компонентов» и «Свойства».
При наличии у выбранного прибора экрана отобразится вкладка «Менеджер экранов» где можно настроить вывод информации на экран.
Разработка коммутационной программы
На холсте создается коммутационная программа проекта на языке FBD с помощью компонентов Библиотеки.
Симуляция коммутационной программы
После создания программы можно смоделировать работу коммутационной программы в режиме симуляции. Во время проверки правильности работы программы пользователь может изменять состояние входов, контролируя состояние выходов на соответствие нужным условиям. После выявления ошибок можно вернуться к правке алгоритма.
Подключение прибора и настройка соединения
Сначала настраивается порт в OWEN Logic. Потом к компьютеру подключается прибор. Далее на прибор подается питание (если этого требует процесс загрузки программы) и производятся настройки прибора в OWEN Logic.
Загрузка коммутационной программы в прибор
После настройки соединения может быть загружена коммутационная программа в прибор из OWEN Logic. После загрузки программы следует сначала отключить питание прибора, затем отсоединить прибор от компьютера.
После записи в прибор, пользовательская программа сохраняется в энергонезависимой памяти прибора и запускается после включения питания или перезагрузки прибора.


Разработка коммутационной программы
Составление коммутационной программы рекомендуется начинать с планирования. План должен описывать все возможные состояния прибора во время функционирования (в виде диаграммы режимов, таблицы состояний, электрической или функциональной схемы и/или др.).
После того как продуманы все задачи, которые должны выполняться, следует составить программу на основе функций и функциональных блоков Библиотеки программы.
Размещение компонентов и создание связей
Компоненты программы размещаются на схеме путем выбора нужного компонента в Библиотеке программы и перемещения на холст методом «drag & drop».
Входы и выходы прибора и компонентов следует соединить, проведя между ними линии. Для создания соединительной линии следует:
• кликнуть ЛКМ на выход первого компонента. Линия присоединится к нему и потянется вслед за курсором мыши;
• если необходимо сделать изгиб линии, то следует кликнуть на холсте;
• протянуть линию до входа второго компонента и кликнуть по нему. Линия связи создана.
Для выделения одного блока следует клинуть по нему ЛКМ. А если надо выделить несколько блоков то можно воспользоваться ”лассо”.
Для этого следует, удерживая ЛКМ, заключить нужные элементы внутрь растягивающегося вслед за курсором мыши прямоугольника.
Настройка параметров компонентов
Компоненты схемы настраиваются на панели Свойства. Чтобы отредактировать нужный компонент, его следует выделить и настроить значения параметров.
Или воспользоваться контекстным меню, которое появится если кликнуть ПКМ на элементе.
Если компонент схемы слишком большой, то можно скорректировать его размер. Для этого, удерживая Ctrl следует нажимать стрелку влево (для уменьшения ширины) или стрелку вправо (для увеличения ширины) компонента.
Для разработки коммутационной программы используются следующие блоки, связи и функции:
Блоки переменных | Размещение переменных для ввода и чтения промежуточных значений из коммутационной программы.
Блок константы | Для ввода фиксированного значения в коммутационную программу.
Чтение/запись в функциональный блок | Чтение и запись значений отдельных параметров из функционального блока в переменную.
Сетевой обмен | Для обмена данными с другими устройствами, подключенными к прибору по сети.
Проведение линии задержки | Для создания задержки на один цикл передачи значения с выхода блока на вход.
Преобразование типов переменных | Для передачи значений от выхода к входу различных типов.
Размещение блока комментария | Текстовые комментарии на схеме.
Перенумеровать компоненты | Переназначение порядковых номеров функциональных блоков схемы.
Задание порядка исполнения | Изменение порядка вычисления значений на выходах блоков коммутационной программы.


Переменные
На схему могут быть добавлены блоки переменных:
• входная переменная — для передачи значения в коммутационную программу;
• выходная переменная — для записи в нее значения из коммутационной программы.
Чтобы добавить блок переменной на схему, следует нажать на его пиктограмму на панели вставки:
Затем нажать на схеме в то место, куда нужно поместить блок. Блок будет добавлен:
При выделенном блоке переменной на панели Свойства следует нажать кнопку «...» в поле «Переменная».
После нажатия кнопки «...» откроется окно Таблица переменных, в которой нужно выбрать или создать новую переменную и нажать кнопку «ОК». Выбранная переменная будет привязана к добавленному блоку:
Если в процессе создания алгоритма переменная выделяется красным цветом, значит, присутствует ошибка.
Чтобы узнать об ошибке, следует навести курсор на выделенный красным блок переменной.
Для блока выходной переменной доступна настройка “Запись в конце цикла”.


Константа
На схему могут быть добавлены блоки константы [image] .
Для включения в программу жестко заданной величины используется блок константы, расположенный на панели вставки. Для размещения блока константы следует нажать на пиктограмму блок, затем – в место на схеме, где должен быть расположен блок.
На панели Свойства выбрать тип данных для константы и ввести значение. Значение будет отображено в блоке на схеме.
После запуска коммутационной программы в приборе значение константы изменить невозможно.


Чтение и запись в функциональный блок
На схему могут быть добавлены блоки:
• — чтения значения из функционального блока;
• — записи значения в функциональный блок.
Блок «Запись в ФБ» используется, чтобы в процессе выполнения алгоритма задавать различные значения для параметра функционального блока.
Например, в зависимости от значения на входе I5 в функциональном блоке «BLINK1» значение параметра «Длительность вкл. состояния» будет иметь значение 2 или 10:
Разместить на схеме блок и на панели свойства выбрать ФБ и имя переменной, в которую будет записываться значение из блока «Запись в ФБ»:
Блок «Чтение из ФБ» предназначен для считывания текущего значения параметра функционального блока и настраивается аналогичным образом.


Сетевой обмен
Работа с сетевыми переменными
Для реализации сетевых возможностей приборов в среде программирования предусмотрен специальный тип переменных – сетевые переменные, которые добавляются на схему проекта с помощью кнопок: и [image] .
Назначение каждой сетевой переменной определяется пользователем на этапе разработки коммутационной схемы. Например, сетевая переменная может служить для задания по сети уставки функционального блока «Таймер с задержкой включения», «Счётчик» и др., или сетевая переменная может быть применена для считывания текущего состояния выхода функционального блока «Универсальный счётчик».
Переменные, значение которых передаётся по сети в программу пользователя, называются сетевые входы. Переменные, которые могут быть считаны по сети – сетевые выходы.
Добавление блока сетевой переменной
Для добавления сетевой переменной в программу следует:
1. Нажать на кнопку [image] или [image] на панели инструментов, затем нажать на место на схеме, где должна располагаться переменная. На холсте появится блок сетевой переменной.
2. Нажать на блок сетевой переменной и на панели свойства в поле «Переменная» на кнопку «...».
3. Шаг 3 – в открывшейся таблице переменных выбрать (или создать новую) переменную для привязки и нажать кнопку «ОК».
4. Присоединить выход/вход сетевой переменной к необходимому компоненту.
Вышеописанный алгоритм работы с сетевыми переменными удобен, если пользователь начинает работу с проектом с программирования прибора . Если список параметров Мастера сети Modbus уже известен, работу удобнее начинать с определения сетевых переменных в таблице переменных. Более подробно о работе с Modbus см. раздел Работа по протоколу Modbus.


Линия задержки
Для создания задержки на один цикл передачи значения с выхода блока на вход используется блок Линия задержки.
Для создания блока следует нажать на пиктограмму Линия задержки на панели вставки и построить линию между выходом и входом функции или функционального блока. Будет проведена красная пунктирная линия.
Пример использования
На вход I1 блока арифметического сложения (тип целочисленный) подается константа, равная 1. На вход I1 по линии задержки подается значение с выхода блока (Q), которое было вычислено в предыдущем цикле.
Значения на входах и выходах блока:
№ цикла | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10
I2 | 0 | 0 | 1 | 1 | 2 | 2 | 3 | 3 | 4 | 4
Q | 1 | 1 | 2 | 2 | 3 | 3 | 4 | 4 | 5 | 5


Преобразование типов переменных
Соединительная связь между входом и выходом блоков коммутационной программы могут быть созданы только для входа и выхода одного и того же типа: булевского, целочисленного или с плавающей точкой. Чтобы создать связь между входом и выходом разных типов, используйте блоки преобразования.
Преобразователь в булевское значение | Преобразовывает целочисленное значение сигнала или значение с плавающей запятой в булевское. Если значение на входе больше 0, то на выходе блока будет 1 («True»).
Преобразователь в целочисленное значение | Преобразовывает булевское значение сигнала или число с плавающей запятой в целочисленное. Если на входе булевское значение 0 («False»), то на выходе будет 0, если на входе 1 («True»), то на выходе будет 1. Если на выходе число с плавающей запятой, то оно округляется с недостатком.
Преобразователь в число с плавающей запятой | Преобразовывает целочисленное значение сигнала или булевское в число с плавающей точкой. Для преобразования целочисленного в число с плавающей точкой добавляется дробная часть (int = 5 → float = 5,0000). Если на входе булевское значение 0 («False»), то на выходе будет 0,0000, если на входе 1 («True»), то на выходе будет 1,0000.
Чтобы добавить блок преобразования, следует выделить нужный на панели вставки и затем нажать в то место схемы, где он должен быть размещен.


Добавление комментария
Чтобы добавить текстовый комментарий на схему, на панели Вставка следует нажать кнопку [image] . Затем кликнуть на то место схемы, где должен располагаться комментарий. Удерживая левую кнопку мыши начертить прямоугольную область текстового блока.
Для выделенного блока комментария можно изменить настройки ввода текста на панели Свойства:
Для того чтобы цвет фона был виден, следует задать значение параметру «Прозрачность фона» более 20.
Чтобы ввести тест комментария, следует выделить двойным кликом мыши текстовый блок и ввести новый текст:
Комментарии можно добавить к компонентам на схеме, которые будут отображаться во время наведения курсора на компонент. Для этого на панели Свойства в поле «Комментарий» следует ввести текст.


Перенумерация компонентов
Переназначение порядковых номеров функциональных блоков схемы: можно нажатием кнопки [image] Перенумеровать компоненты на панели инструментов. Одноименные блоки нумеруются по порядку сверху вниз и слева направо:


Задание порядка исполнения
Вычисление значений всех выходов и обратных связей в коммутационной программе происходит в определенном порядке. Чтобы изменить порядок, следует нажать на панели отладки в выпадающем меню кнопку «Обратные связи» или «Выходы».
Чтобы изменить очередность выполнения, следует двойным щелчком мыши выделить нужный выход или обратную связь и ввести число, какой по счету должна выполняться данная операция.
После установки правильной очередности следует отключить режим настройки порядка исполнения, отжав кнопку «Обратные связи» или «Выходы».
Готовая программа может быть загружена в прибор.


Программирование экрана прибора
Если выбранный при создании проекта прибор имеет экран, то можно запрограммировать вывод на него информации проекта по определенному алгоритму. На экране может отображаться текст и значения переменных программы.
ПРИМЕЧАНИЕ
Набор символов реализован в рамках кодировки Windows-1251.
Для программирования экрана используется панель Менеджер экранов. Чтобы открыть панель Менеджера экранов следует нажать на заголовок в левой части экрана:
Откроется меню ”Менеджера экранов”.
По умолчанию на панели отображается один экран, который можно запрограммировать для вывода информации на ЖКИ прибора.
Добавление экранов
Можно настроить несколько экранов, переключение между которыми для отображения на физическом экране прибора будет осуществляться по нажатию кнопки или по событию.
Для добавления экрана следует кликнуть ПКМ по Группа 1 и в появившемся контекстном меню выбрать Добавить экран.
Для удаления экрана следует кликнуть ПКМ по нужному экрану и в появившемся меню выбрать Удалить экран.
Для смены позиции экрана, его следует перетянуть, удерживая клавишу Shift, на новое место.
При переносе новое положение будет отображаться в виде горизонтального маркера.
Свойства экрана
Для настройки свойств экрана следует выделить нужный экран на панели двойным кликом. Панель настройки свойств отобразится справа от изображения экранов. В панели следует ввести имя экрана, которое будет отображено на панели экранов и в заголовке редактора экранов.
Если в проекте участвуют два или более экранов, то необходимо настроить переходы (условия переключения) между ними. Переходы можно настроить нажатием кнопки «...» в строке «Переход к экрану».
Для создания перехода следует кликнуть ПКМ по Группа 1 и выбрать Редактировать группу в появившемся контекстном меню. Потом выделить необходимый экран и задать переходы в панели Коллекция переходов.
Переход к экрану
Для настройки перехода от «Экрана1» к «Экрану2» следует перейти в свойствах Экрана 1 к настройке перехода, как описано выше, и в открывшемся окне выбрать «Экран2» в строке «Список экранов»:
Во втором поле окна создания перехода выбирается условие, при котором осуществляется переключение на «Экран2».
Генерация события от прибора — выбор кнопки для переключения на указанный экран.
Изменение значения переменной — в таблице переменных выбирается переменная двоичного (boolean) типа, в случае изменения значений значения которой будет осуществлен переход к экрану.
Для завершения настройки экранов следует нажать кнопку «ОК», на панели менеджера экранов будет отображен переход:
Переход от экрана к экрану может происходить по различным событиям, для этого можно настроить коллекцию переходов. Переходы добавляются аналогично описанию выше.
Редактор экранов
Для настройки вывода информации на экран следует открыть редактор экрана двойным кликом по изображению экрана на панели или с помощью кнопки [image] Редактировать.
Один экран может содержать несколько строк, переход к которым осуществляется с помощью кнопок прибора. Для добавления и удаления строк следует открыть [image] Контекстное меню строки.
В строках располагаются нужные информационные блоки (элементы управления), которые перетаскиваются их из панели Библиотека методом drag & drop. Описания блоков приведены в разделе Элементы управления.


Библиотека
ВНИМАНИЕ
Для разных приборов список доступных элементов библиотеки может отличаться.
При открытом проекте на панели Библиотека доступны вкладки, на которых размещены компоненты, используемые при разработке коммутационной программы.
Логические элементы в программе делятся на функциональные блоки и функции.
Функции не сохраняют состояния своих внутренних переменных. К функциям относятся такие элементы как AND, OR, XOR, NOT и другие. Число используемых функций ограничено только объемом памяти прибора.
Функциональные блоки (ФБ) сохраняют состояния своих внутренних переменных. К ФБ относятся триггеры, счетчики таймеры и другие. Каждый прибор имеет собственное ограничение на количество используемых ФБ (см. руководство по эксплуатации прибора).
Макросы позволяют создавать пользовательские ФБ.
Вкладка «Макросы проекта» позволяет расширить число применяемых в проекте ФБ за счет созданных пользователем макросов. Так же в «Макросы проекта» отображаются загруженные с помощью «Менеджера компонентов» макросы.
Элементы управления предназначены программирования экрана прибора. Данный набор компонентов появляется при работе в «Менеждере экранов» при выборе опции «Загрузить в проект».


Функции
Логические функции
Арифметические функции
Функции сравнения
Сдвиговые функции
Битовые функции


Логические функции
Логическое И (AND)
Логическое ИЛИ (OR)
Логическое НЕ (NOT)
Исключающее ИЛИ (XOR)
Особенностью работы логических блоков является их самонастройка на тип переменных. Если первой к блоку была подключена целочисленная переменная, то блок автоматически перестраивается на работу с целочисленными переменными. Данный принцип проиллюстрирован на изображении ниже.
При использовании функций И и ИЛИ следует учитывать, что не подключенные входы логических элементов к входам прибора или другим элементам в программе, будут иметь следующие состояния:
• для элемента И – логическая «1»;
• для элемента ИЛИ – логический «0».
В этом случае логические элементы выполняют функцию повторителя сигнала. Для увеличения числа входов у логических элементов используется их каскадное включение:


Функция И (AND)
Если на всех входах присутствуют сигналы логической «1» (все входы включены – контакты замкнуты), на выходе элемента появляется сигнал логической «1» (выход включен).
Работе соответствует таблица состояний:
I1 | I2 | Q
0 | 0 | 0
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1
Если на входы функции приходят целочисленные значения, то операция будет произведена над каждым битом в отдельности:
И | 0011
 | 0101
 | 0001


Функция ИЛИ (OR)
Если на одном входе присутствует сигнал логической «1» (контакты замкнуты), то на выходе элемента появляется логическая «1» (выход включен).
Работе соответствует приведенная таблица состояний:
I1 | I2 | Q
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 1
Если на входы функции приходят целочисленные значения, то операция будет произведена над каждым битом в отдельности:
ИЛИ | 0011
 | 0101
 | 0111


Функция НЕ (NOT)
Элемент используется для инвертирования сигнала.
Если на входе появляется сигнал логического «0» (контакты разомкнуты), то на выходе элемента появляется логическая «1» (выход включен), и наоборот: сигнал инвертируется.
Работе соответствует приведенная таблица состояний:
I1 | I2
0 | 1
1 | 0
Если на входы функции приходят целочисленные значения, то операция будет произведена над каждым битом в отдельности:
НЕ | 01
 | 10


Функция Исключающее ИЛИ (XOR)
На выходе элемента появляется логическая «1» (выход включен), если только на одном их входов появляется логическая «1».
Работе соответствует приведенная таблица состояний:
Если на входы функции приходят целочисленные значения, то операция будет произведена над каждым битом в отдельности:
XOR | 0011
 | 0101
 | 0110


Арифметические функции
ВНИМАНИЕ
Арифметические функции с плавающей запятой не доступны для приборов линейки ПР110.
Арифметические операции могут производиться над переменными целочисленного типа и типа с плавающей запятой:
Название | Целочисленные | С плавающей запятой
Сложение | ADD | fADD
Вычитание | SUB | fSUB
Умножение | MUL | fMUL
Деление | DIV | fDIV
Деление с остатком | MOD | -
Возведение в степень | - | fPOW
Модуль от числа | - | fABS


Сложение (ADD, fADD)
Для операций над целочисленными переменными используется блок ADD, над переменными с плавающей запятой — fADD.
Результатом выполнения операции на выходе является сумма входных значений.
Если во время выполнения операции значение числа получается больше 4294967295 (32 бита), то биты, выходящие за разрядность 32 бита, отсекаются.
Пример применения элементов для сложения чисел 24 + 2 + 4 + 7 = Q:


Вычитание (SUB, fSUB)
Для операций над целочисленными переменными используется блок SUB, над переменными с плавающей запятой — fSUB.
Результатом выполнения операции на выходе является разность входных значений.
Если во время выполнения операции на первом входе (V1) значение числа меньше второго (V2), то результатом будет число, полученное сложением младшего числа плюс 0x100000000 (4294967296) минус значение числа большего: [(V1 + 0x100000000) – V2] = Q.
Пример применения элемента для вычитания чисел 24 – 2 = Q = 22:
Пример применения элемента для вычитания чисел, где V1 меньше V2: 2 – 24 = Q = 4294967274.


Умножение (MUL, fMUL)
Для операций над целочисленными переменными используется блок MUL, над переменными с плавающей запятой — fMUL.
Результатом выполнения операции умножения на выходе является произведение входных значений.
Если во время выполнения операции значение числа получается больше 4294967295 (32 бита), то биты, выходящие за разрядность 32 бита, отсекаются.
Пример применения элементов для перемножения чисел 24 · 2 · 4 · 7 = Q:


Деление (DIV, fDIV)
Для операций над целочисленными переменными используется блок DIV, над переменными с плавающей запятой — fDIV.
Результатом выполнения операции деления на выходе является частное от деления входных значений.
Если во время использования блока DIV в результате деления получаются доли целого числа, то на выходе производится округление значения до целого числа в меньшую сторону.
В случае деления на 0 на выходе элемента будет значение 0хFFFFFFFF.


Деление с остатком (MOD)
Элемент вычисляет и передает на выход (Q) остаток от деления входных целочисленных значений: V1 / V2.
Пример применения элемента для выделения целого остатка от деления числа 22 на 3:
На рисунке изображен элемент MOD, вычисляющий остаток от деления в режиме симулятора. Выход Q = 1.
В случае деления на 0 на выходе элемента будет значение 0.


Возведение числа в степень (fPOW)
Блок работает с переменными с плавающей запятой (float).
Результатом выполнения операции на выходе блока является переменная типа float, равная числу V1, возведенному в степень V2:
Q = V1V2
Пример использования:
На рисунке показана работа элемента fPOW в режиме симулятора. На входы V1 и V2 подаются константы со значениями 3 и 4 соответственно, на выходе Q вычисленное значение — 81.


Взятие модуля от числа (fABS)
Блок работает с переменными с плавающей запятой (float).
Результатом операции на выходе является модуль подаваемой на вход переменной:
Q = |V|
Пример использования (рисунки работы блока в режиме симулятора):


Функции сравнения
Равно (EQ)
Больше (GT, fGT)
Выбор (SEL)


Равно (EQ)
Результатом выполнения операции на выходе является логическая «1», если входные числа равны:
V1 = V2 → Q = 1
V1 > V2 → Q = 0
V1 < V2 → Q = 0
Примеры применения элементов:


Больше (GT, fGT)
Для сравнения целочисленных переменных (integer) используется блок GT, для переменных с плавающей запятой (float) - блок fGT.
Если входное число на первом входе (V1) больше числа на втором входе (V2), то результатом выполнения операции на выходе является сигнал логической «1».
V1 = V2 → Q = 0
V1 > V2 → Q = 1
V1 < V2 → Q = 0
Примеры применения элементов:


Выбор (SEL, fSEL)
Для выбора целочисленных переменных (integer) используется блок SEL, для переменных с плавающей запятой (float) — блок fSEL.
Если V1 равен логическому «0», то результатом выполнения операции на выходе является входной сигнал V2, и если V1 равен логической «1», то результатом выполнения операции на выходе является входной сигнал V3.
V1 = 0 → Q = V2
V1 = 1 → Q = V3
Примеры применения элементов:


Сдвиговые функции
Логический сдвиг влево (SHL)
Логический сдвиг вправо (SHR)


Побитовый логический сдвиг влево (SHL)
Элемент используется для выполнения операции побитового логического сдвига операнда X влево на N бит с дополнением нулями справа.
Пример применения для сдвига числа 38 (десятичное) = 00100110 (двоичное):


Побитовый логический сдвиг вправо (SHR)
Элемент используется для выполнения операции побитового логического сдвига операнда X вправо на N бит с дополнением нулями слева.
Пример применения для сдвига числа 152 (десятичное) = 10011000 (двоичное):


Битовые функции
Чтение бита (EXTRACT)
Запись бита (PUTBIT)
Дешифратор (DC32)
Шифратор (CD32)


Чтение бита (EXTRACT)
Элемент используется для выполнения операции чтения значения бита N в числе на входе X. Биты нумеруются с нуля. Число на входе Х задается в десятичной системе. Выходное значение всегда двоичное (0 или 1).
Пример применения для чтения пятого бита из числа 81 (десятичное) = 1010001 (двоичное):


Запись бита (PUTBIT)
Элемент используется для выполнения операции записи в числе X значения бита N в состояние, указанное на входе B (логические «0» или «1»). Число на входе Х задается в десятичной системе. Выходное значение целочисленное.
Пример применения записи четвертого бита в сигнале логической «1» для числа 38 (десятичное) = 100110 (двоичное):


Дешифратор (DC32)
Элемент используется для выполнения операции преобразования двоичного кода на входе в позиционный код на выходе. Перед выполнением операции над значением на входе предварительно выполняется побитовая логическая операция «И» с операндом 0x1F (11111b).
Работе элемента соответствует приведенная таблица состояний:
Пример применения:


Шифратор (CD32)
Элемент используется для выполнения операции преобразования позиционного кода на входе в двоичный код на выходе.
Если входное двоичное значение имеет более одной логической «1» в разрядах, работа элемента ведется только со старшим единичным разрядом.
Работе элемента соответствует таблица состояний:


Функциональные блоки
Триггеры
Таймеры
Генераторы
Счетчики
Регуляторы


Триггеры
RS-триггер с приоритетом выключения
SR-триггер с приоритетом включения
Детектор переднего фронта импульса (RTRIG)
Детектор заднего фронта импульса (FTRIG)
D-триггер (DTRIG)


RS-триггер с приоритетом выключения
Блок используется для переключения с фиксацией состояния во время поступления коротких импульсов на соответствующий вход. Работу поясняет приведенная на рисунке ниже диаграмма.
На выходе блока появится логическая «1» по фронту сигнала на входе S.
В случае одновременного поступления сигналов на входы приоритетным является сигнал входа R.


SR-триггер с приоритетом включения
Блок используется для переключения с фиксацией состояния в случае поступления коротких импульсов на соответствующий вход. Работу поясняет приведенная на рисунке ниже диаграмма.
На выходе блока появится логическая «1» по фронту сигнала на входе S.
В случае одновременного поступления сигналов на входы приоритетным является сигнал входа S.


Детектор переднего фронта импульса (RTRIG)
Блок используется в случае необходимости иметь реакцию на изменение состояния дискретного входного сигнала. На выходе генерируется единичный импульс по переднему фронту входного сигнала.
Работу блока объясняет приведенная на рисунке ниже диаграмма.


Детектор заднего фронта импульса (FTRIG)
Блок используется в случае необходимости иметь реакцию на изменение состояния дискретного входного сигнала. На выходе генерируется единичный импульс по заднему фронту входного сигнала.
Работу блока объясняет приведенная на рисунке ниже диаграмма.


D-триггер (DTRIG)
Блок используется для формирования импульса включения выхода на интервал времени импульса на входе D, выходной интервал будет синхронизирован с тактовой частотой на входе С.
На выходе Q блока появится сигнал логической «1» по фронту тактовых импульсов на входе С при наличии сигнала логической «1» на входе D. Возврат выхода в сигнал логического «0» произойдет по фронту тактовых импульсов на входе С при наличии сигнала логического «0» на входе D.
Работу блока объясняет приведенная на рисунке диаграмма.
Вход S принудительно устанавливает выход Q в состояние логической «1»;
Вход R является приоритетным и устанавливает выход Q в состояние логического «0».


Таймеры
Импульс включения заданной длительности (TP)
Таймер с задержкой включения (TON)
Таймер с задержкой отключения (TOF)
Интервальный таймер (CLOCK)
Интервальный таймер с недельным циклом (CLOCKWEEK)


Импульс включения заданной длительности (TP)
Блок используется для формирования импульса включения выхода на заданный интервал времени. Работу блока объясняет приведенная на рисунке ниже диаграмма.
На выходе Q блока появляется сигнал логической «1» по фронту входного сигнала (I). После запуска выход Q не реагирует на изменение значения входного сигнала на интервале Tимп, а по истечении этого интервала выходной сигнал сбрасывается в «0».
Допустимый диапазон значений Тимп = Т: от 0 до 4147200000 мс или 48 дней.
Длительность импульса и единицы измерения времени настраиваются на панели свойств:


Таймер с задержкой включения (TON)
Блок используется для операции задержки передачи сигнала. Работу блока объясняет приведенная на рисунке ниже диаграмма.
На выходе Q блока появится сигнал логической «1» с задержкой относительно фронта входного сигнала (I). Выход включается логической «1» на входе продолжительностью не менее длительности Т и выключается по спаду входного сигнала.
Допустимый диапазон значений Т: от 0 до 4147200000 мс, или 48 дней.
Время задержки включения и единицы измерения времени настраиваются на панели свойств:


Таймер с задержкой отключения (TOF)
Блок используется для задержки отключения выхода. Работу блока объясняет приведенная на рисунке ниже диаграмма.
На выходе блока появится сигнал логической «1» по фронту сигнала на входе I, отсчет времени задержки отключения (Tзад) начнется по каждому спаду входного сигнала. После отключения входного сигнала на выходе появится сигнал логического «0» с задержкой Tзад.
Допустимый диапазон значений Тзад: от 0 до 4147200000 мс, или 48 дней.
Время задержки выключения и единицы измерения времени настраиваются на панели свойств:


Интервальный таймер (CLOCK)
ПРИМЕЧАНИЕ
Данный таймер доступен только для приборов с часами реального времени.
Настройка времени включения и отключения производится на панели свойств:
Блок используется для формирования импульса включения выхода по часам реального времени. Работу блока объясняет приведенная на рисунке ниже диаграмма:
Время включения (Твкл) и отключения (Тоткл) выходов устанавливают в качестве параметров блока.
Допустимый диапазон значений Твкл и Тоткл: от 0,00 с до 24 ч.
Если заданное значение времени отключения меньше времени включения, то диаграмма переключений будет иметь вид:


Интервальный таймер с недельным циклом (CLOCKWEEK)
ПРИМЕЧАНИЕ
Данный таймер доступен только для приборов с часами реального времени.
Настройка времени включения и отключения производится на панели свойств:
Блок используется для формирования импульса включения выхода по часам реального времени, с учетом дней недели. Работу блока объясняет диаграмма на рисунке ниже:
Внутренняя структура блока имеет вид:
Время включения (Твкл), отключения (Тоткл) выхода и дни недели работы устанавливают в качестве параметров блока.
Допустимый диапазон значений Твкл и Тоткл: от 0,00 с до 24 ч.


Генераторы
Генератор прямоугольных импульсов (BLINK)


Генератор прямоугольных импульсов (BLINK)
Блок используется для формирования прямоугольных импульсов пульсации.
На выходе Q генератора формируются импульсы с заданными параметрами длительности включенного (Твкл – сигнал логической «1») и отключенного (Тоткл – сигнал логического «0») состояния на время действия управляющего сигнала на входе I (сигнал логической «1»).
Допустимый диапазон значений Твкл и Тоткл: от 0 до 4233600000 мс или 49 дней.
Длительность включенного и отключенного состояний настраиваются на панели свойств:


Счетчики
Инкрементный счетчик с автосбросом (CT)
Универсальный счетчик (CTN)
Инкрементный счетчик (CTU)


Инкрементный счетчик с автосбросом (CT)
Блок используется для подсчета заданного числа импульсов N (вход Т – уставка числа импульсов).
На выходе Q счетчика появится импульс сигнала логической «1» с длительностью рабочего цикла прибора (Tцикл), если число приходящих на вход I импульсов достигнет установленного значения N (на входе Т).
Допустимый диапазон значений числа импульсов N: от 0 до 65535.
Число импульсов N и параметр сохранения состояния задаются на панели свойств:


Универсальный счетчик (CTN)
Блок является счетчиком, который используется для прямого и обратного счета. Операция «прямой счет» выполняется по переднему фронту импульса на входе прямого счета (U), что увеличивает значение выходного сигнала «Q».
Импульсы, приходящие на вход D («обратный счет»), уменьшают значение выхода «Q».
В случае поступления на вход R сигнала логической «1», выход счетчика «Q» устанавливается в значение входа N.
В случае одновременного поступления сигналов на входы U и D приоритетным является сигнал входа U.
Допустимый диапазон значений числа импульсов N: от 0 до 65535.
Значение N и параметр сохранения состояния задаются на панели свойств:


Инкрементный счетчик (CTU)
ВНИМАНИЕ
Блок Write to FB для CTU не работает. Вместо CTU рекомендуется использовать счетчик CTN.
Блок используется для подсчета числа импульсов, приходящих на вход С. На выходе Q счетчика появится импульс сигнала логической «1», если число приходящих на вход импульсов достигнет установленного значения на входе N (N – уставка).
Допустимый диапазон значений числа импульсов N: от 0 до 65535.
Счетчик сбрасывается в 0 по переднему фронту импульса на входе R. В случае одновременного поступления сигналов на входы приоритетным является сигнал входа R.
Число импульсов N задается на панели свойств:


Регуляторы
ПИД-регулятор (PID)


ПИД-регулятор (PID)
Функциональный блок используется для реализации пропорционально-интегрально-дифференциального (ПИД) закона регулирования.
Входы блока
Название | Тип | Описание | Значения
E | булевский | Разрешение на работу блока. В выключенном состоянии на выход блока подается значение, заданное в свойстве «выходная мощность» | 0 – Выключен 1 – Включен
Pv | с плавающей запятой | Текущее значение регулируемой величины |
Sp | с плавающей запятой | Заданное значение регулируемой величины |
Выходы блока
Название | Тип | Описание | Значения
Pwr | с плавающей запятой | Выходная мощность, % | 0 ... 100
Свойства
Название
Тип
Описание
Значения
Режим работы регулятора
булевский
Режимы работы регулятора:
• режим «нагреватель», используется для управления исполнительными механизмами, воздействие которых приводит к росту значения регулируемой величины;
• режим «холодильник», используется для управления исполнительными механизмами, воздействие которых приводит к снижению значения регулируемой величины
0 – Нагреватель
1 – Холодильник
Выходная мощность | с плавающей запятой | Выходная мощность в выключенном состоянии, % | 0 ... 100
Пропорци-ональный коэффициент | с плавающей запятой | Пропорциональный коэффициент с которым работает ПИД, с | –1E–44 ... 1E+38
Интегральный коэффициент | с плавающей запятой | Интегральный коэффициент с которым работает ПИД, с | –1E–44 ... 1E+38
Дифференци-альный коэффициент | с плавающей запятой | Дифференциальный коэффициент с которым работает ПИД, с | –1E–44 ... 1E+38
Максимальная мощность (значение по умолчанию)
с плавающей запятой
Верхнее ограничение выдаваемой мощности, %
0 ... 100 (80)
Минимальная мощность (значение по умолчанию)
с плавающей запятой
Нижнее ограничение выдаваемой мощности, %
0 ... 100 (20)
Запуск АНР
булевский
Переменная, которая генерирует запуск автонастройки регулятора в случае подачи значения «True». Значение данной переменной задается с помощью блока «Запись в ФБ»
0 – Стоп
1 – Запуск
Автонастройка
Автонастройка проводится с помощью блоков «Запись в ФБ» и «Чтение из ФБ» ( [image] ).
Для автонастройки следует разместить на схеме и настроить функциональный блок PID и блоки чтения и записи.
Для запуска автонастройки следует добавить блок «Запись в ФБ» и привязать его к переменной «Запуск АНР» функционального блока PID1.
Значения остальных параметров функционального блока можно задавать с помощью блока «Запись в ФБ», как показано на рисунке выше, либо настраивать на панели Свойства.
С помощью блоков «Чтение из ФБ» считываются значения параметров «Рассчитанный пропорциональный коэффициент», «Рассчитанный интегральный коэффициент», «Рассчитанный дифференциальный коэффициент» и «Флаг окончания автонастройки».
Для старта автонастройки следует подать сигнал на вход «E» = «True».
По завершении процесса автонастройки для чтения доступны новые значения коэффициентов: «Рассчитанный пропорциональный коэффициент», «Рассчитанное время интегрирования» и «Рассчитанное время дифференцирования». Параметр «Флаг окончания автонастройки» выставляется в «True». Если после этого сбросить вход «Запуск АНР» в «False», то сбросится и флаг окончания.
ВНИМАНИЕ
Флаг окончания автонастройки находится в состоянии «True» один цикл.
Если сбросить вход «Запуск АНР» в значение «False» до окончания настройки, то процесс останавливается, флаг окончания не выставляется, новые значения коэффициентов не вычисляются.
Во время процесса настройки на выход функционального блока PID1 подается тестовая мощность, ограниченная значениями параметров «Максимальная мощность» и «Минимальная мощность».
Последовательность автонастройки для режима «Нагреватель»:
1. Текущее значение меньше уставки, на выход блока подается максимальная мощность (в соответствии с настройками).
2. Как только текущее значение станет больше уставки, на выход блока подается минимальная мощность.
3. Повторение шагов 1 и 2.
4. Рассчитанные параметры ПИД-регулятора подаются на соответствующие выходы, и выставляется флаг окончания.
Если в настройках указанo значение максимальной мощности, при которой невозможно достичь уставки, процесс автонастройки не закончится, пока он не будет сброшен вручную.


Макросы
Макросы представляют собой ФБ, созданные пользователем в “Редакторе макросов”.
Для добавления макроса в проект следует перетащить макрос из “Библиотеки компонентов” на холст проекта:
Чтобы удалить макрос из библиотеки, следует выделить нужный макрос и нажать на [image] .
Рекомендации по созданию макросов приведены в разделе Работа с макросами.


Работа с макросами
Основные действия с макросами:
• сохранение в Библиотеке компонентов для дальнейшего использования в проекте;
• экспортирование в файл для использования в других проектах;
• импортирование созданные ранее макросы;
• загрузка из онлайн-базы в библиотеку проекта.
Создание макроса
Для создания макроса следует:
1. Выбрать команду «Файл → Создать макрос». В открывшемся диалоговом окне задать количество входов и выходов в макросе:
2. Разработать алгоритм работы макроса во вкладке «Редактор макросов», аналогично разработке основной коммутационной программы.
Количество входов и выходов можно увеличить с помощью контекстного меню редактора или с помощью кнопок [image] и [image] .
Чтобы удалить вход или выход, следует кликнуть ПКМ и выбрать команду «Удалить».
3. Задать имя и описание для макроса на панели Свойства:
Введенное имя будет указано в заголовке редактора макросов.
4. Для определения типа и имени входов/выходов выделить курсором вход или выход и настроить его на панели Свойства.
5. Создать логику работы макроса.
6. Далее можно задать «видимость» из коммутационной программы уставок функциональных блоков, использованных в макросе.
Чтобы уставки выбранного ФБ были доступны во время использования ФБ в коммутационной программе, следует настроить в окне свойств блока параметр «Использование в макросе»: Да.
После выбора варианта ”Да” появится выпадающий список “Переименование переменных” с перечислением доступных переменных. Например, для Blink:
7. После создания макроса следует запустить Симулятор и проверить логику его работы.
8. Перед сохранением макроса можно заполнить поля: Имя, Описание, Автор, Имя группы и Пароль доступа.
Рекомендуется задавать недлинное и понятное имя макроса. Содержимое поля Описание отображается под изображением макроса в панели Библиотека.
Если пароль не задан (поле Пароль не заполнено), то доступ на редактирование макроса открыт для всех.
Если не заполнено поле Имя группы, то макрос сохраняется в библиотеке проекта в группе Другие.
Сохранить макрос можно, выбрав команду меню «Файл → Сохранить макрос как».
9. Выбрать вкладку «Макросы проекта» для добавления макроса к коммутационной программе на панели «Библиотека компонентов» и перенести его на холст основной коммутационной программы.
Экспорт макроса
Экспортировать макрос в файл возможно только при открытом окне редактора макроса. Если нужно экспортировать макрос, сохраненный на панели библиотеки, то:
1. Открыть макрос в редакторе.
Если перед сохранением макрос нужно отредактировать, то его следует перетащить на холст коммутационной программы и в контекстном меню макроса выбрать «Редактировать» и внести изменения.
2. Далее в меню «Файл» следует нажать «Экспорт макроса в файл».
3. В открывшемся окне выбрать место расположения и сохранить файл макроса с расширением *.tpl. После сохранения отобразится сообщение об успешном экспорте макроса.
Импорт макроса
Если для создания коммутационной программы требуется использовать макрос, созданный в другом проекте, то этот макрос можно импортировать в проект.
В меню «Файл» следует выбрать пункт «Импорт макроса из файла».
В открывшемся окне выбрать нужный файл и нажать кнопку «ОК». Макрос будет добавлен в панель Библиотека в раздел «Макросы», теперь его можно использовать в проекте.


Элементы управления
С помощью элементов из данного раздела осуществляется обмен данными между выполняемой программой и экраном прибора.
Метка — выводит текстовое сообщение на экран.
Ввод/Вывод (int/float) — организует ввод/вывод на экран значения целочисленной или вещественной переменной.
Ввод/вывод (Boolean) — организует ввод/вывод на экран значения булевской переменной.
Динамический текст — в зависимости от значения переменной программы выводит определенный вариант текстовой строки.
ComboBox — выбор варианта в комбинированном меню и запись числа, соответствующего выбору, в переменную коммутационной программы.
Элементы можно разместить из “Библиотеки компонентов” на экран в редакторе методом drag & drop. Для более точного расположения следует задать координаты экрана на панели свойств.


Метка
Элемент предназначен для размещения текстового блока в строке экрана.
Настройка свойств
Для корректного отображения на экране прибора следует указать координаты расположения и ввести текст на панели свойства:
Координаты
Для расположения первого символа метки по осям X и Y следует указать координаты. Отсчет координат по обеим осям начинается с 0:
• по оси Х — слева направо от 0 до 15 (в зависимости от свойства «Длина»);
• по оси Y — сверху вниз (в зависимости от количества срок экрана, установленного в редакторе экранов).
Задать значение координат (целое число) можно в выпадающем меню в строке координаты (X и Y настраиваются одинаково):
На открывшейся панели можно выбрать способ задания координат: константа или переменная. Для выбора неизменного расположения блока «Метка» следует указать значение координаты в поле ввода.
Для создания бегущей строки следует выбрать вариант «переменная» и нажать кнопку «Выбор» Откроется Таблица переменных, выберите в ней переменную целочисленного типа, которая будет определять значение координаты, и нажать кнопку «ОК». Выбранная переменная будет отображаться в поле ввода:
Параметры
Текст — в поле вводится текст, который будет отображаться на экране прибора. Длина текста не должна превышать значение, указанное для параметра «Длина».
Длина — максимальное количество отображаемых символов блока.
Отображение
В редакторе экранов отображается, как будет выглядеть текстовый блок на экране прибора:


Ввод/Вывод (int/float)
Элемент для вывода на экран прибора или чтения с экрана значения целочисленной или вещественной переменной.
Настройка свойств
Для корректной работы элемента следует указать координаты расположения и настроить параметры ввода/вывода на панели свойства:
Диапазон
Контроль — позволяет ограничить значение, которое пользователь вводит с лицевой панели прибора. Это ограничение не распространяется на значение, полученное в ходе работы программы.
Максимум — максимальное значение параметра для ввода.
Минимум — минимальное значение параметра для ввода.
Координаты
Для расположения первого символа метки следует указать координаты по осям X и Y. Отсчет координат по обеим осям начинается с 0:
• по оси Х — слева направо от 0 до 15 (в зависимости от свойства «Длина»);
• по оси Y — сверху вниз (в зависимости от количества строк экрана, установленного в редакторе экранов).
Задать значение координат (целое число) можно в выпадающем меню в строке координаты (X и Y настраиваются одинаково):
На открывшейся панели можно выбрать способ задания координат: константа или переменная. Для выбора неизменного расположения блока «Метка» следует указать значение координаты в поле ввода.
Для создания бегущей строки следует выбрать вариант «переменная» и нажать кнопку «Выбор». Откроется Таблица переменных, в ней следует переменную целочисленного типа, которая будет определять значение координаты, и нажать кнопку «ОК». Выбранная переменная будет отображаться в поле ввода:
Параметры
Переменная — привязка к переменной проекта (целочисленной или с плавающей точкой). Для выбора переменной следует нажать кнопку «…» и выбрать Таблице переменных.
Тип переменной — выбор типа переменной: целочисленный или вещественный. Если переменная еще не привязана, то необходимо задать тип , в противном случае тип определяется автоматически.
Знаков — суммарное количество отображаемых знаков до и после запятой.
После запятой — количество знаков после запятой: до 6 знаков или определяется автоматически (Авто). Более подробную информацию читайте в руководстве пользователя прибора.
Текст до — текст слева от числового значения.
Текст после — текст справа от числового значения.
Редактируемо — если «Да», то значение привязанной переменной можно изменять с помощью кнопок на лицевой панели прибора.
Длина — общая максимальная длина поля, включающая текст до, значение переменной и текст после.
Отображение


Ввод/Вывод (boolean)
Элемент для вывода на экран или чтения с экрана значения булевской переменной.
Настройка свойств
Координаты
Координаты расположения первого символа метки следует указать по осям X и Y. Отсчет координат по обеим осям начинается с 0:
• по оси Х — слева направо от 0 до 15 (в зависимости от свойства «Длина»);
• по оси Y — сверху вниз (в зависимости от количества строк экрана, установленного в редакторе экранов).
Задать значение координат (целое число) можно в выпадающем меню в строке координаты (X и Y настраиваются одинаково):
На открывшейся панели можно выбрать способ задания координат: константа или переменная. Для выбора неизменного расположения блока «Метка» следует указать значение координаты в поле ввода.
Для создания бегущей строки следует выбрать вариант «переменная» и нажать кнопку «Выбор». Откроется Таблица переменных, в ней следует выбрать переменную целочисленного типа, которая будет определять значение координаты и нажать кнопку «ОК». Выбранная переменная будет отображаться в поле ввода:
Параметры
Переменная — привязка к булевской переменной проекта. Для выбора переменной следует нажать кнопку «…» и выбрать в Таблице переменных.
Текст «True» — текст, соответствующий значению переменной, равному «1».
Текст «False» — текст, соответствующий значению переменной, равному «0».
Текст до — текст слева от выводимого значения.
Текст после — текст справа от выводимого значения.
Редактируемо — если выбрано значение «Да», то значение привязанной переменной можно изменять с помощью кнопок на лицевой панели прибора.
Длина — общая максимальная длина поля, включающая текст до, значение переменной и текст после.
Отображение


Динамический текст
Элемент для вывода на экран прибора одной из нескольких текстовых строк в зависимости от значения привязанной переменной.
Настройка свойств
Координаты
Для расположения первого символа метки следует указать координаты по осям X и Y. Отсчет координат по обеим осям начинается с 0:
• по оси Х — слева направо от 0 до 15 (в зависимости от свойства «Длина»);
• по оси Y — сверху вниз (в зависимости от количества строк экрана, установленного в редакторе экранов).
Задать значение координат (целое число) можно в выпадающем меню (X и Y настраиваются одинаково):
На открывшейся панели можно выбрать способ задания координат: константа или переменная. Для выбора неизменного расположения блока «Метка» следует указать значение координаты в поле ввода.
Для создания бегущей строки следует выбрать вариант «переменная» и нажать кнопку «Выбор». Откроется Таблица переменных, в ней следует выбрать переменную целочисленного типа, которая будет определять значение координаты, и нажать кнопку «ОК». Выбранная переменная будет отображаться в поле ввода:
Параметры
Переменная — привязка к целочисленной переменной проекта. Для выбор переменной следует нажать кнопку «…» и выбрать в Таблице переменных.
Список строк — таблица, в каждой строке которой значению привязанной целочисленной переменной («Значение») соответствует выводимая на экран текстовая строка («Текст»). В столбце «Символов» указывается количество символов в строке, восклицательный знак выводится при превышении значения параметра «Длина».
Длина — максимальная длина поля. В случае превышения длины текст будет отображаться не полностью.
Отображение


Комбинированный список (ComboBox)
Данный элемент используется для выбора одной строки из нескольких текстовых строк и записи в привязанную переменную значения, соответствующего выбору.
Настройка свойств
Координаты
Для расположения первого символа метки следует указать координаты по осям X и Y. Отсчет координат по обеим осям начинается с 0:
• по оси Х — слева направо от 0 до 15 (в зависимости от свойства «Длина»);
• по оси Y — сверху вниз (в зависимости от количества строк экрана, установленного в редакторе экранов).
Задать значение координат (целое число) можно в выпадающем меню в строке координаты (X и Y настраиваются одинаково):
На открывшейся панели можно выбрать способ задания координат: константа или переменная. Для выбора неизменного расположения блока «Метка» следует указать значение координаты в поле ввода.
Для создания бегущей строки следует выбрать вариант «переменная» и нажать кнопку «Выбор». Откроется Таблица переменных, в ней следует выбрать переменную целочисленного типа, которая будет определять значение координаты, и нажать кнопку «ОК». Выбранная переменная будет отображаться в поле ввода.
Параметры
Переменная — привязка к целочисленной переменной проекта. Для выбора переменной следует нажать кнопку «…» и выбрать в Таблице переменных.
Список строк — таблица, в каждой строке которой значению привязанной целочисленной переменной («Значение») соответствует выводимая на экран текстовая строка («Текст»). В столбце «Символов» указывается количество символов в строке, восклицательный знак выводится при превышении значения параметра «Длина».
Длина — максимальная длина поля. В случае превышения длины текст будет отображаться не полностью.
Отображение


Содержание
Используемые аббревиатуры и термины
О программе
Назначение
Требования к ПК
«Горячие» клавиши
Время цикла
Принцип выполнения коммутационной программы
Начало работы
Быстрый старт
Включатель света с автоматическим отключением
Автоматическое управление электромотором мешалки
Вывод значения переменной на экран
Задание уставок таймеров с экрана
Пример подключения ПР200 к OwenCloud через шлюз ПМ210 по протоколу Modbus RTU
Упаковка/распаковка бит/целых чисел
Обработка битовых переменных с помощью маски
Описание интерфейса
Главное меню
Информация о проекте
Менеджер компонентов
Добавление компонента в проект
Панель свойств
Загрузка в прибор
Обновление встроенного ПО
Информация о приборе
Настройка прибора
Экран
Часы
Интерфейсы
Работа по протоколу Modbus
RS-485
RS-485 режим Master
RS-485 режим Slave
Шаблоны сетевых устройств
Модули расширения
Входы и выходы
Юстировка входов/выходов
Таблица переменных
Свойства переменных
Типы переменных
Настройка порта
Режим симулятора
Расширения
Управление расширениями
Расширение «Мастер тиражирования»
Расширение «Экспорт устройства в OPC»
Расширение «Экспорт устройства в OwenCloud»
Рабочая область
Панель Библиотека компонентов
Панель «Переменные»
Менеджер и редактор экранов
Панель статуса
Создание проекта и порядок работы
Разработка коммутационной программы
Переменные
Константа
Чтение и запись в функциональный блок
Сетевой обмен
Линия задержки
Преобразование типов переменных
Добавление комментария
Перенумерация компонентов
Задание порядка исполнения
Программирование экрана прибора
Библиотека
Функции
Логические функции
Функция И (AND)
Функция ИЛИ (OR)
Функция НЕ (NOT)
Функция Исключающее ИЛИ (XOR)
Арифметические функции
Сложение (ADD, fADD)
Вычитание (SUB, fSUB)
Умножение (MUL, fMUL)
Деление (DIV, fDIV)
Деление с остатком (MOD)
Возведение числа в степень (fPOW)
Взятие модуля от числа (fABS)
Функции сравнения
Равно (EQ)
Больше (GT, fGT)
Выбор (SEL, fSEL)
Сдвиговые функции
Побитовый логический сдвиг влево (SHL)
Побитовый логический сдвиг вправо (SHR)
Битовые функции
Чтение бита (EXTRACT)
Запись бита (PUTBIT)
Дешифратор (DC32)
Шифратор (CD32)
Функциональные блоки
Триггеры
RS-триггер с приоритетом выключения
SR-триггер с приоритетом включения
Детектор переднего фронта импульса (RTRIG)
Детектор заднего фронта импульса (FTRIG)
D-триггер (DTRIG)
Таймеры
Импульс включения заданной длительности (TP)
Таймер с задержкой включения (TON)
Таймер с задержкой отключения (TOF)
Интервальный таймер (CLOCK)
Интервальный таймер с недельным циклом (CLOCKWEEK)
Генераторы
Генератор прямоугольных импульсов (BLINK)
Счетчики
Инкрементный счетчик с автосбросом (CT)
Универсальный счетчик (CTN)
Инкрементный счетчик (CTU)
Регуляторы
ПИД-регулятор (PID)
Макросы
Работа с макросами
Элементы управления
Метка
Ввод/Вывод (int/float)
Ввод/Вывод (boolean)
Динамический текст
Комбинированный список (ComboBox)
1


OWEN Logic (версия 1.12)
Руководство пользователя
1.13